aboutsummaryrefslogtreecommitdiffstats
path: root/packages/openmoko-base
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2007-03-28 15:09:53 +0000
committerKoen Kooi <koen@openembedded.org>2007-03-28 15:09:53 +0000
commit8cbb367f96dd5826c03d10a9ec8abadf0073f717 (patch)
tree6e7faa3bdf5d2f1c208f4c5ecaa5622c511e5e78 /packages/openmoko-base
parentb2fb28dbc919753212298bd283c118d6f1aea086 (diff)
downloadopenembedded-8cbb367f96dd5826c03d10a9ec8abadf0073f717.tar.gz
openmoko: add qvga theme and mark themes as arch agnostic
Diffstat (limited to 'packages/openmoko-base')
-rw-r--r--packages/openmoko-base/openmoko-theme-standard-qvga_svn.bb25
-rw-r--r--packages/openmoko-base/openmoko-theme-standard_svn.bb3
2 files changed, 27 insertions, 1 deletions
diff --git a/packages/openmoko-base/openmoko-theme-standard-qvga_svn.bb b/packages/openmoko-base/openmoko-theme-standard-qvga_svn.bb
new file mode 100644
index 0000000000..0c19db77ac
--- /dev/null
+++ b/packages/openmoko-base/openmoko-theme-standard-qvga_svn.bb
@@ -0,0 +1,25 @@
+DESCRIPTION = "Standard Gtk+ theme for the OpenMoko distribution, qvga version"
+SECTION = "openmoko/base"
+PV = "0.0+svn${SRCDATE}"
+PR = "r0"
+
+inherit openmoko-base
+
+SRC_URI = "${OPENMOKO_MIRROR}/src/target/${OPENMOKO_RELEASE}/artwork;module=themes;proto=http"
+S = "${WORKDIR}"
+
+dirs = "themes/openmoko-standard"
+
+do_install() {
+ find ${WORKDIR} -name ".svn" | xargs rm -rf
+ install -d ${D}${datadir}/themes/
+ for i in ${dirs}; do
+ cp -fpPR ${WORKDIR}/$i ${D}${datadir}/themes/
+ done
+
+ install -d ${D}${sysconfdir}/gtk-2.0
+ echo 'include "${datadir}/themes/openmoko-standard-qvga/gtk-2.0/gtkrc"' >> ${D}${sysconfdir}/gtk-2.0/gtkrc
+}
+
+PACKAGE_ARCH = "all"
+FILES_${PN} = "${datadir} ${sysconfdir}"
diff --git a/packages/openmoko-base/openmoko-theme-standard_svn.bb b/packages/openmoko-base/openmoko-theme-standard_svn.bb
index e7a6def235..6265526de6 100644
--- a/packages/openmoko-base/openmoko-theme-standard_svn.bb
+++ b/packages/openmoko-base/openmoko-theme-standard_svn.bb
@@ -1,7 +1,7 @@
DESCRIPTION = "Standard Gtk+ theme for the OpenMoko distribution"
SECTION = "openmoko/base"
PV = "0.0+svn${SRCDATE}"
-PR = "r3"
+PR = "r4"
inherit openmoko-base
@@ -21,4 +21,5 @@ do_install() {
echo 'include "${datadir}/themes/openmoko-standard/gtk-2.0/gtkrc"' >> ${D}${sysconfdir}/gtk-2.0/gtkrc
}
+PACKAGE_ARCH = "all"
FILES_${PN} = "${datadir} ${sysconfdir}"