aboutsummaryrefslogtreecommitdiffstats
path: root/packages/openmoko-tools
diff options
context:
space:
mode:
authorHolger Hans Peter Freyther <zecke@openmoko.org>2008-08-06 02:38:34 +0200
committerHolger Hans Peter Freyther <zecke@selfish.org>2008-10-28 22:48:38 +0100
commit12e84f237f6340e2688415dba8bb3204021a38f3 (patch)
treee98a96fadb9be3cfc37817af30b319aaabc49134 /packages/openmoko-tools
parentcae3aa1ba13e84dc8897111e16efc9d9ac58d6c8 (diff)
downloadopenembedded-12e84f237f6340e2688415dba8bb3204021a38f3.tar.gz
openmoko: Add a Gtk+ utility to set the root password
This utility will be installable through the feed.
Diffstat (limited to 'packages/openmoko-tools')
-rw-r--r--packages/openmoko-tools/openmoko-set-root-password.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/packages/openmoko-tools/openmoko-set-root-password.bb b/packages/openmoko-tools/openmoko-set-root-password.bb
new file mode 100644
index 0000000000..a521a1fd6d
--- /dev/null
+++ b/packages/openmoko-tools/openmoko-set-root-password.bb
@@ -0,0 +1,25 @@
+DESCRIPTION = "Set the root password."
+SUMMARY = "On installation you will be prompted to set a root password. With \
+this password you can then log into the machine."
+LICENSE = "GPL"
+DEPENDS = "gtk+"
+PKG_TAGS_${PN} = "group::programming"
+
+SRC_URI = "svn://svn.openmoko.org/developers/zecke/;module=root-password;proto=http"
+S = "${WORKDIR}/root-password"
+PV = "1.0+svn${SRCREV}"
+
+do_compile () {
+ cd ${S}
+ oe_runmake
+}
+
+do_install() {
+ install -d ${D}/${sbindir}
+ install -m 0755 ${S}/root-password ${D}/${sbindir}/${PN}
+}
+
+pkg_postinst_${PN} () {
+ # assume we use display 0
+ DISPLAY=:0 ${sbindir}/${PN}
+}