aboutsummaryrefslogtreecommitdiffstats
path: root/packages/openmoko-tools
diff options
context:
space:
mode:
authorJohn Lee <john_lee@openmoko.org>2008-05-14 10:37:49 +0000
committerJohn Lee <john_lee@openmoko.org>2008-12-18 23:05:55 +0800
commitfd1aaa7cb993049e1eb3503c5fd932e74b667999 (patch)
tree1c3eca8d935a30b5adea16ad7db8d61c2ccfea06 /packages/openmoko-tools
parent73f61225efed9f3af1a1f5f3d491aa5e87f2641f (diff)
downloadopenembedded-fd1aaa7cb993049e1eb3503c5fd932e74b667999.tar.gz
openmoko-toolchain-scripts: bugfix ${S}, change directory.
* fix ${S} * set PACKAGE_ARCH to "all" * move to openmoko-tools. one less directory.
Diffstat (limited to 'packages/openmoko-tools')
-rw-r--r--packages/openmoko-tools/openmoko-toolchain-scripts_svn.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/packages/openmoko-tools/openmoko-toolchain-scripts_svn.bb b/packages/openmoko-tools/openmoko-toolchain-scripts_svn.bb
new file mode 100644
index 0000000000..e30d66b58a
--- /dev/null
+++ b/packages/openmoko-tools/openmoko-toolchain-scripts_svn.bb
@@ -0,0 +1,22 @@
+DESCRIPTION = "Convenient scripts to be used with openmoko toolchain."
+
+PV = "0.0+svnr${SRCREV}"
+PE = "1"
+PR = "r1"
+
+SRC_URI = "svn://svn.openmoko.org/trunk/src/host;module=toolchain-scripts;proto=http"
+
+S = "${WORKDIR}/toolchain-scripts"
+
+do_install () {
+ install -d ${D}/${prefix}
+ cp -dr ${S}/* ${D}/${prefix}
+ find ${D} -name ".svn" | xargs rm -rf
+ rm -rf ${D}/${prefix}/patches
+}
+
+PACKAGE_ARCH = "all"
+
+FILES_${PN} = "/*"
+
+inherit sdk