aboutsummaryrefslogtreecommitdiffstats
path: root/packages/openobex
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2007-07-19 13:19:16 +0000
committerKoen Kooi <koen@openembedded.org>2007-07-19 13:19:16 +0000
commitb72ab51b5c17755d62d482c2ebf523368f7000b4 (patch)
tree4d66f84a8e2db06eed78d10c0112b0246a945198 /packages/openobex
parent210096920c0f9f51df535cdce94f0592b8e2492c (diff)
downloadopenembedded-b72ab51b5c17755d62d482c2ebf523368f7000b4.tar.gz
openobex: update to 1.3
Diffstat (limited to 'packages/openobex')
-rw-r--r--packages/openobex/openobex-1.3/.mtn2git_empty0
-rw-r--r--packages/openobex/openobex-1.3/libusb_crosscompile_check.patch11
-rw-r--r--packages/openobex/openobex_1.2.bb2
-rw-r--r--packages/openobex/openobex_1.3.bb33
4 files changed, 45 insertions, 1 deletions
diff --git a/packages/openobex/openobex-1.3/.mtn2git_empty b/packages/openobex/openobex-1.3/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/openobex/openobex-1.3/.mtn2git_empty
diff --git a/packages/openobex/openobex-1.3/libusb_crosscompile_check.patch b/packages/openobex/openobex-1.3/libusb_crosscompile_check.patch
new file mode 100644
index 0000000000..ca5bc0041a
--- /dev/null
+++ b/packages/openobex/openobex-1.3/libusb_crosscompile_check.patch
@@ -0,0 +1,11 @@
+--- /tmp/acinclude.m4 2007-07-19 15:11:49.000000000 +0200
++++ openobex-1.3/acinclude.m4 2007-07-19 15:13:06.925215000 +0200
+@@ -128,7 +128,7 @@
+
+ if (test "${usb_enable}" = "yes" && test "${usb_found}" = "yes"); then
+ AC_DEFINE(HAVE_USB, 1, [Define if system supports USB and it's enabled])
+- AC_CHECK_FILE(${prefix}/lib/pkgconfig/libusb.pc, REQUIRES="$REQUIRES libusb")
++ REQUIRES="libusb"
+ fi
+
+ AM_CONDITIONAL(APPS, test "${apps_enable}" = "yes")
diff --git a/packages/openobex/openobex_1.2.bb b/packages/openobex/openobex_1.2.bb
index e6ec335978..358415d9b0 100644
--- a/packages/openobex/openobex_1.2.bb
+++ b/packages/openobex/openobex_1.2.bb
@@ -8,7 +8,7 @@ LICENSE = "GPL"
PR = "r5"
SRC_URI = "${SOURCEFORGE_MIRROR}/openobex/openobex-${PV}.tar.gz \
- file://disable-cable-test.patch;patch=1" \
+ file://disable-cable-test.patch;patch=1 \
file://libusb_crosscompile_check.patch;patch=1"
inherit autotools binconfig pkgconfig
diff --git a/packages/openobex/openobex_1.3.bb b/packages/openobex/openobex_1.3.bb
new file mode 100644
index 0000000000..606f8de1c3
--- /dev/null
+++ b/packages/openobex/openobex_1.3.bb
@@ -0,0 +1,33 @@
+DESCRIPTION = "The Openobex project is an open source implementation of the \
+Object Exchange (OBEX) protocol."
+HOMEPAGE = "http://openobex.triq.net"
+SECTION = "libs"
+PROVIDES = "openobex-apps"
+DEPENDS = "libusb bluez-libs"
+LICENSE = "GPL"
+PR = "r0"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/openobex/openobex-${PV}.tar.gz \
+ file://disable-cable-test.patch;patch=1 \
+ file://libusb_crosscompile_check.patch;patch=1"
+
+inherit autotools binconfig pkgconfig
+
+EXTRA_OECONF = "--enable-apps --enable-syslog --enable-dump \
+ --with-usb=${STAGING_LIBDIR}/.. --with-bluez=${STAGING_LIBDIR}/.."
+
+do_stage() {
+ oe_libinstall -so -C lib libopenobex ${STAGING_LIBDIR}
+ ln -sf libopenobex.so ${STAGING_LIBDIR}/libopenobex-1.2.so
+ install -d ${STAGING_INCDIR}/openobex
+ install -m 0644 include/*.h ${STAGING_INCDIR}/openobex/
+ install -d ${STAGING_DIR}/aclocal
+ install -m 0644 openobex.m4 ${STAGING_DATADIR}/aclocal/
+}
+
+# how to stop shlibrename from renaming -apps?
+PACKAGES += "openobex-apps"
+FILES_${PN} = "${libdir}/lib*.so.*"
+FILES_${PN}-dev += "${bindir}/openobex-config"
+FILES_${PN}-apps = "${bindir}/*"
+DEBIAN_NOAUTONAME_${PN}-apps = "1"