aboutsummaryrefslogtreecommitdiffstats
path: root/packages/opensp
diff options
context:
space:
mode:
authorJamie Lenehan <lenehan@twibble.org>2007-06-02 02:34:13 +0000
committerJamie Lenehan <lenehan@twibble.org>2007-06-02 02:34:13 +0000
commitddfb2e6db7b335af89f62d95678af54b17890784 (patch)
tree62f6be542b3d02a8262e14d9aea826edc6f94212 /packages/opensp
parent4e77b23d9562625103d354ac324539d61c6bad26 (diff)
downloadopenembedded-ddfb2e6db7b335af89f62d95678af54b17890784.tar.gz
opensp 1.5: Fix compile issues with various compilers, fix from
opensp cvs and also as specified in bug #301. Tested with gcc 3.4.4 and 4.1.2 for both opensp and opensp-native. Fixes #301 and #2366.
Diffstat (limited to 'packages/opensp')
-rw-r--r--packages/opensp/opensp-1.5/rangmap-fix.patch12
-rw-r--r--packages/opensp/opensp_1.5.bb5
2 files changed, 16 insertions, 1 deletions
diff --git a/packages/opensp/opensp-1.5/rangmap-fix.patch b/packages/opensp/opensp-1.5/rangmap-fix.patch
new file mode 100644
index 0000000000..55c00a8f08
--- /dev/null
+++ b/packages/opensp/opensp-1.5/rangmap-fix.patch
@@ -0,0 +1,12 @@
+Index: OpenSP-1.5/include/RangeMap.cxx
+===================================================================
+--- OpenSP-1.5.orig/include/RangeMap.cxx 2000-02-26 03:55:21.000000000 +1100
++++ OpenSP-1.5/include/RangeMap.cxx 2007-06-02 11:48:17.000000000 +1000
+@@ -7,6 +7,7 @@
+ #include "RangeMap.h"
+ #include "ISet.h"
+ #include "types.h"
++#include "constant.h"
+
+ #ifdef SP_NAMESPACE
+ namespace SP_NAMESPACE {
diff --git a/packages/opensp/opensp_1.5.bb b/packages/opensp/opensp_1.5.bb
index 5d6ad639af..de28a5f552 100644
--- a/packages/opensp/opensp_1.5.bb
+++ b/packages/opensp/opensp_1.5.bb
@@ -3,9 +3,12 @@ DESCRIPTION = "OpenSP is a library and a set of tools \
for validating, parsing, and manipulating SGML and \
XML documents."
LICENSE = "MIT"
+PR = "r1"
+
SRC_URI = "${SOURCEFORGE_MIRROR}/openjade/OpenSP-${PV}.tar.gz \
file://m4.patch;patch=1 \
- file://attributevalue.patch;patch=1"
+ file://attributevalue.patch;patch=1 \
+ file://rangmap-fix.patch;patch=1"
S = "${WORKDIR}/OpenSP-${PV}"
inherit autotools