aboutsummaryrefslogtreecommitdiffstats
path: root/packages/openssl
diff options
context:
space:
mode:
authorJeremy Laine <jeremy.laine@m4x.org>2008-05-12 19:29:18 +0000
committerJeremy Laine <jeremy.laine@m4x.org>2008-05-12 19:29:18 +0000
commit11e808cd7b8470ff63b74126bb13eba69f725f78 (patch)
treeba798ff31eb169d5d78059dee94d14339bada42e /packages/openssl
parent98269dda52518038cda6293eedb54c2538c1358d (diff)
downloadopenembedded-11e808cd7b8470ff63b74126bb13eba69f725f78.tar.gz
openssl.inc: fix openssl 0.9.8 builds for x86 targets
* split do_compile() into do do_configure() and do_compile() * don't clobber CFLAG by exporting it: edit Configure script to set the machine-specific flags, and let the Configure script append feature-based flags * don't use linux-pentium and linux-ppro, they got dropped in openssl 0.9.8, use the Debian machine definitions instead
Diffstat (limited to 'packages/openssl')
-rw-r--r--packages/openssl/openssl-native_0.9.7g.bb2
-rw-r--r--packages/openssl/openssl-native_0.9.7m.bb2
-rw-r--r--packages/openssl/openssl.inc23
-rw-r--r--packages/openssl/openssl_0.9.7e.bb2
-rw-r--r--packages/openssl/openssl_0.9.7g.bb2
-rw-r--r--packages/openssl/openssl_0.9.7m.bb2
-rw-r--r--packages/openssl/openssl_0.9.8g.bb2
7 files changed, 19 insertions, 16 deletions
diff --git a/packages/openssl/openssl-native_0.9.7g.bb b/packages/openssl/openssl-native_0.9.7g.bb
index 115d4011d9..f48e123152 100644
--- a/packages/openssl/openssl-native_0.9.7g.bb
+++ b/packages/openssl/openssl-native_0.9.7g.bb
@@ -2,7 +2,7 @@ inherit pkgconfig native
require openssl.inc
-PR = "r1"
+PR = "r2"
SRC_URI += "file://debian.patch;patch=1 \
file://armeb.patch;patch=1;pnum=0 \
diff --git a/packages/openssl/openssl-native_0.9.7m.bb b/packages/openssl/openssl-native_0.9.7m.bb
index 115d4011d9..f48e123152 100644
--- a/packages/openssl/openssl-native_0.9.7m.bb
+++ b/packages/openssl/openssl-native_0.9.7m.bb
@@ -2,7 +2,7 @@ inherit pkgconfig native
require openssl.inc
-PR = "r1"
+PR = "r2"
SRC_URI += "file://debian.patch;patch=1 \
file://armeb.patch;patch=1;pnum=0 \
diff --git a/packages/openssl/openssl.inc b/packages/openssl/openssl.inc
index 9fb8b343b6..b77fda9a5b 100644
--- a/packages/openssl/openssl.inc
+++ b/packages/openssl/openssl.inc
@@ -7,11 +7,12 @@ SRC_URI = "http://www.openssl.org/source/openssl-${PV}.tar.gz"
S = "${WORKDIR}/openssl-${PV}"
AR_append = " r"
-export CFLAG = "-fPIC -DTHREADS -D_REENTRANT -DDSO_DLFCN -DHAVE_DLFCN_H -DTERMIO -Wall ${FULL_OPTIMIZATION}"
+CFLAG = "${@base_conditional('SITEINFO_ENDIANESS', 'le', '-DL_ENDIAN', '-DB_ENDIAN', d)} \
+ -DTERMIO ${FULL_OPTIMIZATION} -Wall"
# -02 does not work on mipsel: ssh hangs when it tries to read /dev/urandom
-export CFLAG_mtx-1 := "${@'${CFLAG}'.replace('-O2', '')}"
-export CFLAG_mtx-2 := "${@'${CFLAG}'.replace('-O2', '')}"
+CFLAG_mtx-1 := "${@'${CFLAG}'.replace('-O2', '')}"
+CFLAG_mtx-2 := "${@'${CFLAG}'.replace('-O2', '')}"
export DIRS = "crypto ssl apps"
export EX_LIBS = "-lgcc -ldl"
@@ -21,15 +22,12 @@ PACKAGES =+ "libcrypto libssl"
FILES_libcrypto = "${libdir}/libcrypto.so.*"
FILES_libssl = "${libdir}/libssl.so.*"
-do_compile () {
+do_configure () {
cd util
perl perlpath.pl ${bindir}
cd ..
ln -sf apps/openssl.pod crypto/crypto.pod ssl/ssl.pod doc/
- # Additional flag based on target endiness (see siteinfo.bbclass)
- CFLAG="${CFLAG} ${@base_conditional('SITEINFO_ENDIANESS', 'le', '-DL_ENDIAN', '-DB_ENDIAN', d)}"
-
os=${HOST_OS}
if [ "x$os" = "xlinux-uclibc" ]; then
os=linux
@@ -49,13 +47,13 @@ do_compile () {
target=debian-sh4
;;
linux-i486)
- target=linux-pentium
+ target=debian-i386-i486
;;
linux-i586)
- target=linux-pentium
+ target=debian-i386-i586
;;
linux-i686)
- target=linux-ppro
+ target=debian-i386-i686/cmov
;;
linux-powerpc)
target=linux-ppc
@@ -67,7 +65,12 @@ do_compile () {
target=linux-sparcv8
;;
esac
+ # inject machine-specific flags
+ sed -i -e "s|^\(\"$target\",\s*\"[^:]\+\):\([^:]\+\)|\1:${CFLAG}|g" Configure
perl ./Configure shared --prefix=${prefix} --openssldir=${libdir}/ssl $target
+}
+
+do_compile () {
oe_runmake
}
diff --git a/packages/openssl/openssl_0.9.7e.bb b/packages/openssl/openssl_0.9.7e.bb
index a7d3670758..cda364a53d 100644
--- a/packages/openssl/openssl_0.9.7e.bb
+++ b/packages/openssl/openssl_0.9.7e.bb
@@ -1,6 +1,6 @@
require openssl.inc
-PR = "r5"
+PR = "r6"
SRC_URI += "file://debian.patch;patch=1 \
file://armeb.patch;patch=1 \
diff --git a/packages/openssl/openssl_0.9.7g.bb b/packages/openssl/openssl_0.9.7g.bb
index 3a420001c9..fbd2af26f9 100644
--- a/packages/openssl/openssl_0.9.7g.bb
+++ b/packages/openssl/openssl_0.9.7g.bb
@@ -2,7 +2,7 @@ inherit pkgconfig
require openssl.inc
-PR = "r6"
+PR = "r7"
SRC_URI += "file://debian.patch;patch=1 \
file://armeb.patch;patch=1;pnum=0 \
diff --git a/packages/openssl/openssl_0.9.7m.bb b/packages/openssl/openssl_0.9.7m.bb
index 3a420001c9..fbd2af26f9 100644
--- a/packages/openssl/openssl_0.9.7m.bb
+++ b/packages/openssl/openssl_0.9.7m.bb
@@ -2,7 +2,7 @@ inherit pkgconfig
require openssl.inc
-PR = "r6"
+PR = "r7"
SRC_URI += "file://debian.patch;patch=1 \
file://armeb.patch;patch=1;pnum=0 \
diff --git a/packages/openssl/openssl_0.9.8g.bb b/packages/openssl/openssl_0.9.8g.bb
index 133283f0f8..ed99d264f4 100644
--- a/packages/openssl/openssl_0.9.8g.bb
+++ b/packages/openssl/openssl_0.9.8g.bb
@@ -2,7 +2,7 @@ inherit pkgconfig
require openssl.inc
-PR = "r7"
+PR = "r8"
SRC_URI += "file://debian.patch;patch=1 \
file://configure-targets.patch;patch=1 \