aboutsummaryrefslogtreecommitdiffstats
path: root/packages/opie-mediaplayer1
diff options
context:
space:
mode:
authorPaul Eggleton <bluelightning@bluelightning.org>2008-10-05 01:05:09 +0000
committerPaul Eggleton <bluelightning@bluelightning.org>2008-10-05 01:05:09 +0000
commitb145ccf20e4595ad1dccb2d04aa401c20a968aaf (patch)
tree59e87a6c28d8bfbc9ba2d96271a0f9ded10376cc /packages/opie-mediaplayer1
parenteb2b188670508a81464f0e308178619bc0593501 (diff)
downloadopenembedded-b145ccf20e4595ad1dccb2d04aa401c20a968aaf.tar.gz
opie-mediaplayer1: fix compile error (fixes bug #4624)
Diffstat (limited to 'packages/opie-mediaplayer1')
-rw-r--r--packages/opie-mediaplayer1/files/.mtn2git_empty0
-rw-r--r--packages/opie-mediaplayer1/files/double_name.patch11
-rw-r--r--packages/opie-mediaplayer1/opie-mediaplayer1-core_1.2.4.bb4
3 files changed, 13 insertions, 2 deletions
diff --git a/packages/opie-mediaplayer1/files/.mtn2git_empty b/packages/opie-mediaplayer1/files/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/opie-mediaplayer1/files/.mtn2git_empty
diff --git a/packages/opie-mediaplayer1/files/double_name.patch b/packages/opie-mediaplayer1/files/double_name.patch
new file mode 100644
index 0000000000..d4e787f7f9
--- /dev/null
+++ b/packages/opie-mediaplayer1/files/double_name.patch
@@ -0,0 +1,11 @@
+--- opieplayer/mediaplayerplugininterface.h 3 Mar 2002 17:13:17 -0000 1.5
++++ opieplayer/mediaplayerplugininterface.h 4 Oct 2008 16:45:38 -0000 1.6
+@@ -65,7 +65,7 @@
+ virtual int audioSamples( int stream ) = 0;
+ virtual bool audioSetSample( long sample, int stream ) = 0;
+ virtual long audioGetSample( int stream ) = 0;
+- virtual bool audioReadSamples( short *samples, int channels, long samples, long& samplesRead, int stream ) = 0;
++ virtual bool audioReadSamples( short *output, int channels, long samples, long& samplesRead, int stream ) = 0;
+
+ // If decoder doesn't support video then return 0 here
+ virtual int videoStreams() = 0;
diff --git a/packages/opie-mediaplayer1/opie-mediaplayer1-core_1.2.4.bb b/packages/opie-mediaplayer1/opie-mediaplayer1-core_1.2.4.bb
index ca0beacb47..db194b9a37 100644
--- a/packages/opie-mediaplayer1/opie-mediaplayer1-core_1.2.4.bb
+++ b/packages/opie-mediaplayer1/opie-mediaplayer1-core_1.2.4.bb
@@ -2,5 +2,5 @@ require ${PN}.inc
SRC_URI = "${HANDHELDS_CVS};tag=${TAG};module=opie/core/multimedia/opieplayer \
${HANDHELDS_CVS};tag=${TAG};module=opie/pics \
- ${HANDHELDS_CVS};tag=${TAG};module=opie/apps"
-
+ ${HANDHELDS_CVS};tag=${TAG};module=opie/apps \
+ file://double_name.patch;patch=1"