aboutsummaryrefslogtreecommitdiffstats
path: root/packages/opie-taskbar
diff options
context:
space:
mode:
authorPaul Sokolovsky <pmiscml@gmail.com>2007-07-05 19:30:26 +0000
committerPaul Sokolovsky <pmiscml@gmail.com>2007-07-05 19:30:26 +0000
commit9c5576a8fb44075d861255398c42c419c4f1cca2 (patch)
tree4051c091aeaed3224ee2d3e1b92e6bccf1f9e45c /packages/opie-taskbar
parent2f15c6d489ead5d531bee206829a1a5b4821dce2 (diff)
downloadopenembedded-9c5576a8fb44075d861255398c42c419c4f1cca2.tar.gz
opie-taskbar-images: Don't package images to machine-dependent file, instead
package to separate packages for each reolution (otherwise, machine independent). Then, some higher-level task (task-opie) will select need package for specific machine. User still will be able to install another package fwiw, or even multiple (for example, to have nice wallpaper across screen rotations, but this of course will need runtime support).
Diffstat (limited to 'packages/opie-taskbar')
-rw-r--r--packages/opie-taskbar/opie-taskbar-images.inc24
-rw-r--r--packages/opie-taskbar/opie-taskbar-images_cvs.bb2
-rw-r--r--packages/opie-taskbar/opie-taskbar.inc6
3 files changed, 25 insertions, 7 deletions
diff --git a/packages/opie-taskbar/opie-taskbar-images.inc b/packages/opie-taskbar/opie-taskbar-images.inc
index dafffe59f0..f3cef44835 100644
--- a/packages/opie-taskbar/opie-taskbar-images.inc
+++ b/packages/opie-taskbar/opie-taskbar-images.inc
@@ -2,7 +2,7 @@ DESCRIPTION = "Opie Launcher and Taskbar"
SECTION = "opie/base"
PRIORITY = "optional"
LICENSE = "GPL"
-DEPENDS = "opie-libqrsync opie-qss"
+RPROVIDES = "${PN}"
APPNAME = "qpe"
S = "${WORKDIR}/launcher"
@@ -18,15 +18,29 @@ PIXMAP_SIZE_asus730 = "-480x640"
PIXMAP_SIZE_htcuniversal= "-480x640"
PIXMAP_SIZE_hx4700 = "-480x640"
+PACKAGES = "${PN}-480x640 ${PN}-640x480 ${PN}-800x600 ${PN}-240x320"
+
#inherit opie
do_install() {
install -d ${D}${palmtopdir}/pics/launcher
- install -m 0644 ${WORKDIR}/pics/launcher/firstuse${PIXMAP_SIZE}.jpg ${D}${palmtopdir}/pics/launcher/firstuse.jpg
- install -m 0644 ${WORKDIR}/pics/launcher/opie-background${PIXMAP_SIZE}.jpg ${D}${palmtopdir}/pics/launcher/opie-background.jpg
+ install -m 0644 ${WORKDIR}/pics/launcher/firstuse.jpg ${D}${palmtopdir}/pics/launcher/firstuse-240x320.jpg
+ install -m 0644 ${WORKDIR}/pics/launcher/opie-background.jpg ${D}${palmtopdir}/pics/launcher/opie-background-240x320.jpg
+
+ install -m 0644 ${WORKDIR}/pics/launcher/firstuse-480x640.jpg ${D}${palmtopdir}/pics/launcher/firstuse-480x640.jpg
+ install -m 0644 ${WORKDIR}/pics/launcher/opie-background-480x640.jpg ${D}${palmtopdir}/pics/launcher/opie-background-480x640.jpg
+
+ install -m 0644 ${WORKDIR}/pics/launcher/firstuse-640x480.jpg ${D}${palmtopdir}/pics/launcher/firstuse-640x480.jpg
+ install -m 0644 ${WORKDIR}/pics/launcher/opie-background-640x480.jpg ${D}${palmtopdir}/pics/launcher/opie-background-640x480.jpg
+
+ install -m 0644 ${WORKDIR}/pics/launcher/firstuse-800x600.jpg ${D}${palmtopdir}/pics/launcher/firstuse-800x600.jpg
+ install -m 0644 ${WORKDIR}/pics/launcher/opie-background-800x600.jpg ${D}${palmtopdir}/pics/launcher/opie-background-800x600.jpg
}
-FILES_${PN} += " ${palmtopdir}/pics"
+FILES_${PN}-240x320 += " ${palmtopdir}/pics/*/*-240x320.*"
+FILES_${PN}-480x640 += " ${palmtopdir}/pics/*/*-480x640.*"
+FILES_${PN}-640x480 += " ${palmtopdir}/pics/*/*-640x480.*"
+FILES_${PN}-800x600 += " ${palmtopdir}/pics/*/*-800x600.*"
-PACKAGE_ARCH = "${MACHINE_ARCH}"
+PACKAGE_ARCH = "all"
diff --git a/packages/opie-taskbar/opie-taskbar-images_cvs.bb b/packages/opie-taskbar/opie-taskbar-images_cvs.bb
index 0f1854b9d0..0566431474 100644
--- a/packages/opie-taskbar/opie-taskbar-images_cvs.bb
+++ b/packages/opie-taskbar/opie-taskbar-images_cvs.bb
@@ -1,5 +1,5 @@
require ${PN}.inc
PV = "${OPIE_CVS_PV}"
-PR = "r2"
+PR = "r3"
SRC_URI = "${HANDHELDS_CVS};module=opie/pics"
diff --git a/packages/opie-taskbar/opie-taskbar.inc b/packages/opie-taskbar/opie-taskbar.inc
index 14f4ed0318..4f43e550b9 100644
--- a/packages/opie-taskbar/opie-taskbar.inc
+++ b/packages/opie-taskbar/opie-taskbar.inc
@@ -3,7 +3,11 @@ SECTION = "opie/base"
PRIORITY = "optional"
LICENSE = "GPL"
DEPENDS = "opie-libqrsync opie-qss"
-RDEPENDS = "opie-taskbar-images"
+# Unfortunately, ipkg has buggy handling of Rdepends to multiple packages with the same Provides.
+# Instead of seeing if something in package package lists selects needed package among the rest
+# or errors out otherwise, it just install random package which has needed Provides. So, comment
+# this out.
+#RDEPENDS = "opie-taskbar-images"
APPNAME = "qpe"
S = "${WORKDIR}/launcher"