aboutsummaryrefslogtreecommitdiffstats
path: root/packages/opie-theme
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2005-06-30 08:19:37 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-06-30 08:19:37 +0000
commitc8e5702127e507e82e6f68a4b8c546803accea9d (patch)
tree00583491f40ecc640f2b28452af995e3a63a09d7 /packages/opie-theme
parent87ec8ca4d2e2eb4d1c1e1e1a6b46a395d56805b9 (diff)
downloadopenembedded-c8e5702127e507e82e6f68a4b8c546803accea9d.tar.gz
import clean BK tree at cset 1.3670
Diffstat (limited to 'packages/opie-theme')
-rw-r--r--packages/opie-theme/.mtn2git_empty0
-rw-r--r--packages/opie-theme/opie-theme.inc45
-rw-r--r--packages/opie-theme/opie-theme_1.2.0.bb7
3 files changed, 52 insertions, 0 deletions
diff --git a/packages/opie-theme/.mtn2git_empty b/packages/opie-theme/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/opie-theme/.mtn2git_empty
diff --git a/packages/opie-theme/opie-theme.inc b/packages/opie-theme/opie-theme.inc
index e69de29bb2..7614953d21 100644
--- a/packages/opie-theme/opie-theme.inc
+++ b/packages/opie-theme/opie-theme.inc
@@ -0,0 +1,45 @@
+DESCRIPTION = "Themed style"
+SECTION = "opie/styles"
+PRIORITY = "optional"
+MAINTAINER = "Team Opie <opie@handhelds.org>"
+LICENSE = "GPL"
+APPNAME = "theme"
+
+
+S = "${WORKDIR}/${APPNAME}"
+
+inherit opie
+
+# FILES plugins/styles/libtheme.so*
+do_install() {
+ install -d ${D}${palmtopdir}/plugins/styles/pixmaps/
+ install -d ${D}${palmtopdir}/plugins/styles/themes/
+ for t in cleannsimple GradE8 ixpe luna
+ do
+ install -d ${D}${palmtopdir}/plugins/styles/pixmaps/$t/
+ for f in ../styles/pixmaps/$t/*
+ do
+ [ -f $f ] && install -m 0644 $f ${D}${palmtopdir}/plugins/styles/pixmaps/$t/
+ done
+ install -m 0644 ../styles/themes/$t.themerc ${D}${palmtopdir}/plugins/styles/themes/
+ done
+ for t in lumonmarble lumonwave
+ do
+ install -d ${D}${palmtopdir}/plugins/styles/pixmaps/lumon/
+ for f in ../styles/pixmaps/lumon/*
+ do
+ [ -f $f ] && install -m 0644 $f ${D}${palmtopdir}/plugins/styles/pixmaps/lumon/
+ done
+ install -m 0644 ../styles/themes/$t.themerc ${D}${palmtopdir}/plugins/styles/themes/
+ done
+}
+
+PACKAGES = " opie-theme-cleannsimple opie-theme-grade8 opie-theme-ixpe opie-theme-lumonmarble opie-theme-lumonwave opie-theme-luna opie-theme "
+
+FILES_opie-theme = " ${palmtopdir}/plugins/styles/libtheme.so*"
+FILES_opie-theme-cleannsimple = " ${palmtopdir}/plugins/styles/themes/cleannsimple.themerc ${palmtopdir}/plugins/styles/pixmaps/cleannsimple/*.png"
+FILES_opie-theme-grade8 = " ${palmtopdir}/plugins/styles/themes/GradE8.themerc ${palmtopdir}/plugins/styles/pixmaps/GradE8/*.png"
+FILES_opie-theme-ixpe = " ${palmtopdir}/plugins/styles/themes/ixpe.themerc ${palmtopdir}/plugins/styles/pixmaps/ixpe/*.png"
+FILES_opie-theme-lumonmarble = " ${palmtopdir}/plugins/styles/themes/lumonmarble.themerc ${palmtopdir}/plugins/styles/pixmaps/lumon/arrowdown.png ${palmtopdir}/plugins/styles/pixmaps/lumon/arrowleft.png ${palmtopdir}/plugins/styles/pixmaps/lumon/arrowright.png ${palmtopdir}/plugins/styles/pixmaps/lumon/arrowup.png ${palmtopdir}/plugins/styles/pixmaps/lumon/backgroundwhitemarble.png ${palmtopdir}/plugins/styles/pixmaps/lumon/backgroundbluemarble.png ${palmtopdir}/plugins/styles/pixmaps/lumon/button.png ${palmtopdir}/plugins/styles/pixmaps/lumon/buttonborder.png ${palmtopdir}/plugins/styles/pixmaps/lumon/buttonborderdown.png ${palmtopdir}/plugins/styles/pixmaps/lumon/buttondown.png ${palmtopdir}/plugins/styles/pixmaps/lumon/checkbox.png ${palmtopdir}/plugins/styles/pixmaps/lumon/checkboxdown.png ${palmtopdir}/plugins/styles/pixmaps/lumon/hscrollgroove.png ${palmtopdir}/plugins/styles/pixmaps/lumon/menubar.png ${palmtopdir}/plugins/styles/pixmaps/lumon/menuitemdown.png ${palmtopdir}/plugins/styles/pixmaps/lumon/radio.png ${palmtopdir}/plugins/styles/pixmaps/lumon/radiodown.png ${palmtopdir}/plugins/styles/pixmaps/lumon/scrollbutton.png ${palmtopdir}/plugins/styles/pixmaps/lumon/sunkenarrowdown.png ${palmtopdir}/plugins/styles/pixmaps/lumon/sunkenarrowleft.png ${palmtopdir}/plugins/styles/pixmaps/lumon/sunkenarrowright.png ${palmtopdir}/plugins/styles/pixmaps/lumon/sunkenarrowup.png ${palmtopdir}/plugins/styles/pixmaps/lumon/tab.png ${palmtopdir}/plugins/styles/pixmaps/lumon/tabdown.png ${palmtopdir}/plugins/styles/pixmaps/lumon/vscrollgroove.png"
+FILES_opie-theme-lumonwave = " ${palmtopdir}/plugins/styles/themes/lumonwave.themerc ${palmtopdir}/plugins/styles/pixmaps/lumon/arrowdown.png ${palmtopdir}/plugins/styles/pixmaps/lumon/arrowleft.png ${palmtopdir}/plugins/styles/pixmaps/lumon/arrowright.png ${palmtopdir}/plugins/styles/pixmaps/lumon/arrowup.png ${palmtopdir}/plugins/styles/pixmaps/lumon/backgroundwave.png ${palmtopdir}/plugins/styles/pixmaps/lumon/backgroundwaveblue.png ${palmtopdir}/plugins/styles/pixmaps/lumon/button.png ${palmtopdir}/plugins/styles/pixmaps/lumon/buttonborder.png ${palmtopdir}/plugins/styles/pixmaps/lumon/buttonborderdown.png ${palmtopdir}/plugins/styles/pixmaps/lumon/buttondown.png ${palmtopdir}/plugins/styles/pixmaps/lumon/checkbox.png ${palmtopdir}/plugins/styles/pixmaps/lumon/checkboxdown.png ${palmtopdir}/plugins/styles/pixmaps/lumon/hscrollgroove.png ${palmtopdir}/plugins/styles/pixmaps/lumon/menubar.png ${palmtopdir}/plugins/styles/pixmaps/lumon/menuitemdown.png ${palmtopdir}/plugins/styles/pixmaps/lumon/radio.png ${palmtopdir}/plugins/styles/pixmaps/lumon/radiodown.png ${palmtopdir}/plugins/styles/pixmaps/lumon/scrollbutton.png ${palmtopdir}/plugins/styles/pixmaps/lumon/splitter.png ${palmtopdir}/plugins/styles/pixmaps/lumon/sunkenarrowdown.png ${palmtopdir}/plugins/styles/pixmaps/lumon/sunkenarrowleft.png ${palmtopdir}/plugins/styles/pixmaps/lumon/sunkenarrowright.png ${palmtopdir}/plugins/styles/pixmaps/lumon/sunkenarrowup.png ${palmtopdir}/plugins/styles/pixmaps/lumon/tab.png ${palmtopdir}/plugins/styles/pixmaps/lumon/tabdown.png ${palmtopdir}/plugins/styles/pixmaps/lumon/vscrollgroove.png"
+FILES_opie-theme-luna = " ${palmtopdir}/plugins/styles/themes/luna.themerc ${palmtopdir}/plugins/styles/pixmaps/luna/*.png"
diff --git a/packages/opie-theme/opie-theme_1.2.0.bb b/packages/opie-theme/opie-theme_1.2.0.bb
index e69de29bb2..4d3866f0ef 100644
--- a/packages/opie-theme/opie-theme_1.2.0.bb
+++ b/packages/opie-theme/opie-theme_1.2.0.bb
@@ -0,0 +1,7 @@
+include ${PN}.inc
+
+
+PR = "r0"
+
+SRC_URI = "${HANDHELDS_CVS};tag=${TAG};module=opie/noncore/styles/theme \
+ ${HANDHELDS_CVS};tag=${TAG};module=opie/plugins/styles "