aboutsummaryrefslogtreecommitdiffstats
path: root/packages/oprofile
diff options
context:
space:
mode:
authornslu2-linux.adm@bkbits.net <nslu2-linux.adm@bkbits.net>2005-06-13 14:40:10 +0000
committernslu2-linux.adm@bkbits.net <nslu2-linux.adm@bkbits.net>2005-06-13 14:40:10 +0000
commit46bb5871b7a1e1784dadb74db6bd796437754e52 (patch)
treefa5a0a913cdc01c0f214ae67b81cec7d21094a68 /packages/oprofile
parent87b62a7ab0bc54ea9a2fc4725a59c41bd48171a3 (diff)
downloadopenembedded-46bb5871b7a1e1784dadb74db6bd796437754e52.tar.gz
Merge bk://oe-devel.bkbits.net/openembedded
into bkbits.net:/repos/n/nslu2-linux/openembedded 2005/06/13 16:35:06+02:00 uni-frankfurt.de!mickeyl Merge bk://oe-devel@oe-devel.bkbits.net/openembedded into r2d2.tm.informatik.uni-frankfurt.de:/local/pkg/oe/packages 2005/06/13 16:34:50+02:00 uni-frankfurt.de!mickeyl remove sharp-aticore. it has been superseded by sharp-aticore-oss 2005/06/13 16:10:40+02:00 utwente.nl!koen Merge bk://oe-devel@oe-devel.bkbits.net/openembedded into bitbake.utwente.nl:/home/koen/OE/openembedded 2005/06/13 16:10:22+02:00 utwente.nl!koen xextensions_20050610.bb: change version to 1.0.3 2005/06/13 15:08:33+01:00 rpsys.net!RP Merge bk://oe-devel@oe-devel.bkbits.net/openembedded into tim.rpsys.net:/usr/oe/openembedded 2005/06/13 14:54:00+01:00 rpsys.net!RP oprofile: Add a fix to correct the broken offset handling of the kernel image on arm BKrev: 42ad9aca821nDca8VyvkPqyxgklLlA
Diffstat (limited to 'packages/oprofile')
-rw-r--r--packages/oprofile/oprofile-0.9/arm_offsetfix.patch0
-rw-r--r--packages/oprofile/oprofile/arm_offsetfix.patch0
-rw-r--r--packages/oprofile/oprofile_0.9.bb40
-rw-r--r--packages/oprofile/oprofile_cvs.bb42
4 files changed, 82 insertions, 0 deletions
diff --git a/packages/oprofile/oprofile-0.9/arm_offsetfix.patch b/packages/oprofile/oprofile-0.9/arm_offsetfix.patch
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/oprofile/oprofile-0.9/arm_offsetfix.patch
diff --git a/packages/oprofile/oprofile/arm_offsetfix.patch b/packages/oprofile/oprofile/arm_offsetfix.patch
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/oprofile/oprofile/arm_offsetfix.patch
diff --git a/packages/oprofile/oprofile_0.9.bb b/packages/oprofile/oprofile_0.9.bb
index e69de29bb2..9893aa4f07 100644
--- a/packages/oprofile/oprofile_0.9.bb
+++ b/packages/oprofile/oprofile_0.9.bb
@@ -0,0 +1,40 @@
+SECTION = "devel"
+DESCRIPTION = "OProfile is a system-wide profiler for Linux systems, capable \
+of profiling all running code at low overhead."
+LICENSE = "GPL"
+MAINTAINER = "Chris Larson <kergoth@handhelds.org>"
+DEPENDS = "popt binutils"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/oprofile/oprofile-${PV}.tar.gz \
+ file://no_arm_mapping_syms.patch;patch=1 \
+ file://arm_offsetfix.patch;patch=1 \
+ file://acinclude.m4"
+S = "${WORKDIR}/oprofile-${PV}"
+
+inherit autotools
+
+# NOTE: this disables the build of the kernel modules.
+# Should add the oprofile kernel modules, for those with 2.4
+# kernels, as a seperate .oe file.
+EXTRA_OECONF = "--with-kernel-support \
+ --without-x"
+
+do_configure () {
+ cp ${WORKDIR}/acinclude.m4 ${S}/
+ autotools_do_configure
+}
+# Available config options
+# --enable-abi enable abi portability code (default is disabled)
+# --enable-pch enable precompiled header (default is disabled)
+# --enable-gcov enable option for gcov coverage testing (default is disabled)
+# --disable-werror disable -Werror flag (default is enabled for non-release)
+# --disable-optimization disable optimization flags (default is enabled)
+# --with-kernel-support Use 2.6 kernel (no kernel source tree required)
+# --with-linux=dir Path to Linux source tree
+# --with-module-dir=dir Path to module installation directory
+# --with-extra-includes=DIR add extra include paths
+# --with-extra-libs=DIR add extra library paths
+# --with-x use the X Window System
+# --with-qt-dir where the root of Qt is installed
+# --with-qt-includes where the Qt includes are.
+# --with-qt-libraries where the Qt library is installed.
diff --git a/packages/oprofile/oprofile_cvs.bb b/packages/oprofile/oprofile_cvs.bb
index e69de29bb2..eaeca927a7 100644
--- a/packages/oprofile/oprofile_cvs.bb
+++ b/packages/oprofile/oprofile_cvs.bb
@@ -0,0 +1,42 @@
+PV = "0.0cvs${CVSDATE}"
+SECTION = "devel"
+DESCRIPTION = "OProfile is a system-wide profiler for Linux systems, capable \
+of profiling all running code at low overhead."
+LICENSE = "GPL"
+MAINTAINER = "Chris Larson <kergoth@handhelds.org>"
+DEPENDS = "popt binutils"
+
+SRC_URI = "cvs://anonymous@cvs.sourceforge.net/cvsroot/oprofile;module=oprofile \
+ file://no_arm_mapping_syms.patch;patch=1 \
+ file://arm_offsetfix.patch;patch=1 \
+ file://acinclude.m4"
+S = "${WORKDIR}/oprofile"
+
+inherit autotools
+
+# NOTE: this disables the build of the kernel modules.
+# Should add the oprofile kernel modules, for those with 2.4
+# kernels, as a seperate .oe file.
+EXTRA_OECONF = "--with-kernel-support \
+ --without-x \
+ --disable-werror "
+
+do_configure () {
+ cp ${WORKDIR}/acinclude.m4 ${S}/
+ autotools_do_configure
+}
+# Available config options
+# --enable-abi enable abi portability code (default is disabled)
+# --enable-pch enable precompiled header (default is disabled)
+# --enable-gcov enable option for gcov coverage testing (default is disabled)
+# --disable-werror disable -Werror flag (default is enabled for non-release)
+# --disable-optimization disable optimization flags (default is enabled)
+# --with-kernel-support Use 2.6 kernel (no kernel source tree required)
+# --with-linux=dir Path to Linux source tree
+# --with-module-dir=dir Path to module installation directory
+# --with-extra-includes=DIR add extra include paths
+# --with-extra-libs=DIR add extra library paths
+# --with-x use the X Window System
+# --with-qt-dir where the root of Qt is installed
+# --with-qt-includes where the Qt includes are.
+# --with-qt-libraries where the Qt library is installed.