aboutsummaryrefslogtreecommitdiffstats
path: root/packages/orinoco
diff options
context:
space:
mode:
authorRolf Leggewie <oe-devel@rolf.leggewie.biz>2008-01-17 13:46:20 +0000
committerRolf Leggewie <oe-devel@rolf.leggewie.biz>2008-01-17 13:46:20 +0000
commit1cc3b20815d17dc80799a148edbdd58dbfded439 (patch)
tree0dc85a2497924c8c004eba0924dd44218a13d7e0 /packages/orinoco
parentd97abd932d4f40ddeed057702023e06bb35b3f93 (diff)
downloadopenembedded-1cc3b20815d17dc80799a148edbdd58dbfded439.tar.gz
orinoco-modules: unify
Diffstat (limited to 'packages/orinoco')
-rw-r--r--packages/orinoco/orinoco-modules.inc21
-rw-r--r--packages/orinoco/orinoco-modules_0.13e.bb20
-rw-r--r--packages/orinoco/orinoco-modules_0.15rc1.bb19
-rw-r--r--packages/orinoco/orinoco-modules_0.15rc2.bb22
-rw-r--r--packages/orinoco/orinoco-modules_cvs.bb19
5 files changed, 31 insertions, 70 deletions
diff --git a/packages/orinoco/orinoco-modules.inc b/packages/orinoco/orinoco-modules.inc
new file mode 100644
index 0000000000..fc14eb3ee5
--- /dev/null
+++ b/packages/orinoco/orinoco-modules.inc
@@ -0,0 +1,21 @@
+DESCRIPTION = "A driver for wireless LAN cards based on Hermes(Orinoco) cards. \
+Also contains support for cards using downloadable firmware, i.e. the Symbol/Socket family."
+SECTION = "kernel/modules"
+PRIORITY = "optional"
+PROVIDES = "spectrum-modules"
+LICENSE = "GPL"
+
+SRC_URI = "http://ozlabs.org/people/dgibson/dldwd/orinoco-${PV}.tar.gz"
+S = "${WORKDIR}/orinoco-${PV}"
+
+inherit module
+
+PACKAGES = "orinoco-modules-cs orinoco-modules-pci orinoco-modules-usb orinoco-modules-nortel orinoco-modules"
+FILES_orinoco-modules-pci = "/lib/modules/${KERNEL_VERSION}/net/orinoco_p*${KERNEL_OBJECT_SUFFIX}"
+FILES_orinoco-modules-usb = "/lib/modules/${KERNEL_VERSION}/net/*_usb${KERNEL_OBJECT_SUFFIX}"
+FILES_orinoco-modules-nortel = "/lib/modules/${KERNEL_VERSION}/net/orinoco_tmd${KERNEL_OBJECT_SUFFIX} \
+ /lib/modules/${KERNEL_VERSION}/net/orinoco_nortel${KERNEL_OBJECT_SUFFIX}"
+FILES_orinoco-modules = "/lib/modules/"
+RDEPENDS_orinoco-modules-pci = "orinoco-modules"
+RDEPENDS_orinoco-modules-usb = "orinoco-modules"
+RDEPENDS_orinoco-modules-nortel = "orinoco-modules"
diff --git a/packages/orinoco/orinoco-modules_0.13e.bb b/packages/orinoco/orinoco-modules_0.13e.bb
index 9c5cc2f776..f8f8e446a9 100644
--- a/packages/orinoco/orinoco-modules_0.13e.bb
+++ b/packages/orinoco/orinoco-modules_0.13e.bb
@@ -1,11 +1,8 @@
-DESCRIPTION = "A driver for wireless LAN cards based on Hermes(Orinoco) cards. \
-Also contains support for cards using downloadable firmware, i.e. the Symbol/Socket family."
-SECTION = "kernel/modules"
-PRIORITY = "optional"
-LICENSE = "GPL"
+require orinoco-modules.inc
+
PR = "r4"
-SRC_URI = "http://ozlabs.org/people/dgibson/dldwd/orinoco-${PV}.tar.gz; \
+SRC_URI += "\
file://crosscompile.patch;patch=1 \
file://monitor-${PV}.patch;patch=1 \
file://spectrum.conf \
@@ -14,8 +11,6 @@ SRC_URI = "http://ozlabs.org/people/dgibson/dldwd/orinoco-${PV}.tar.gz; \
file://orinoco_cs.conf"
S = "${WORKDIR}/orinoco-${PV}"
-inherit module
-
do_compile_prepend() {
cp -f ${WORKDIR}/spectrum* ${S}/
}
@@ -30,14 +25,5 @@ do_install() {
install -m 0644 ${WORKDIR}/orinoco_cs.conf ${D}${sysconfdir}/modutils/
}
-PACKAGES = "orinoco-modules-cs orinoco-modules-pci orinoco-modules-usb orinoco-modules-nortel orinoco-modules"
FILES_orinoco-modules-cs = "/lib/modules/${KERNEL_VERSION}/net/*_cs${KERNEL_OBJECT_SUFFIX} /${sysconfdir}"
-FILES_orinoco-modules-pci = "/lib/modules/${KERNEL_VERSION}/net/orinoco_p*${KERNEL_OBJECT_SUFFIX}"
-FILES_orinoco-modules-usb = "/lib/modules/${KERNEL_VERSION}/net/*_usb${KERNEL_OBJECT_SUFFIX}"
-FILES_orinoco-modules-nortel = "/lib/modules/${KERNEL_VERSION}/net/orinoco_tmd${KERNEL_OBJECT_SUFFIX} \
- /lib/modules/${KERNEL_VERSION}/net/orinoco_nortel${KERNEL_OBJECT_SUFFIX}"
-FILES_orinoco-modules = "/lib/modules/"
RDEPENDS_orinoco-modules-cs = "orinoco-modules"
-RDEPENDS_orinoco-modules-pci = "orinoco-modules"
-RDEPENDS_orinoco-modules-usb = "orinoco-modules"
-RDEPENDS_orinoco-modules-nortel = "orinoco-modules"
diff --git a/packages/orinoco/orinoco-modules_0.15rc1.bb b/packages/orinoco/orinoco-modules_0.15rc1.bb
index ebf0f03bbf..7289b6eaf8 100644
--- a/packages/orinoco/orinoco-modules_0.15rc1.bb
+++ b/packages/orinoco/orinoco-modules_0.15rc1.bb
@@ -1,10 +1,7 @@
-DESCRIPTION = "A driver for wireless LAN cards based on Hermes(Orinoco) cards. \
-Also contains support for cards using downloadable firmware, i.e. the Symbol/Socket family."
-SECTION = "kernel/modules"
-PRIORITY = "optional"
+require orinoco-modules.inc
+
DEPENDS = "orinoco-conf spectrum-fw"
RDEPENDS = "orinoco-conf"
-LICENSE = "GPL"
PR = "r7"
SRC_URI = "${SOURCEFORGE_MIRROR}/orinoco/orinoco-${PV}.tar.gz \
@@ -13,23 +10,11 @@ SRC_URI = "${SOURCEFORGE_MIRROR}/orinoco/orinoco-${PV}.tar.gz \
file://add_event.patch;patch=1 \
file://add_utsname.patch;patch=1 \
file://spectrum_cs_ids.patch;patch=1"
-S = "${WORKDIR}/orinoco-${PV}"
-
-inherit module
do_install() {
install -d ${D}${base_libdir}/modules/${KERNEL_VERSION}/net/
install -m 0644 *${KERNEL_OBJECT_SUFFIX} ${D}${base_libdir}/modules/${KERNEL_VERSION}/net/
}
-PACKAGES = "orinoco-modules-cs orinoco-modules-pci orinoco-modules-usb orinoco-modules-nortel orinoco-modules"
FILES_orinoco-modules-cs = "/lib/modules/${KERNEL_VERSION}/net/*_cs${KERNEL_OBJECT_SUFFIX}"
-FILES_orinoco-modules-pci = "/lib/modules/${KERNEL_VERSION}/net/orinoco_p*${KERNEL_OBJECT_SUFFIX}"
-FILES_orinoco-modules-usb = "/lib/modules/${KERNEL_VERSION}/net/*_usb${KERNEL_OBJECT_SUFFIX}"
-FILES_orinoco-modules-nortel = "/lib/modules/${KERNEL_VERSION}/net/orinoco_tmd${KERNEL_OBJECT_SUFFIX} \
- /lib/modules/${KERNEL_VERSION}/net/orinoco_nortel${KERNEL_OBJECT_SUFFIX}"
-FILES_orinoco-modules = "/lib/modules/"
RDEPENDS_orinoco-modules-cs = "orinoco-modules spectrum-fw"
-RDEPENDS_orinoco-modules-pci = "orinoco-modules"
-RDEPENDS_orinoco-modules-usb = "orinoco-modules"
-RDEPENDS_orinoco-modules-nortel = "orinoco-modules"
diff --git a/packages/orinoco/orinoco-modules_0.15rc2.bb b/packages/orinoco/orinoco-modules_0.15rc2.bb
index 4153e8c4fc..da223fca7d 100644
--- a/packages/orinoco/orinoco-modules_0.15rc2.bb
+++ b/packages/orinoco/orinoco-modules_0.15rc2.bb
@@ -1,37 +1,21 @@
-DESCRIPTION = "A driver for wireless LAN cards based on Hermes(Orinoco) cards. \
-Also contains support for cards using downloadable firmware, i.e. the Symbol/Socket family."
-SECTION = "kernel/modules"
-PRIORITY = "optional"
-PROVIDES = "spectrum-modules"
+require orinoco-modules.inc
+
DEPENDS = "orinoco-conf spectrum-fw"
RDEPENDS = "orinoco-conf"
-LICENSE = "GPL"
PR = "r9"
-SRC_URI = "http://ozlabs.org/people/dgibson/dldwd/orinoco-${PV}.tar.gz \
+SRC_URI += "\
file://makefile_fix.patch;patch=1 \
file://list-move.patch;patch=1 \
file://add_utsname.patch;patch=1 \
file://add_event.patch;patch=1 \
file://spectrum_cs_ids.patch;patch=1 \
file://catch-up-with-kernel-changes.patch;patch=1"
-S = "${WORKDIR}/orinoco-${PV}"
-
-inherit module
do_install() {
install -d ${D}${base_libdir}/modules/${KERNEL_VERSION}/net/
install -m 0644 *${KERNEL_OBJECT_SUFFIX} ${D}${base_libdir}/modules/${KERNEL_VERSION}/net/
}
-PACKAGES = "orinoco-modules-cs orinoco-modules-pci orinoco-modules-usb orinoco-modules-nortel orinoco-modules"
FILES_orinoco-modules-cs = "/lib/modules/${KERNEL_VERSION}/net/*_cs${KERNEL_OBJECT_SUFFIX}"
-FILES_orinoco-modules-pci = "/lib/modules/${KERNEL_VERSION}/net/orinoco_p*${KERNEL_OBJECT_SUFFIX}"
-FILES_orinoco-modules-usb = "/lib/modules/${KERNEL_VERSION}/net/*_usb${KERNEL_OBJECT_SUFFIX}"
-FILES_orinoco-modules-nortel = "/lib/modules/${KERNEL_VERSION}/net/orinoco_tmd${KERNEL_OBJECT_SUFFIX} \
- /lib/modules/${KERNEL_VERSION}/net/orinoco_nortel${KERNEL_OBJECT_SUFFIX}"
-FILES_orinoco-modules = "/lib/modules/"
RDEPENDS_orinoco-modules-cs = "orinoco-modules spectrum-fw"
-RDEPENDS_orinoco-modules-pci = "orinoco-modules"
-RDEPENDS_orinoco-modules-usb = "orinoco-modules"
-RDEPENDS_orinoco-modules-nortel = "orinoco-modules"
diff --git a/packages/orinoco/orinoco-modules_cvs.bb b/packages/orinoco/orinoco-modules_cvs.bb
index 5d3efec80f..78bfd2ce0f 100644
--- a/packages/orinoco/orinoco-modules_cvs.bb
+++ b/packages/orinoco/orinoco-modules_cvs.bb
@@ -1,11 +1,7 @@
-DESCRIPTION = "A driver for wireless LAN cards based on Hermes(Orinoco) cards. \
-Also contains support for cards using downloadable firmware, i.e. the Symbol/Socket family."
-SECTION = "kernel/modules"
-PRIORITY = "optional"
-PROVIDES = "spectrum-modules"
+require orinoco-modules.inc
+
DEPENDS = "orinoco-conf spectrum-fw"
RDEPENDS = "orinoco-conf"
-LICENSE = "GPL"
PR = "r2"
PARALLEL_MAKE = ""
@@ -18,21 +14,10 @@ SRC_URI = "cvs://anonymous@cvs.sv.gnu.org/cvsroot/orinoco;module=orinoco;method=
file://list-move.patch;patch=1"
S = "${WORKDIR}/orinoco"
-inherit module
-
do_install() {
install -d ${D}${base_libdir}/modules/${KERNEL_VERSION}/net/
install -m 0644 *${KERNEL_OBJECT_SUFFIX} ${D}${base_libdir}/modules/${KERNEL_VERSION}/net/
}
-PACKAGES = "orinoco-modules-cs orinoco-modules-pci orinoco-modules-usb orinoco-modules-nortel orinoco-modules"
FILES_orinoco-modules-cs = "/lib/modules/${KERNEL_VERSION}/net/*_cs${KERNEL_OBJECT_SUFFIX}"
-FILES_orinoco-modules-pci = "/lib/modules/${KERNEL_VERSION}/net/orinoco_p*${KERNEL_OBJECT_SUFFIX}"
-FILES_orinoco-modules-usb = "/lib/modules/${KERNEL_VERSION}/net/*_usb${KERNEL_OBJECT_SUFFIX}"
-FILES_orinoco-modules-nortel = "/lib/modules/${KERNEL_VERSION}/net/orinoco_tmd${KERNEL_OBJECT_SUFFIX} \
- /lib/modules/${KERNEL_VERSION}/net/orinoco_nortel${KERNEL_OBJECT_SUFFIX}"
-FILES_orinoco-modules = "/lib/modules/"
RDEPENDS_orinoco-modules-cs = "orinoco-modules spectrum-fw"
-RDEPENDS_orinoco-modules-pci = "orinoco-modules"
-RDEPENDS_orinoco-modules-usb = "orinoco-modules"
-RDEPENDS_orinoco-modules-nortel = "orinoco-modules"