aboutsummaryrefslogtreecommitdiffstats
path: root/packages/orinoco
diff options
context:
space:
mode:
authorRichard Purdie <rpurdie@rpsys.net>2005-08-03 22:24:50 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-08-03 22:24:50 +0000
commit450f11bd2d7166baedca74f1ec5ba4d2e6910104 (patch)
tree462c9b42cce76fcc2fe443ccf23be339b7d2e3e2 /packages/orinoco
parenta40e5dff63a60c40c47c7155650440a3b37e999b (diff)
downloadopenembedded-450f11bd2d7166baedca74f1ec5ba4d2e6910104.tar.gz
orinoco: Fix this to work with the latest kernels. Further device IDs may need adding for spectrum cards...
Diffstat (limited to 'packages/orinoco')
-rw-r--r--packages/orinoco/orinoco-modules-0.15rc1/add_event.patch56
-rw-r--r--packages/orinoco/orinoco-modules-0.15rc1/add_utsname.patch9
-rw-r--r--packages/orinoco/orinoco-modules-0.15rc1/spectrum_cs_ids.patch101
-rw-r--r--packages/orinoco/orinoco-modules-0.15rc2/add_event.patch56
-rw-r--r--packages/orinoco/orinoco-modules-0.15rc2/add_utsname.patch21
-rw-r--r--packages/orinoco/orinoco-modules-0.15rc2/spectrum_cs_ids.patch101
-rw-r--r--packages/orinoco/orinoco-modules_0.15rc1.bb5
-rw-r--r--packages/orinoco/orinoco-modules_0.15rc2.bb8
8 files changed, 352 insertions, 5 deletions
diff --git a/packages/orinoco/orinoco-modules-0.15rc1/add_event.patch b/packages/orinoco/orinoco-modules-0.15rc1/add_event.patch
new file mode 100644
index 0000000000..f8b86f335b
--- /dev/null
+++ b/packages/orinoco/orinoco-modules-0.15rc1/add_event.patch
@@ -0,0 +1,56 @@
+Index: orinoco-0.15rc2/orinoco_cs.c
+===================================================================
+--- orinoco-0.15rc2.orig/orinoco_cs.c 2004-07-28 07:06:45.000000000 +0100
++++ orinoco-0.15rc2/orinoco_cs.c 2005-08-03 18:38:34.000000000 +0100
+@@ -189,11 +189,13 @@
+
+ client_reg.dev_info = &dev_info;
+ client_reg.Attributes = INFO_IO_CLIENT | INFO_CARD_SHARE;
++#if (LINUX_VERSION_CODE < KERNEL_VERSION(2,6,13))
+ client_reg.EventMask =
+ CS_EVENT_CARD_INSERTION | CS_EVENT_CARD_REMOVAL |
+ CS_EVENT_RESET_PHYSICAL | CS_EVENT_CARD_RESET |
+ CS_EVENT_PM_SUSPEND | CS_EVENT_PM_RESUME;
+ client_reg.event_handler = &orinoco_cs_event;
++#endif
+ client_reg.Version = 0x0210; /* FIXME: what does this mean? */
+ client_reg.event_callback_args.client_data = link;
+
+@@ -612,6 +614,9 @@
+ .name = DRIVER_NAME,
+ },
+ .attach = orinoco_cs_attach,
++#if (LINUX_VERSION_CODE > KERNEL_VERSION(2,6,12))
++ .event = orinoco_cs_event,
++#endif
+ .detach = orinoco_cs_detach,
+ };
+
+Index: orinoco-0.15rc2/spectrum_cs.c
+===================================================================
+--- orinoco-0.15rc2.orig/spectrum_cs.c 2005-08-03 11:51:09.000000000 +0100
++++ orinoco-0.15rc2/spectrum_cs.c 2005-08-03 18:38:46.000000000 +0100
+@@ -699,11 +699,13 @@
+
+ client_reg.dev_info = &dev_info;
+ client_reg.Attributes = INFO_IO_CLIENT | INFO_CARD_SHARE;
++#if (LINUX_VERSION_CODE < KERNEL_VERSION(2,6,13))
+ client_reg.EventMask =
+ CS_EVENT_CARD_INSERTION | CS_EVENT_CARD_REMOVAL |
+ CS_EVENT_RESET_PHYSICAL | CS_EVENT_CARD_RESET |
+ CS_EVENT_PM_SUSPEND | CS_EVENT_PM_RESUME;
+ client_reg.event_handler = &spectrum_cs_event;
++#endif
+ client_reg.Version = 0x0210; /* FIXME: what does this mean? */
+ client_reg.event_callback_args.client_data = link;
+
+@@ -1096,6 +1098,9 @@
+ .name = DRIVER_NAME,
+ },
+ .attach = spectrum_cs_attach,
++#if (LINUX_VERSION_CODE > KERNEL_VERSION(2,6,12))
++ .event = spectrum_cs_event,
++#endif
+ .detach = spectrum_cs_detach,
+ };
+
diff --git a/packages/orinoco/orinoco-modules-0.15rc1/add_utsname.patch b/packages/orinoco/orinoco-modules-0.15rc1/add_utsname.patch
new file mode 100644
index 0000000000..864910eb85
--- /dev/null
+++ b/packages/orinoco/orinoco-modules-0.15rc1/add_utsname.patch
@@ -0,0 +1,9 @@
+Index: orinoco-0.15rc1/kcompat.h
+===================================================================
+--- orinoco-0.15rc1.orig/kcompat.h 2005-08-03 14:51:18.000000000 +0000
++++ orinoco-0.15rc1/kcompat.h 2005-08-03 15:11:02.000000000 +0000
+@@ -1,3 +1,4 @@
++#include <linux/utsname.h>
+ #include <linux/version.h>
+
+ /********************************************************************/
diff --git a/packages/orinoco/orinoco-modules-0.15rc1/spectrum_cs_ids.patch b/packages/orinoco/orinoco-modules-0.15rc1/spectrum_cs_ids.patch
new file mode 100644
index 0000000000..709e05a435
--- /dev/null
+++ b/packages/orinoco/orinoco-modules-0.15rc1/spectrum_cs_ids.patch
@@ -0,0 +1,101 @@
+Index: orinoco-0.15rc2/spectrum_cs.c
+===================================================================
+--- orinoco-0.15rc2.orig/spectrum_cs.c 2005-08-03 18:43:58.000000000 +0100
++++ orinoco-0.15rc2/spectrum_cs.c 2005-08-03 22:27:03.000000000 +0100
+@@ -1092,6 +1092,17 @@
+ " (Pavel Roskin <proski@gnu.org>,"
+ " David Gibson <hermes@gibson.dropbear.id.au>, et al)";
+
++#if (LINUX_VERSION_CODE > KERNEL_VERSION(2,6,12))
++static struct pcmcia_device_id spectrum_cs_ids[] = {
++ PCMCIA_DEVICE_MANF_CARD(0x026c, 0x0001),
++ PCMCIA_DEVICE_MANF_CARD(0x0104, 0x0001),
++ PCMCIA_DEVICE_MANF_CARD(0x0089, 0x0001),
++ PCMCIA_DEVICE_PROD_ID12("Symbol", "Spectrum24 LA4100 Series WLAN PC Card", 0xd20d85fd, 0x63066cd9),
++ PCMCIA_DEVICE_NULL,
++};
++MODULE_DEVICE_TABLE(pcmcia, spectrum_cs_ids);
++#endif
++
+ static struct pcmcia_driver orinoco_driver = {
+ .owner = THIS_MODULE,
+ .drv = {
+@@ -1100,6 +1111,7 @@
+ .attach = spectrum_cs_attach,
+ #if (LINUX_VERSION_CODE > KERNEL_VERSION(2,6,12))
+ .event = spectrum_cs_event,
++ .id_table = spectrum_cs_ids,
+ #endif
+ .detach = spectrum_cs_detach,
+ };
+Index: orinoco-0.15rc2/orinoco_cs.c
+===================================================================
+--- orinoco-0.15rc2.orig/orinoco_cs.c 2005-08-03 18:43:55.000000000 +0100
++++ orinoco-0.15rc2/orinoco_cs.c 2005-08-03 22:58:58.000000000 +0100
+@@ -608,6 +608,58 @@
+ " (David Gibson <hermes@gibson.dropbear.id.au>, "
+ "Pavel Roskin <proski@gnu.org>, et al)";
+
++#if (LINUX_VERSION_CODE > KERNEL_VERSION(2,6,12))
++static struct pcmcia_device_id orinoco_cs_ids[] = {
++ PCMCIA_DEVICE_MANF_CARD(0x000b, 0x7300),
++ PCMCIA_DEVICE_MANF_CARD(0x0089, 0x0001),
++ PCMCIA_DEVICE_MANF_CARD(0x0138, 0x0002),
++ PCMCIA_DEVICE_MANF_CARD(0x0156, 0x0002),
++ PCMCIA_DEVICE_MANF_CARD(0x01eb, 0x080a),
++ PCMCIA_DEVICE_MANF_CARD(0x0261, 0x0002),
++ PCMCIA_DEVICE_MANF_CARD(0x0268, 0x0001),
++ PCMCIA_DEVICE_MANF_CARD(0x026f, 0x0305),
++ PCMCIA_DEVICE_MANF_CARD(0x0274, 0x1613),
++ PCMCIA_DEVICE_MANF_CARD(0x028a, 0x0002),
++ PCMCIA_DEVICE_MANF_CARD(0x028a, 0x0673),
++ PCMCIA_DEVICE_MANF_CARD(0x02aa, 0x0002),
++ PCMCIA_DEVICE_MANF_CARD(0x02ac, 0x0002),
++ PCMCIA_DEVICE_MANF_CARD(0x14ea, 0xb001),
++ PCMCIA_DEVICE_MANF_CARD(0x50c2, 0x7300),
++ PCMCIA_DEVICE_MANF_CARD(0x9005, 0x0021),
++ PCMCIA_DEVICE_MANF_CARD(0xc250, 0x0002),
++ PCMCIA_DEVICE_MANF_CARD(0xd601, 0x0002),
++ PCMCIA_DEVICE_MANF_CARD(0xd601, 0x0002),
++ PCMCIA_DEVICE_MANF_CARD(0xd601, 0x0005),
++ PCMCIA_DEVICE_MANF_CARD(0xd601, 0x0005),
++ PCMCIA_DEVICE_PROD_ID12("3Com", "3CRWE737A AirConnect Wireless LAN PC Card", 0x41240e5b, 0x56010af3),
++ PCMCIA_DEVICE_PROD_ID123("Instant Wireless ", " Network PC CARD", "Version 01.02", 0x11d901af, 0x6e9bd926, 0x4b74baa0),
++ PCMCIA_DEVICE_PROD_ID12("ACTIONTEC", "PRISM Wireless LAN PC Card", 0x393089da, 0xa71e69d5),
++ PCMCIA_DEVICE_PROD_ID12("Avaya Communication", "Avaya Wireless PC Card", 0xd8a43b78, 0x0d341169),
++ PCMCIA_DEVICE_PROD_ID12("BUFFALO", "WLI-PCM-L11G", 0x2decece3, 0xf57ca4b3),
++ PCMCIA_DEVICE_PROD_ID12("Cabletron", "RoamAbout 802.11 DS", 0x32d445f5, 0xedeffd90),
++ PCMCIA_DEVICE_PROD_ID12("corega K.K.", "Wireless LAN PCC-11", 0x5261440f, 0xa6405584),
++ PCMCIA_DEVICE_PROD_ID12("corega K.K.", "Wireless LAN PCCA-11", 0x5261440f, 0xdf6115f9),
++ PCMCIA_DEVICE_PROD_ID12("D", "Link DRC-650 11Mbps WLAN Card", 0x71b18589, 0xf144e3ac),
++ PCMCIA_DEVICE_PROD_ID12("D", "Link DWL-650 11Mbps WLAN Card", 0x71b18589, 0xb6f1b0ab),
++ PCMCIA_DEVICE_PROD_ID12("ELSA", "AirLancer MC-11", 0x4507a33a, 0xef54f0e3),
++ PCMCIA_DEVICE_PROD_ID12("HyperLink", "Wireless PC Card 11Mbps", 0x56cc3f1a, 0x0bcf220c),
++ PCMCIA_DEVICE_PROD_ID12("INTERSIL", "HFA384x/IEEE", 0x74c5e40d, 0xdb472a18),
++ PCMCIA_DEVICE_PROD_ID12("Lucent Technologies", "WaveLAN/IEEE", 0x23eb9949, 0xc562e72a),
++ PCMCIA_DEVICE_PROD_ID12("MELCO", "WLI-PCM-L11", 0x481e0094, 0x7360e410),
++ PCMCIA_DEVICE_PROD_ID12("MELCO", "WLI-PCM-L11G", 0x481e0094, 0xf57ca4b3),
++ PCMCIA_DEVICE_PROD_ID12("Microsoft", "Wireless Notebook Adapter MN-520", 0x5961bf85, 0x6eec8c01),
++ PCMCIA_DEVICE_PROD_ID12("NCR", "WaveLAN/IEEE", 0x24358cd4, 0xc562e72a),
++ PCMCIA_DEVICE_PROD_ID12("NETGEAR MA401RA Wireless PC", "Card", 0x0306467f, 0x9762e8f1),
++ PCMCIA_DEVICE_PROD_ID12("PLANEX", "GeoWave/GW-CF110", 0x209f40ab, 0xd9715264),
++ PCMCIA_DEVICE_PROD_ID12("PROXIM", "LAN PC CARD HARMONY 80211B", 0xc6536a5e, 0x090c3cd9),
++ PCMCIA_DEVICE_PROD_ID12("PROXIM", "LAN PCI CARD HARMONY 80211B", 0xc6536a5e, 0x9f494e26),
++ PCMCIA_DEVICE_PROD_ID12("SAMSUNG", "11Mbps WLAN Card", 0x43d74cb4, 0x579bd91b),
++ PCMCIA_DEVICE_PROD_ID1("Symbol Technologies", 0x3f02b4d6),
++ PCMCIA_DEVICE_NULL,
++};
++MODULE_DEVICE_TABLE(pcmcia, orinoco_cs_ids);
++#endif
++
+ static struct pcmcia_driver orinoco_driver = {
+ .owner = THIS_MODULE,
+ .drv = {
+@@ -616,6 +668,7 @@
+ .attach = orinoco_cs_attach,
+ #if (LINUX_VERSION_CODE > KERNEL_VERSION(2,6,12))
+ .event = orinoco_cs_event,
++ .id_table = orinoco_cs_ids,
+ #endif
+ .detach = orinoco_cs_detach,
+ };
diff --git a/packages/orinoco/orinoco-modules-0.15rc2/add_event.patch b/packages/orinoco/orinoco-modules-0.15rc2/add_event.patch
new file mode 100644
index 0000000000..f8b86f335b
--- /dev/null
+++ b/packages/orinoco/orinoco-modules-0.15rc2/add_event.patch
@@ -0,0 +1,56 @@
+Index: orinoco-0.15rc2/orinoco_cs.c
+===================================================================
+--- orinoco-0.15rc2.orig/orinoco_cs.c 2004-07-28 07:06:45.000000000 +0100
++++ orinoco-0.15rc2/orinoco_cs.c 2005-08-03 18:38:34.000000000 +0100
+@@ -189,11 +189,13 @@
+
+ client_reg.dev_info = &dev_info;
+ client_reg.Attributes = INFO_IO_CLIENT | INFO_CARD_SHARE;
++#if (LINUX_VERSION_CODE < KERNEL_VERSION(2,6,13))
+ client_reg.EventMask =
+ CS_EVENT_CARD_INSERTION | CS_EVENT_CARD_REMOVAL |
+ CS_EVENT_RESET_PHYSICAL | CS_EVENT_CARD_RESET |
+ CS_EVENT_PM_SUSPEND | CS_EVENT_PM_RESUME;
+ client_reg.event_handler = &orinoco_cs_event;
++#endif
+ client_reg.Version = 0x0210; /* FIXME: what does this mean? */
+ client_reg.event_callback_args.client_data = link;
+
+@@ -612,6 +614,9 @@
+ .name = DRIVER_NAME,
+ },
+ .attach = orinoco_cs_attach,
++#if (LINUX_VERSION_CODE > KERNEL_VERSION(2,6,12))
++ .event = orinoco_cs_event,
++#endif
+ .detach = orinoco_cs_detach,
+ };
+
+Index: orinoco-0.15rc2/spectrum_cs.c
+===================================================================
+--- orinoco-0.15rc2.orig/spectrum_cs.c 2005-08-03 11:51:09.000000000 +0100
++++ orinoco-0.15rc2/spectrum_cs.c 2005-08-03 18:38:46.000000000 +0100
+@@ -699,11 +699,13 @@
+
+ client_reg.dev_info = &dev_info;
+ client_reg.Attributes = INFO_IO_CLIENT | INFO_CARD_SHARE;
++#if (LINUX_VERSION_CODE < KERNEL_VERSION(2,6,13))
+ client_reg.EventMask =
+ CS_EVENT_CARD_INSERTION | CS_EVENT_CARD_REMOVAL |
+ CS_EVENT_RESET_PHYSICAL | CS_EVENT_CARD_RESET |
+ CS_EVENT_PM_SUSPEND | CS_EVENT_PM_RESUME;
+ client_reg.event_handler = &spectrum_cs_event;
++#endif
+ client_reg.Version = 0x0210; /* FIXME: what does this mean? */
+ client_reg.event_callback_args.client_data = link;
+
+@@ -1096,6 +1098,9 @@
+ .name = DRIVER_NAME,
+ },
+ .attach = spectrum_cs_attach,
++#if (LINUX_VERSION_CODE > KERNEL_VERSION(2,6,12))
++ .event = spectrum_cs_event,
++#endif
+ .detach = spectrum_cs_detach,
+ };
+
diff --git a/packages/orinoco/orinoco-modules-0.15rc2/add_utsname.patch b/packages/orinoco/orinoco-modules-0.15rc2/add_utsname.patch
new file mode 100644
index 0000000000..7c2efec2f3
--- /dev/null
+++ b/packages/orinoco/orinoco-modules-0.15rc2/add_utsname.patch
@@ -0,0 +1,21 @@
+Index: orinoco-0.15rc1/kcompat.h
+===================================================================
+--- orinoco-0.15rc1.orig/kcompat.h 2005-08-03 14:51:18.000000000 +0000
++++ orinoco-0.15rc1/kcompat.h 2005-08-03 15:11:02.000000000 +0000
+@@ -1,3 +1,4 @@
++#include <linux/utsname.h>
+ #include <linux/version.h>
+
+ /********************************************************************/
+Index: orinoco-0.15rc2/orinoco.h
+===================================================================
+--- orinoco-0.15rc2.orig/orinoco.h 2004-07-28 07:06:45.000000000 +0100
++++ orinoco-0.15rc2/orinoco.h 2005-08-03 18:43:46.000000000 +0100
+@@ -13,6 +13,7 @@
+ #include <linux/spinlock.h>
+ #include <linux/netdevice.h>
+ #include <linux/wireless.h>
++#include <linux/utsname.h>
+ #include <linux/version.h>
+ #if LINUX_VERSION_CODE >= KERNEL_VERSION(2, 4, 25)
+ #include <linux/moduleparam.h>
diff --git a/packages/orinoco/orinoco-modules-0.15rc2/spectrum_cs_ids.patch b/packages/orinoco/orinoco-modules-0.15rc2/spectrum_cs_ids.patch
new file mode 100644
index 0000000000..709e05a435
--- /dev/null
+++ b/packages/orinoco/orinoco-modules-0.15rc2/spectrum_cs_ids.patch
@@ -0,0 +1,101 @@
+Index: orinoco-0.15rc2/spectrum_cs.c
+===================================================================
+--- orinoco-0.15rc2.orig/spectrum_cs.c 2005-08-03 18:43:58.000000000 +0100
++++ orinoco-0.15rc2/spectrum_cs.c 2005-08-03 22:27:03.000000000 +0100
+@@ -1092,6 +1092,17 @@
+ " (Pavel Roskin <proski@gnu.org>,"
+ " David Gibson <hermes@gibson.dropbear.id.au>, et al)";
+
++#if (LINUX_VERSION_CODE > KERNEL_VERSION(2,6,12))
++static struct pcmcia_device_id spectrum_cs_ids[] = {
++ PCMCIA_DEVICE_MANF_CARD(0x026c, 0x0001),
++ PCMCIA_DEVICE_MANF_CARD(0x0104, 0x0001),
++ PCMCIA_DEVICE_MANF_CARD(0x0089, 0x0001),
++ PCMCIA_DEVICE_PROD_ID12("Symbol", "Spectrum24 LA4100 Series WLAN PC Card", 0xd20d85fd, 0x63066cd9),
++ PCMCIA_DEVICE_NULL,
++};
++MODULE_DEVICE_TABLE(pcmcia, spectrum_cs_ids);
++#endif
++
+ static struct pcmcia_driver orinoco_driver = {
+ .owner = THIS_MODULE,
+ .drv = {
+@@ -1100,6 +1111,7 @@
+ .attach = spectrum_cs_attach,
+ #if (LINUX_VERSION_CODE > KERNEL_VERSION(2,6,12))
+ .event = spectrum_cs_event,
++ .id_table = spectrum_cs_ids,
+ #endif
+ .detach = spectrum_cs_detach,
+ };
+Index: orinoco-0.15rc2/orinoco_cs.c
+===================================================================
+--- orinoco-0.15rc2.orig/orinoco_cs.c 2005-08-03 18:43:55.000000000 +0100
++++ orinoco-0.15rc2/orinoco_cs.c 2005-08-03 22:58:58.000000000 +0100
+@@ -608,6 +608,58 @@
+ " (David Gibson <hermes@gibson.dropbear.id.au>, "
+ "Pavel Roskin <proski@gnu.org>, et al)";
+
++#if (LINUX_VERSION_CODE > KERNEL_VERSION(2,6,12))
++static struct pcmcia_device_id orinoco_cs_ids[] = {
++ PCMCIA_DEVICE_MANF_CARD(0x000b, 0x7300),
++ PCMCIA_DEVICE_MANF_CARD(0x0089, 0x0001),
++ PCMCIA_DEVICE_MANF_CARD(0x0138, 0x0002),
++ PCMCIA_DEVICE_MANF_CARD(0x0156, 0x0002),
++ PCMCIA_DEVICE_MANF_CARD(0x01eb, 0x080a),
++ PCMCIA_DEVICE_MANF_CARD(0x0261, 0x0002),
++ PCMCIA_DEVICE_MANF_CARD(0x0268, 0x0001),
++ PCMCIA_DEVICE_MANF_CARD(0x026f, 0x0305),
++ PCMCIA_DEVICE_MANF_CARD(0x0274, 0x1613),
++ PCMCIA_DEVICE_MANF_CARD(0x028a, 0x0002),
++ PCMCIA_DEVICE_MANF_CARD(0x028a, 0x0673),
++ PCMCIA_DEVICE_MANF_CARD(0x02aa, 0x0002),
++ PCMCIA_DEVICE_MANF_CARD(0x02ac, 0x0002),
++ PCMCIA_DEVICE_MANF_CARD(0x14ea, 0xb001),
++ PCMCIA_DEVICE_MANF_CARD(0x50c2, 0x7300),
++ PCMCIA_DEVICE_MANF_CARD(0x9005, 0x0021),
++ PCMCIA_DEVICE_MANF_CARD(0xc250, 0x0002),
++ PCMCIA_DEVICE_MANF_CARD(0xd601, 0x0002),
++ PCMCIA_DEVICE_MANF_CARD(0xd601, 0x0002),
++ PCMCIA_DEVICE_MANF_CARD(0xd601, 0x0005),
++ PCMCIA_DEVICE_MANF_CARD(0xd601, 0x0005),
++ PCMCIA_DEVICE_PROD_ID12("3Com", "3CRWE737A AirConnect Wireless LAN PC Card", 0x41240e5b, 0x56010af3),
++ PCMCIA_DEVICE_PROD_ID123("Instant Wireless ", " Network PC CARD", "Version 01.02", 0x11d901af, 0x6e9bd926, 0x4b74baa0),
++ PCMCIA_DEVICE_PROD_ID12("ACTIONTEC", "PRISM Wireless LAN PC Card", 0x393089da, 0xa71e69d5),
++ PCMCIA_DEVICE_PROD_ID12("Avaya Communication", "Avaya Wireless PC Card", 0xd8a43b78, 0x0d341169),
++ PCMCIA_DEVICE_PROD_ID12("BUFFALO", "WLI-PCM-L11G", 0x2decece3, 0xf57ca4b3),
++ PCMCIA_DEVICE_PROD_ID12("Cabletron", "RoamAbout 802.11 DS", 0x32d445f5, 0xedeffd90),
++ PCMCIA_DEVICE_PROD_ID12("corega K.K.", "Wireless LAN PCC-11", 0x5261440f, 0xa6405584),
++ PCMCIA_DEVICE_PROD_ID12("corega K.K.", "Wireless LAN PCCA-11", 0x5261440f, 0xdf6115f9),
++ PCMCIA_DEVICE_PROD_ID12("D", "Link DRC-650 11Mbps WLAN Card", 0x71b18589, 0xf144e3ac),
++ PCMCIA_DEVICE_PROD_ID12("D", "Link DWL-650 11Mbps WLAN Card", 0x71b18589, 0xb6f1b0ab),
++ PCMCIA_DEVICE_PROD_ID12("ELSA", "AirLancer MC-11", 0x4507a33a, 0xef54f0e3),
++ PCMCIA_DEVICE_PROD_ID12("HyperLink", "Wireless PC Card 11Mbps", 0x56cc3f1a, 0x0bcf220c),
++ PCMCIA_DEVICE_PROD_ID12("INTERSIL", "HFA384x/IEEE", 0x74c5e40d, 0xdb472a18),
++ PCMCIA_DEVICE_PROD_ID12("Lucent Technologies", "WaveLAN/IEEE", 0x23eb9949, 0xc562e72a),
++ PCMCIA_DEVICE_PROD_ID12("MELCO", "WLI-PCM-L11", 0x481e0094, 0x7360e410),
++ PCMCIA_DEVICE_PROD_ID12("MELCO", "WLI-PCM-L11G", 0x481e0094, 0xf57ca4b3),
++ PCMCIA_DEVICE_PROD_ID12("Microsoft", "Wireless Notebook Adapter MN-520", 0x5961bf85, 0x6eec8c01),
++ PCMCIA_DEVICE_PROD_ID12("NCR", "WaveLAN/IEEE", 0x24358cd4, 0xc562e72a),
++ PCMCIA_DEVICE_PROD_ID12("NETGEAR MA401RA Wireless PC", "Card", 0x0306467f, 0x9762e8f1),
++ PCMCIA_DEVICE_PROD_ID12("PLANEX", "GeoWave/GW-CF110", 0x209f40ab, 0xd9715264),
++ PCMCIA_DEVICE_PROD_ID12("PROXIM", "LAN PC CARD HARMONY 80211B", 0xc6536a5e, 0x090c3cd9),
++ PCMCIA_DEVICE_PROD_ID12("PROXIM", "LAN PCI CARD HARMONY 80211B", 0xc6536a5e, 0x9f494e26),
++ PCMCIA_DEVICE_PROD_ID12("SAMSUNG", "11Mbps WLAN Card", 0x43d74cb4, 0x579bd91b),
++ PCMCIA_DEVICE_PROD_ID1("Symbol Technologies", 0x3f02b4d6),
++ PCMCIA_DEVICE_NULL,
++};
++MODULE_DEVICE_TABLE(pcmcia, orinoco_cs_ids);
++#endif
++
+ static struct pcmcia_driver orinoco_driver = {
+ .owner = THIS_MODULE,
+ .drv = {
+@@ -616,6 +668,7 @@
+ .attach = orinoco_cs_attach,
+ #if (LINUX_VERSION_CODE > KERNEL_VERSION(2,6,12))
+ .event = orinoco_cs_event,
++ .id_table = orinoco_cs_ids,
+ #endif
+ .detach = orinoco_cs_detach,
+ };
diff --git a/packages/orinoco/orinoco-modules_0.15rc1.bb b/packages/orinoco/orinoco-modules_0.15rc1.bb
index 01c2f287ad..17428f35a3 100644
--- a/packages/orinoco/orinoco-modules_0.15rc1.bb
+++ b/packages/orinoco/orinoco-modules_0.15rc1.bb
@@ -4,11 +4,14 @@ SECTION = "kernel/modules"
PRIORITY = "optional"
MAINTAINER = "Michael 'Mickey' Lauer <mickey@Vanille.de>"
LICENSE = "GPL"
-PR = "r4"
+PR = "r5"
SRC_URI = "${SOURCEFORGE_MIRROR}/orinoco/orinoco-${PV}.tar.gz \
file://makefile_fix.patch;patch=1 \
file://list-move.patch;patch=1 \
+ file://add_event.patch;patch=1 \
+ file://add_utsname.patch;patch=1 \
+ file://spectrum_cs_ids.patch;patch=1 \
file://spectrum-firmware.patch;patch=1 \
file://spectrum.conf \
file://spectrum_fw.h \
diff --git a/packages/orinoco/orinoco-modules_0.15rc2.bb b/packages/orinoco/orinoco-modules_0.15rc2.bb
index 73140f8d4c..60cae87857 100644
--- a/packages/orinoco/orinoco-modules_0.15rc2.bb
+++ b/packages/orinoco/orinoco-modules_0.15rc2.bb
@@ -5,14 +5,14 @@ PRIORITY = "optional"
PROVIDES = "spectrum-modules"
MAINTAINER = "Michael 'Mickey' Lauer <mickey@Vanille.de>"
LICENSE = "GPL"
-PR = "r6"
-
-# seems to cause problems on arm
-DEFAULT_PREFERENCE_arm = "-1"
+PR = "r7"
SRC_URI = "http://ozlabs.org/people/dgibson/dldwd/orinoco-${PV}.tar.gz \
file://makefile_fix.patch;patch=1 \
file://list-move.patch;patch=1 \
+ file://add_utsname.patch;patch=1 \
+ file://add_event.patch;patch=1 \
+ file://spectrum_cs_ids.patch;patch=1 \
file://spectrum-firmware.patch;patch=1 \
file://catch-up-with-kernel-changes.patch;patch=1 \
file://spectrum.conf \