aboutsummaryrefslogtreecommitdiffstats
path: root/packages/orinoco
diff options
context:
space:
mode:
authorPhil Blundell <philb@gnu.org>2004-12-12 13:20:44 +0000
committerPhil Blundell <philb@gnu.org>2004-12-12 13:20:44 +0000
commitbab84a93cc58b6242787e59364edec11007d04a3 (patch)
treea243cd2e1948ae6ac18386579b4092b1300f8f36 /packages/orinoco
parentb8a5fe02e647bf95474145647a2f4fbcb98abc6f (diff)
downloadopenembedded-bab84a93cc58b6242787e59364edec11007d04a3.tar.gz
Merge bk://oe-devel@oe-devel.bkbits.net/openembedded
into stealth.nexus.co.uk:/home/pb/oe/oe 2004/12/12 13:19:50+00:00 nexus.co.uk!pb don't ship orinoco_plx, orinoco_pci and orinoco_tmd on non PCI platforms BKrev: 41bc45acD9qzpMZ1N0FZglRyBqT8zw
Diffstat (limited to 'packages/orinoco')
-rw-r--r--packages/orinoco/orinoco-modules_0.13e.bb34
1 files changed, 34 insertions, 0 deletions
diff --git a/packages/orinoco/orinoco-modules_0.13e.bb b/packages/orinoco/orinoco-modules_0.13e.bb
index e69de29bb2..ab99ff28c6 100644
--- a/packages/orinoco/orinoco-modules_0.13e.bb
+++ b/packages/orinoco/orinoco-modules_0.13e.bb
@@ -0,0 +1,34 @@
+DESCRIPTION = "A driver for wireless LAN cards based on Hermes(Orinoco) cards. \
+Also contains support for cards using downloadable firmware, i.e. the Symbol/Socket family."
+SECTION = "kernel/modules"
+PRIORITY = "optional"
+MAINTAINER = "Michael 'Mickey' Lauer <mickey@Vanille.de>"
+LICENSE = "GPL"
+PR = "r2"
+
+SRC_URI = "http://ozlabs.org/people/dgibson/dldwd/orinoco-${PV}.tar.gz; \
+ file://crosscompile.patch;patch=1 \
+ file://monitor-${PV}.patch;patch=1 \
+ file://spectrum*"
+S = "${WORKDIR}/orinoco-${PV}"
+
+inherit module
+
+do_compile_prepend() {
+ cp -f ${WORKDIR}/spectrum* ${S}/
+}
+
+do_install() {
+ install -d ${D}/lib/modules/${KERNEL_VERSION}/kernel/drivers/net/wireless
+ install -d ${D}/etc/pcmcia
+ install -m 0644 *.o ${D}/lib/modules/${KERNEL_VERSION}/kernel/drivers/net/wireless/
+ install -m 0644 spectrum.conf ${D}/etc/pcmcia/
+ install -m 0644 hermes.conf ${D}/etc/pcmcia/
+
+ # if PCI is disabled, don't ship the PCI modules
+ if grep -q '#undef \+CONFIG_PCI' ${STAGING_KERNEL_DIR}/include/linux/autoconf.h; then
+ for f in plx pci tmd; do
+ rm -f ${D}/lib/modules/${KERNEL_VERSION}/kernel/drivers/net/wireless/orinoco_$f.o
+ done
+ fi
+}