aboutsummaryrefslogtreecommitdiffstats
path: root/packages/pad
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /packages/pad
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'packages/pad')
-rw-r--r--packages/pad/pad-native.bb15
-rwxr-xr-xpackages/pad/pad/pad.c40
2 files changed, 0 insertions, 55 deletions
diff --git a/packages/pad/pad-native.bb b/packages/pad/pad-native.bb
deleted file mode 100644
index e8c2b6d579..0000000000
--- a/packages/pad/pad-native.bb
+++ /dev/null
@@ -1,15 +0,0 @@
-SECTION = "console/utils"
-DESCRIPTION = "Console utility for padding a file (filling with 0 to reach a specified length)"
-FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/pad"
-SRC_URI = "file://pad.c"
-LICENSE = "PD"
-inherit native
-
-do_compile() {
- cp ${WORKDIR}/pad.c .
- ${CC} -I. -o pad pad.c
-}
-
-do_stage() {
- install -m 0755 pad ${STAGING_BINDIR}/
-}
diff --git a/packages/pad/pad/pad.c b/packages/pad/pad/pad.c
deleted file mode 100755
index e81e22504d..0000000000
--- a/packages/pad/pad/pad.c
+++ /dev/null
@@ -1,40 +0,0 @@
-#include <stdio.h>
-#include <stdlib.h>
-#include <sys/types.h>
-#include <sys/stat.h>
-#include <unistd.h>
-
-int stat(const char *file_name, struct stat *buf);
-
-int syntax(void)
-{
- printf("syntax:\n");
- printf(" pad padnum filename\n");
- return(0);
-}
-
-int main(int argc, char **argv)
-{
- FILE *fp;
- long int i=0L, padsize=0L;
- unsigned char data=0xff;
- struct stat fileinfo;
- if(argc<3){
- syntax();
- exit(1);
- }
- if((fp=fopen(argv[2],"a"))==NULL){
- printf("error opening %s.\n",argv[2]);
- exit(1);
- }
- if(stat(argv[2],&fileinfo)!=0){
- printf("error in stat of %s.\n",argv[2]);
- exit(1);
- }
- padsize = strtol(argv[1],NULL,10) - fileinfo.st_size;
- for(i=0;i<padsize;i++){
- fwrite(&data,1,1,fp);
- }
- fclose(fp);
- return(0);
-}