aboutsummaryrefslogtreecommitdiffstats
path: root/packages/palantir
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2009-01-05 15:04:06 +0100
committerKoen Kooi <koen@openembedded.org>2009-01-05 15:04:06 +0100
commit6613cff9f7a44b0d8bfdb8f12f856f791a3cc161 (patch)
treeed4a4475d86734075599a6ac92e610b9e2a58af5 /packages/palantir
parentac5ca6c9bcbabac5bd3731fbdf00a5fe5d19cdb8 (diff)
downloadopenembedded-6613cff9f7a44b0d8bfdb8f12f856f791a3cc161.tar.gz
palantier: add 2.7
Diffstat (limited to 'packages/palantir')
-rw-r--r--packages/palantir/palantir_2.7.bb37
1 files changed, 37 insertions, 0 deletions
diff --git a/packages/palantir/palantir_2.7.bb b/packages/palantir/palantir_2.7.bb
new file mode 100644
index 0000000000..ad1b2f6a19
--- /dev/null
+++ b/packages/palantir/palantir_2.7.bb
@@ -0,0 +1,37 @@
+DESCRIPTION = "Palantir - a multichannel interactive streaming solution"
+LICENSE = "GPLv2"
+DEPENDS = "jpeg libgsm"
+
+SRC_URI = "http://www.fastpath.it/products/palantir/pub/palantir-${PV}.tgz"
+
+S = "${WORKDIR}/palantir-${PV}/server"
+
+TARGET_CC_ARCH += "${CFLAGS} ${LDFLAGS}"
+
+export BASE_DIR="${prefix}"
+
+do_install() {
+ sed -i -e s:chown:echo:g -e s:chmod:echo:g Makefile
+ mkdir -p ${D}/var/log/palantir
+ LOG_FILE="${D}/var/log/palantir" OWNER="${USER}" BASE_DIR="${D}${prefix}" oe_runmake install
+ rm ${D}/${datadir}/palantir/telmu_pipe
+}
+
+FILES_${PN} += "${datadir}/palantir/"
+
+pkg_postinst_${PN} () {
+ # can't do this offline
+ if [ "x$D" != "x" ]; then
+ exit 1
+ fi
+ grep "^palantir:" /etc/passwd > /dev/null || adduser --disabled-password --system --home /var/run/palantir --no-create-home palantir --ingroup palantir -g palantir
+ mkfifo ${datadir}/palantir/telmu_pipe
+ chown palantir ${datadir}/palantir/*
+ chmod 600 ${datadir}/palantir/telmu_pipe
+}
+
+
+pkg_postrm_${PN} () {
+ deluser palantir || true
+}
+