aboutsummaryrefslogtreecommitdiffstats
path: root/packages/pam
diff options
context:
space:
mode:
authorMike Westerhof <mwester@dls.net>2008-09-08 06:03:55 +0000
committerMike Westerhof <mwester@dls.net>2008-09-08 06:03:55 +0000
commitfbe2d6775362947d2aa59f27c3ab190997d10c02 (patch)
tree3f2bc10c854fa17996719fe586b060d4670c81b5 /packages/pam
parent60547ded403dd699b9505963a9ecd7d8b5131c0d (diff)
downloadopenembedded-fbe2d6775362947d2aa59f27c3ab190997d10c02.tar.gz
libpam: add flex as a dependency; handle empty .debug dir case (and clean up
the python whitespace too), bump PR.
Diffstat (limited to 'packages/pam')
-rw-r--r--packages/pam/libpam_1.0.2.bb15
1 files changed, 11 insertions, 4 deletions
diff --git a/packages/pam/libpam_1.0.2.bb b/packages/pam/libpam_1.0.2.bb
index cf98944778..0b7eada2ab 100644
--- a/packages/pam/libpam_1.0.2.bb
+++ b/packages/pam/libpam_1.0.2.bb
@@ -10,6 +10,10 @@ SECTION = "libs"
PRIORITY = "optional"
LICENSE = "GPLv2"
+DEPENDS = "flex flex-native"
+
+PR = "r1"
+
# The project is actually called Linux-PAM but that gives
# a bad OE package name because of the upper case characters
pn = "Linux-PAM"
@@ -24,12 +28,15 @@ inherit autotools
LEAD_SONAME = "libpam.so.*"
python populate_packages_prepend () {
- pam_libdir = bb.data.expand('${libdir}/security', d)
+ import os.path
+
+ pam_libdir = bb.data.expand('${libdir}/security', d)
pam_libdirdebug = bb.data.expand('${libdir}/security/.debug', d)
- pam_filterdir = bb.data.expand('${libdir}/security/pam_filter', d)
+ pam_filterdir = bb.data.expand('${libdir}/security/pam_filter', d)
do_split_packages(d, pam_libdir, '^pam(.*)\.so$', 'pam-plugin%s', 'PAM plugin for %s', extra_depends='')
- do_split_packages(d, pam_libdir, '^pam(.*)\.la$', 'pam-plugin%s-dev', 'PAM plugin for %s dev', extra_depends='')
- do_split_packages(d, pam_libdirdebug, '^pam(.*)\.so$', 'pam-plugin%s-dbg', 'PAM plugin for %s debugging symbols', extra_depends='')
+ do_split_packages(d, pam_libdir, '^pam(.*)\.la$', 'pam-plugin%s-dev', 'PAM plugin for %s dev', extra_depends='')
+ if os.path.exists(pam_libdirdebug):
+ do_split_packages(d, pam_libdirdebug, '^pam(.*)\.so$', 'pam-plugin%s-dbg', 'PAM plugin for %s debugging symbols', extra_depends='')
do_split_packages(d, pam_filterdir, '^(.*)$', 'pam-filter-%s', 'PAM filter for %s', extra_depends='')
}