aboutsummaryrefslogtreecommitdiffstats
path: root/packages/pango/pango_1.10.2.bb
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2005-12-30 09:45:41 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-12-30 09:45:41 +0000
commit0e62b72beab8a6ddbcab43e4427c94a19dcde79f (patch)
treec1a793fa213ccea749273b64a2682100057d37eb /packages/pango/pango_1.10.2.bb
parent8fb37e53a3a85a3e22816b62f78533769bc2e536 (diff)
downloadopenembedded-0e62b72beab8a6ddbcab43e4427c94a19dcde79f.tar.gz
pango: update to 1.10.2 which should be a lot faster as its predecessors
Diffstat (limited to 'packages/pango/pango_1.10.2.bb')
-rw-r--r--packages/pango/pango_1.10.2.bb43
1 files changed, 43 insertions, 0 deletions
diff --git a/packages/pango/pango_1.10.2.bb b/packages/pango/pango_1.10.2.bb
new file mode 100644
index 0000000000..6977cbc5f1
--- /dev/null
+++ b/packages/pango/pango_1.10.2.bb
@@ -0,0 +1,43 @@
+LICENSE = "LGPL"
+SECTION = "x11/libs"
+# Xt needed to keep autoconf's check for X11 happy
+DEPENDS = "glib-2.0 fontconfig freetype zlib x11 libxft xt gtk-doc cairo"
+DESCRIPTION = "The goal of the Pango project is to provide an \
+Open Source framework for the layout and rendering of \
+internationalized text."
+PR = "r0"
+
+# seems to go wrong with default cflags
+FULL_OPTIMIZATION_arm = "-O2"
+
+SRC_URI = "ftp://ftp.gtk.org/pub/gtk/v2.8/pango-${PV}.tar.bz2 \
+ file://no-tests.patch;patch=1"
+
+inherit autotools pkgconfig
+
+EXTRA_OECONF = "--disable-glibtest \
+ --enable-explicit-deps=no \
+ --disable-debug"
+
+FILES_${PN} = "/etc ${bindir} ${libdir}/libpango*.so.*"
+
+LIBV = "1.4.0"
+
+do_stage () {
+autotools_stage_all
+}
+
+postinst_prologue() {
+if [ "x$D" != "x" ]; then
+ exit 1
+fi
+
+}
+
+python populate_packages_prepend () {
+ prologue = bb.data.getVar("postinst_prologue", d, 1)
+
+ modules_root = bb.data.expand('${libdir}/pango/${LIBV}/modules', d)
+
+ do_split_packages(d, modules_root, '^pango-(.*)\.so$', 'pango-module-%s', 'Pango module %s', prologue + 'pango-querymodules > /etc/pango/pango.modules')
+}