aboutsummaryrefslogtreecommitdiffstats
path: root/packages/pango
diff options
context:
space:
mode:
authorFlorian Boor <florian.boor@kernelconcepts.de>2006-07-05 13:03:28 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2006-07-05 13:03:28 +0000
commita7c094472a42a606442aad2cac2fb0e4fa73f0e3 (patch)
treefb4c521b1e440e546cb25308c0f3c21ca14b79cb /packages/pango
parentfd128b368d57b904414776eb73f50ce650e5268c (diff)
downloadopenembedded-a7c094472a42a606442aad2cac2fb0e4fa73f0e3.tar.gz
pango: add 1.13.2
Diffstat (limited to 'packages/pango')
-rw-r--r--packages/pango/pango-1.13.2/.mtn2git_empty0
-rw-r--r--packages/pango/pango-1.13.2/opentype-makefile.patch20
-rw-r--r--packages/pango/pango_1.13.2.bb48
3 files changed, 68 insertions, 0 deletions
diff --git a/packages/pango/pango-1.13.2/.mtn2git_empty b/packages/pango/pango-1.13.2/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/pango/pango-1.13.2/.mtn2git_empty
diff --git a/packages/pango/pango-1.13.2/opentype-makefile.patch b/packages/pango/pango-1.13.2/opentype-makefile.patch
new file mode 100644
index 0000000000..9f68420bc5
--- /dev/null
+++ b/packages/pango/pango-1.13.2/opentype-makefile.patch
@@ -0,0 +1,20 @@
+--- pango/opentype/Makefile.am~ 2006-07-05 14:49:28.000000000 +0200
++++ pango/opentype/Makefile.am 2006-07-05 14:49:28.000000000 +0200
+@@ -5,7 +5,7 @@
+
+ noinst_LTLIBRARIES = libharfbuzz-1.la
+
+-SOURCES = \
++MAIN_SOURCES = \
+ ftglue.c \
+ harfbuzz-buffer.c \
+ harfbuzz-dump.c \
+@@ -34,7 +34,7 @@
+ harfbuzz-open-private.h
+
+ libharfbuzz_1_la_SOURCES = \
+- $(SOURCES) \
++ $(MAIN_SOURCES) \
+ $(PUBLICHEADERS) \
+ $(PRIVATEHEADERS)
+
diff --git a/packages/pango/pango_1.13.2.bb b/packages/pango/pango_1.13.2.bb
new file mode 100644
index 0000000000..113f604340
--- /dev/null
+++ b/packages/pango/pango_1.13.2.bb
@@ -0,0 +1,48 @@
+LICENSE = "LGPL"
+SECTION = "x11/libs"
+# Xt needed to keep autoconf's check for X11 happy
+DEPENDS = "glib-2.0 fontconfig freetype zlib x11 libxft xt gtk-doc cairo"
+DESCRIPTION = "The goal of the Pango project is to provide an \
+Open Source framework for the layout and rendering of \
+internationalized text."
+PR = "r0"
+
+# seems to go wrong with default cflags
+FULL_OPTIMIZATION_arm = "-O2"
+
+SRC_URI = "http://ftp.gnome.org/pub/GNOME/sources/pango/1.13/pango-${PV}.tar.bz2 \
+ file://no-tests.patch;patch=1 \
+ file://opentype-makefile.patch;patch=1;pnum=0"
+
+inherit autotools pkgconfig
+
+EXTRA_OECONF = "--disable-glibtest \
+ --enable-explicit-deps=no \
+ --disable-debug"
+
+FILES_${PN} = "/etc ${bindir} ${libdir}/libpango*.so.*"
+
+LIBV = "1.5.0"
+
+do_stage () {
+ for lib in pango pangox pangoft2 pangoxft pangocairo; do
+ oe_libinstall -so -C pango lib$lib-1.0 ${STAGING_LIBDIR}/
+ done
+ install -d ${STAGING_INCDIR}/pango
+ install -m 0644 ${S}/pango/pango*.h ${STAGING_INCDIR}/pango/
+}
+
+postinst_prologue() {
+if [ "x$D" != "x" ]; then
+ exit 1
+fi
+
+}
+
+python populate_packages_prepend () {
+ prologue = bb.data.getVar("postinst_prologue", d, 1)
+
+ modules_root = bb.data.expand('${libdir}/pango/${LIBV}/modules', d)
+
+ do_split_packages(d, modules_root, '^pango-(.*)\.so$', 'pango-module-%s', 'Pango module %s', prologue + 'pango-querymodules > /etc/pango/pango.modules')
+}