aboutsummaryrefslogtreecommitdiffstats
path: root/packages/patch
diff options
context:
space:
mode:
authorJamie Lenehan <lenehan@twibble.org>2006-10-23 23:56:13 +0000
committerJamie Lenehan <lenehan@twibble.org>2006-10-23 23:56:13 +0000
commit5e035af68c660b8f5cd56ba1fa7a0262477216e1 (patch)
treea4f692804c47caebbabd94bdede9d439b5313112 /packages/patch
parent0d6366b500dfe1ab4ee228d4a180729dcf49c713 (diff)
downloadopenembedded-5e035af68c660b8f5cd56ba1fa7a0262477216e1.tar.gz
patch 2.5.9: Use alternatives for patch since busybox also provides a patch
command. As per #1472.
Diffstat (limited to 'packages/patch')
-rw-r--r--packages/patch/patch.inc10
-rw-r--r--packages/patch/patch_2.5.9.bb2
2 files changed, 10 insertions, 2 deletions
diff --git a/packages/patch/patch.inc b/packages/patch/patch.inc
index c8240ca3a9..4ce51703aa 100644
--- a/packages/patch/patch.inc
+++ b/packages/patch/patch.inc
@@ -8,4 +8,12 @@ SECTION = "utils"
SRC_URI = "${GNU_MIRROR}/patch/patch-${PV}.tar.gz"
S = "${WORKDIR}/patch-${PV}"
-inherit autotools
+inherit autotools update-alternatives
+
+do_install_append () {
+ mv ${D}${bindir}/patch ${D}${bindir}/patch.${PN}
+}
+
+ALTERNATIVE_NAME = "patch"
+ALTERNATIVE_PATH = "patch.${PN}"
+ALTERNATIVE_PRIORITY = "100"
diff --git a/packages/patch/patch_2.5.9.bb b/packages/patch/patch_2.5.9.bb
index 940b15a205..ff485546fc 100644
--- a/packages/patch/patch_2.5.9.bb
+++ b/packages/patch/patch_2.5.9.bb
@@ -7,4 +7,4 @@ SRC_URI = "${GNU_MIRROR}/patch/patch-2.5.4.tar.gz \
file://unified-reject-files.diff;patch=1 \
file://global-reject-file.diff;patch=1 "
S = "${WORKDIR}/patch-2.5.4"
-PR = "r1" \ No newline at end of file
+PR = "r2" \ No newline at end of file