aboutsummaryrefslogtreecommitdiffstats
path: root/packages/patcher
diff options
context:
space:
mode:
authorChris Larson <clarson@kergoth.com>2006-08-28 20:30:14 +0000
committerChris Larson <clarson@kergoth.com>2006-08-28 20:30:14 +0000
commitd3c0ca658f75bf8f2aa96c51126712eb8d45c875 (patch)
tree71f0dc44890c6004b9592936984495039d57454b /packages/patcher
parent395ef28947528cc4cd955ae4480c2b6b5561c892 (diff)
downloadopenembedded-d3c0ca658f75bf8f2aa96c51126712eb8d45c875.tar.gz
Merge from poky:
Rework the way patches are handled. There are now two abstract base classes, initialized in patch.bbclass. One for patchset operations on a directory, and another for patch failure resolution. Currently includes 'patch' and 'quilt' concrete PatchSet classes, and a 'user' resolver class, which simply drops you into a shell in the source tree to fix the rejects.
Diffstat (limited to 'packages/patcher')
-rw-r--r--packages/patcher/patcher-native_20040913.bb4
1 files changed, 1 insertions, 3 deletions
diff --git a/packages/patcher/patcher-native_20040913.bb b/packages/patcher/patcher-native_20040913.bb
index 833ca21a53..7da61e91c2 100644
--- a/packages/patcher/patcher-native_20040913.bb
+++ b/packages/patcher/patcher-native_20040913.bb
@@ -14,9 +14,7 @@ SRC_URI = "http://www.holgerschurig.de/files/linux/patcher-${PV}.tar.bz2"
SRC_URI_append_build-freebsd = " file://freebsd_gpatch.patch;patch=1 "
S = "${WORKDIR}/patcher"
-PATCHCLEANCMD = ""
-PATCHCMD = "num='%s'; name='%s'; file='%s'; patch -p "$num" -i "$file""
-PATCHCMD_build-freebsd = "num='%s'; name='%s'; file='%s'; gpatch -p "$num" -i "$file""
+PATCHTOOL = "patch"
do_stage() {
install -m 0755 patcher.py ${STAGING_BINDIR}/patcher