aboutsummaryrefslogtreecommitdiffstats
path: root/packages/patcher
diff options
context:
space:
mode:
authorHolger Freyther <zecke@selfish.org>2005-07-17 13:02:31 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-07-17 13:02:31 +0000
commitc4a4b2905d3ffbc85217a48843d07e4fd887e203 (patch)
tree198072cd60bdd9436810714084fec41fad02c39a /packages/patcher
parent440d78ee0713d56b60320ac0bd9a4b38a42739dd (diff)
downloadopenembedded-c4a4b2905d3ffbc85217a48843d07e4fd887e203.tar.gz
conf/bitbake.conf:
-Add the BUILD_OS to the overrides. This allows us for example to use gpatch on FreeBSD instead of patch packages/patcher/patcher-native_...bb: -Change the PATCHCMD to use gpatch as well - s/build-fbsd/build-freebsd/
Diffstat (limited to 'packages/patcher')
-rw-r--r--packages/patcher/files/freebsd_gpatch.patch4
-rw-r--r--packages/patcher/patcher-native_20040913.bb3
2 files changed, 4 insertions, 3 deletions
diff --git a/packages/patcher/files/freebsd_gpatch.patch b/packages/patcher/files/freebsd_gpatch.patch
index f7e107a410..ee6365f49d 100644
--- a/packages/patcher/files/freebsd_gpatch.patch
+++ b/packages/patcher/files/freebsd_gpatch.patch
@@ -2,8 +2,8 @@ On FreeBSD the default patch program has a different command line
interface than GNU patch. Make patcher use the GNU patch.
---- patcher.py.old Mon Sep 13 21:59:05 2004
-+++ patcher.py Sun Jul 17 14:24:50 2005
+--- patcher/patcher.py.old Mon Sep 13 21:59:05 2004
++++ patcher/patcher.py Sun Jul 17 14:24:50 2005
@@ -631,8 +631,8 @@
my $res;
diff --git a/packages/patcher/patcher-native_20040913.bb b/packages/patcher/patcher-native_20040913.bb
index 1d49d0e035..833ca21a53 100644
--- a/packages/patcher/patcher-native_20040913.bb
+++ b/packages/patcher/patcher-native_20040913.bb
@@ -11,11 +11,12 @@ PR = "r1"
inherit native
SRC_URI = "http://www.holgerschurig.de/files/linux/patcher-${PV}.tar.bz2"
-SRC_URI_append_build-fbsd = " file://freebsd_gpatch.patch;patch=1 "
+SRC_URI_append_build-freebsd = " file://freebsd_gpatch.patch;patch=1 "
S = "${WORKDIR}/patcher"
PATCHCLEANCMD = ""
PATCHCMD = "num='%s'; name='%s'; file='%s'; patch -p "$num" -i "$file""
+PATCHCMD_build-freebsd = "num='%s'; name='%s'; file='%s'; gpatch -p "$num" -i "$file""
do_stage() {
install -m 0755 patcher.py ${STAGING_BINDIR}/patcher