aboutsummaryrefslogtreecommitdiffstats
path: root/packages/pciutils
diff options
context:
space:
mode:
authorOyvind Repvik <nail@nslu2-linux.org>2005-08-23 14:55:53 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-08-23 14:55:53 +0000
commitd08e6e48b4282150feda8eb319a874c6de3591e7 (patch)
tree6fc6934ea71a597f8fafb07c1ca9408474bdf9a1 /packages/pciutils
parent3dd231ab06b0cab8595e8696a0b029f69d67ac9f (diff)
downloadopenembedded-d08e6e48b4282150feda8eb319a874c6de3591e7.tar.gz
Add pci.ids, in a separate package
Diffstat (limited to 'packages/pciutils')
-rw-r--r--packages/pciutils/pciutils_2.1.11.bb10
1 files changed, 8 insertions, 2 deletions
diff --git a/packages/pciutils/pciutils_2.1.11.bb b/packages/pciutils/pciutils_2.1.11.bb
index 792b34fda7..98d5f55af2 100644
--- a/packages/pciutils/pciutils_2.1.11.bb
+++ b/packages/pciutils/pciutils_2.1.11.bb
@@ -4,10 +4,11 @@ to PCI bus configuration space and several utilities based on this library.'
HOMEPAGE = "http://atrey.karlin.mff.cuni.cz/~mj/pciutils.shtml"
LICENSE = "GPLv2"
-PR="r1"
+PR="r2"
PARALLEL_MAKE = ""
-
+FILES_pciutils-ids="${prefix}/share/pci.ids"
+PACKAGES =+ "pciutils-ids"
SRC_URI = "ftp://ftp.kernel.org/pub/software/utils/pciutils/pciutils-${PV}.tar.bz2 \
file://configure.patch;patch=1 \
file://configure-uclibc.patch;patch=1 \
@@ -25,3 +26,8 @@ export MANDIR = "${D}${mandir}"
do_install () {
oe_runmake install
}
+do_install_append () {
+ install -d ${D}/${prefix}/share
+ install -m 6440 ${WORKDIR}/${PN}-${PV}/pci.ids ${D}/${prefix}/share
+}
+