aboutsummaryrefslogtreecommitdiffstats
path: root/packages/pcmcia-cs
diff options
context:
space:
mode:
authorRichard Purdie <rpurdie@rpsys.net>2005-11-14 15:36:02 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-11-14 15:36:02 +0000
commit9ef849f523405597e1fdd3ae44df310a3a3ed37b (patch)
tree4dccbf0c057fad8a612b80a4b83a7946e18006d1 /packages/pcmcia-cs
parent401c2566de3debb224b44fdec8d878b2c83738f2 (diff)
downloadopenembedded-9ef849f523405597e1fdd3ae44df310a3a3ed37b.tar.gz
pcmcia-cs 3.2.8: gcc4 fixes
Diffstat (limited to 'packages/pcmcia-cs')
-rw-r--r--packages/pcmcia-cs/files/gcc4_fixes.patch26
-rw-r--r--packages/pcmcia-cs/pcmcia-cs_3.2.8.bb3
2 files changed, 28 insertions, 1 deletions
diff --git a/packages/pcmcia-cs/files/gcc4_fixes.patch b/packages/pcmcia-cs/files/gcc4_fixes.patch
new file mode 100644
index 0000000000..c68ba7a0f9
--- /dev/null
+++ b/packages/pcmcia-cs/files/gcc4_fixes.patch
@@ -0,0 +1,26 @@
+Index: pcmcia-cs-3.2.8/debug-tools/lspnp.c
+===================================================================
+--- pcmcia-cs-3.2.8.orig/debug-tools/lspnp.c 2002-02-13 05:45:01.000000000 +0000
++++ pcmcia-cs-3.2.8/debug-tools/lspnp.c 2005-11-11 23:43:33.000000000 +0000
+@@ -496,7 +496,7 @@
+ dump_io_fixed(r); break;
+ }
+ }
+- (u_char *)p += sz + 1;
++ p = (union pnp_resource *) ((u_char *)p + sz + 1);
+ }
+ return (u_char *)p;
+ }
+Index: pcmcia-cs-3.2.8/debug-tools/setpnp.c
+===================================================================
+--- pcmcia-cs-3.2.8.orig/debug-tools/setpnp.c 2001-10-10 02:58:12.000000000 +0000
++++ pcmcia-cs-3.2.8/debug-tools/setpnp.c 2005-11-11 23:44:32.000000000 +0000
+@@ -163,7 +163,7 @@
+ break;
+ }
+ }
+- (u_char *)p += sz + 1;
++ p = (union pnp_resource *) ((u_char *)p + sz + 1);
+ }
+ return (u_char *)p;
+ }
diff --git a/packages/pcmcia-cs/pcmcia-cs_3.2.8.bb b/packages/pcmcia-cs/pcmcia-cs_3.2.8.bb
index fa685f8d5f..e0ebf70d93 100644
--- a/packages/pcmcia-cs/pcmcia-cs_3.2.8.bb
+++ b/packages/pcmcia-cs/pcmcia-cs_3.2.8.bb
@@ -3,7 +3,7 @@ SECTION = "base"
PRIORITY = "required"
LICENSE = "GPL"
DEPENDS = "virtual/kernel"
-PR = "r22"
+PR = "r23"
SRC_URI = "${SOURCEFORGE_MIRROR}/pcmcia-cs/pcmcia-cs-${PV}.tar.gz \
file://busybox.patch;patch=1 \
@@ -12,6 +12,7 @@ SRC_URI = "${SOURCEFORGE_MIRROR}/pcmcia-cs/pcmcia-cs-${PV}.tar.gz \
file://automount.patch;patch=1 \
file://ratoc-cfu1u.patch;patch=1 \
file://no-hostap-cards.patch;patch=1 \
+ file://gcc4_fixes.patch;patch=1 \
file://pcmcia \
file://ide.opts \
file://wireless.opts \