aboutsummaryrefslogtreecommitdiffstats
path: root/packages/perl
diff options
context:
space:
mode:
authorJamie Lenehan <lenehan@twibble.org>2007-04-24 13:57:31 +0000
committerJamie Lenehan <lenehan@twibble.org>2007-04-24 13:57:31 +0000
commit0a76edae15ea6d3bfb442e3a4d189f174e6b39d0 (patch)
treee5bbd46fb320d5d0268fc827b29d6a5af2a91ffa /packages/perl
parent3109706302aae1be018f9d63bcdf7f48f5ea3136 (diff)
downloadopenembedded-0a76edae15ea6d3bfb442e3a4d189f174e6b39d0.tar.gz
perl 5.8.8: Replace host paths from the configuration file that is to be
installed on the target with those that are suitable for the target. This has no effect on actually using perl but would have an effect on trying to build perl modules on the target.
Diffstat (limited to 'packages/perl')
-rw-r--r--packages/perl/perl_5.8.8.bb8
1 files changed, 6 insertions, 2 deletions
diff --git a/packages/perl/perl_5.8.8.bb b/packages/perl/perl_5.8.8.bb
index cb6014c085..6e79066afa 100644
--- a/packages/perl/perl_5.8.8.bb
+++ b/packages/perl/perl_5.8.8.bb
@@ -5,7 +5,7 @@ LICENSE = "Artistic|GPL"
PRIORITY = "optional"
# We need gnugrep (for -I)
DEPENDS = "virtual/db perl-native grep-native"
-PR = "r2"
+PR = "r3"
# Major part of version
PVM = "5.8"
@@ -109,7 +109,11 @@ do_install() {
# Fix up installed configuration
if test "${MACHINE}" != "native"; then
- sed -i -e "s,${D},,g" ${D}/${libdir}/perl/${PV}/Config_heavy.pl
+ sed -i -e "s,${D},,g" \
+ -e "s,-isystem${STAGING_INCDIR} ,,g" \
+ -e "s,${STAGING_LIBDIR},${libdir},g" \
+ -e "s,${STAGING_INCDIR},${includedir},g" \
+ ${D}/${libdir}/perl/${PV}/Config_heavy.pl
fi
}
do_stage() {