aboutsummaryrefslogtreecommitdiffstats
path: root/packages/perl
diff options
context:
space:
mode:
authorJohn Bowler <jbowler@nslu2-linux.org>2005-11-11 07:15:36 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-11-11 07:15:36 +0000
commit1c60e3ea33243897f1159d617a0bf0fb9e5916f3 (patch)
tree9c07ba79b1bd4132216ca513c55faf5df5a74c66 /packages/perl
parent82111b6f46d1afcb5d480fceaabc6822403e1867 (diff)
downloadopenembedded-1c60e3ea33243897f1159d617a0bf0fb9e5916f3.tar.gz
db: fix db3/db4 confusion by causing all packages to use virtual/db in db-4.3 4.3.29
- The SleepyCat implementation of the Berkeley DB exists in OE in two different - versions, 3.2 and 4.3. These appear to now be compatible (i.e. with the correct - settings db-4.3 can do everything db-3.2 can do and all packages compile with it). - The previous scheme of allowing both to be built (which was highly error prone) - has been removed and all db users now reference virtual/db. - Affects: - bogofilter, cyrus-*, openldap, perl, postfix, rpm
Diffstat (limited to 'packages/perl')
-rw-r--r--packages/perl/perl-native_5.8.4.bb3
-rw-r--r--packages/perl/perl-native_5.8.7.bb3
-rw-r--r--packages/perl/perl.inc2
3 files changed, 5 insertions, 3 deletions
diff --git a/packages/perl/perl-native_5.8.4.bb b/packages/perl/perl-native_5.8.4.bb
index da30274627..a4065e999b 100644
--- a/packages/perl/perl-native_5.8.4.bb
+++ b/packages/perl/perl-native_5.8.4.bb
@@ -1,11 +1,12 @@
DESCRIPTION = "Perl is a popular scripting language."
HOMEPAGE = "http://www.perl.org/"
LICENSE = "Artistic|GPL"
+PR = "r1"
SECTION = "libs"
inherit native
-DEPENDS = "db3-native gdbm-native"
+DEPENDS = "virtual/db-native gdbm-native"
SRC_URI = "http://ftp.funet.fi/pub/CPAN/src/perl-${PV}.tar.gz"
S = "${WORKDIR}/perl-${PV}"
diff --git a/packages/perl/perl-native_5.8.7.bb b/packages/perl/perl-native_5.8.7.bb
index cc2b7fc5b1..4a28478b94 100644
--- a/packages/perl/perl-native_5.8.7.bb
+++ b/packages/perl/perl-native_5.8.7.bb
@@ -2,11 +2,12 @@ DESCRIPTION = "Perl is a popular scripting language."
MAINTAINER="David Karlstrom <daka@thg.se>"
HOMEPAGE = "http://www.perl.org/"
LICENSE = "Artistic|GPL"
+PR = "r1"
SECTION = "libs"
inherit native
-DEPENDS = "db3-native gdbm-native"
+DEPENDS = "virtual/db-native gdbm-native"
SRC_URI = "http://ftp.funet.fi/pub/CPAN/src/perl-${PV}.tar.gz"
S = "${WORKDIR}/perl-${PV}"
diff --git a/packages/perl/perl.inc b/packages/perl/perl.inc
index 5ee5418fc4..505249cd9e 100644
--- a/packages/perl/perl.inc
+++ b/packages/perl/perl.inc
@@ -3,7 +3,7 @@ HOMEPAGE = "http://www.perl.org/"
LICENSE = "Artistic|GPL"
SECTION = "devel"
PRIORITY = "optional"
-DEPENDS = "db3 perl-native"
+DEPENDS = "virtual/db perl-native"
SRC_URI = "http://ftp.funet.fi/pub/CPAN/src/perl-${PV}.tar.gz \
file://Makefile.patch;patch=1 \