aboutsummaryrefslogtreecommitdiffstats
path: root/packages/perl
diff options
context:
space:
mode:
authorJamie Lenehan <lenehan@twibble.org>2007-05-30 07:00:11 +0000
committerJamie Lenehan <lenehan@twibble.org>2007-05-30 07:00:11 +0000
commit290ca8b6c88511606acfff39a20e414c58a0a724 (patch)
treee07b1c4108d927dd8fb897ca81f3dd0228a51c61 /packages/perl
parent39611c22b7715ebba0f61c7a32a237373243d699 (diff)
downloadopenembedded-290ca8b6c88511606acfff39a20e414c58a0a724.tar.gz
perl-native 5.8.8: Fix an issues with the perl makedepend script not
properly terminating a quote. This is in theory the fix for the /bin/sh -> /bin/dash problems with perl, however since I don't have any issues here with dash (ubuntu 6.10) I can't confirm this. The patch is an obvious fix though so I'm adding it.
Diffstat (limited to 'packages/perl')
-rw-r--r--packages/perl/perl-5.8.8/native-makedepend-dash.patch13
-rw-r--r--packages/perl/perl-native_5.8.8.bb5
2 files changed, 16 insertions, 2 deletions
diff --git a/packages/perl/perl-5.8.8/native-makedepend-dash.patch b/packages/perl/perl-5.8.8/native-makedepend-dash.patch
new file mode 100644
index 0000000000..1f15474377
--- /dev/null
+++ b/packages/perl/perl-5.8.8/native-makedepend-dash.patch
@@ -0,0 +1,13 @@
+Index: perl-5.8.8/makedepend.SH
+===================================================================
+--- perl-5.8.8.orig/makedepend.SH 2007-05-24 12:06:52.000000000 +1000
++++ perl-5.8.8/makedepend.SH 2007-05-24 12:27:33.000000000 +1000
+@@ -128,7 +128,7 @@
+ *.y) filebase=`basename $file .y` ;;
+ esac
+ case "$file" in
+- */*) finc="-I`echo $file | sed 's#/[^/]*$##`" ;;
++ */*) finc="-I`echo $file | sed 's#/[^/]*$##'`" ;;
+ *) finc= ;;
+ esac
+ $echo "Finding dependencies for $filebase$_o."
diff --git a/packages/perl/perl-native_5.8.8.bb b/packages/perl/perl-native_5.8.8.bb
index de7e4ffa3f..d4896daa12 100644
--- a/packages/perl/perl-native_5.8.8.bb
+++ b/packages/perl/perl-native_5.8.8.bb
@@ -3,7 +3,7 @@ HOMEPAGE = "http://www.perl.org/"
SECTION = "libs"
LICENSE = "Artistic|GPL"
DEPENDS = "virtual/db-native gdbm-native"
-PR = "r9"
+PR = "r10"
FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/perl-${PV}"
@@ -13,7 +13,8 @@ SRC_URI = "http://ftp.funet.fi/pub/CPAN/src/perl-${PV}.tar.gz \
file://perl-configpm-switch.patch;patch=1 \
file://native-nopacklist.patch;patch=1 \
file://native-no-gdbminc.patch;patch=1 \
- file://native-perlinc.patch;patch=1"
+ file://native-perlinc.patch;patch=1 \
+ file://native-makedepend-dash.patch;patch=1"
S = "${WORKDIR}/perl-${PV}"