aboutsummaryrefslogtreecommitdiffstats
path: root/packages/perl
diff options
context:
space:
mode:
authorBernhard Rosenkraenzer <bero@arklinux.org>2007-05-01 11:30:59 +0000
committerJamie Lenehan <lenehan@twibble.org>2007-05-01 11:30:59 +0000
commit32cbfda7038c0ec4ebc806198a37541a688a5adc (patch)
treed0c8860371f0d093fe3669686bc4cbf47b392e43 /packages/perl
parent6cdb4b3fa2816832a6d04306320ca9c548fa4c56 (diff)
downloadopenembedded-32cbfda7038c0ec4ebc806198a37541a688a5adc.tar.gz
perl-native: Patch perl's makedepend.SH to work with gcc 4.2. Shouldn't be
needed for perl since it doesn't run makedepend.SH. Closes #2168
Diffstat (limited to 'packages/perl')
-rw-r--r--packages/perl/files/perl-5.8.8-gcc-4.2.patch13
-rw-r--r--packages/perl/perl-native_5.8.7.bb3
-rw-r--r--packages/perl/perl-native_5.8.8.bb3
3 files changed, 17 insertions, 2 deletions
diff --git a/packages/perl/files/perl-5.8.8-gcc-4.2.patch b/packages/perl/files/perl-5.8.8-gcc-4.2.patch
new file mode 100644
index 0000000000..d9869e1974
--- /dev/null
+++ b/packages/perl/files/perl-5.8.8-gcc-4.2.patch
@@ -0,0 +1,13 @@
+See http://bugs.openembedded.org/show_bug.cgi?id=2168
+Fix for gcc 4.2
+
+--- perl-5.8.8/makedepend.SH.ark 2006-11-01 16:32:05.000000000 +0100
++++ perl-5.8.8/makedepend.SH 2006-11-01 16:32:15.000000000 +0100
+@@ -167,6 +167,7 @@
+ -e '/^#.*<builtin>/d' \
+ -e '/^#.*<built-in>/d' \
+ -e '/^#.*<command line>/d' \
++ -e '/^#.*<command-line>/d' \
+ -e '/^#.*"-"/d' \
+ -e '/: file path prefix .* never used$/d' \
+ -e 's#\.[0-9][0-9]*\.c#'"$file.c#" \
diff --git a/packages/perl/perl-native_5.8.7.bb b/packages/perl/perl-native_5.8.7.bb
index ffbdc4ec32..ebb10e5580 100644
--- a/packages/perl/perl-native_5.8.7.bb
+++ b/packages/perl/perl-native_5.8.7.bb
@@ -1,7 +1,7 @@
DESCRIPTION = "Perl is a popular scripting language."
HOMEPAGE = "http://www.perl.org/"
LICENSE = "Artistic|GPL"
-PR = "r4"
+PR = "r5"
SECTION = "libs"
inherit native
@@ -9,6 +9,7 @@ inherit native
DEPENDS = "virtual/db-native gdbm-native"
SRC_URI = "http://ftp.funet.fi/pub/CPAN/src/perl-${PV}.tar.gz \
+ file://perl-5.8.8-gcc-4.2.patch;patch=1 \
file://Configure-multilib.patch;patch=1"
S = "${WORKDIR}/perl-${PV}"
diff --git a/packages/perl/perl-native_5.8.8.bb b/packages/perl/perl-native_5.8.8.bb
index 75002313cd..a9333d79ee 100644
--- a/packages/perl/perl-native_5.8.8.bb
+++ b/packages/perl/perl-native_5.8.8.bb
@@ -3,13 +3,14 @@ HOMEPAGE = "http://www.perl.org/"
SECTION = "libs"
LICENSE = "Artistic|GPL"
DEPENDS = "virtual/db-native gdbm-native"
-PR = "r1"
+PR = "r2"
FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/perl-${PV}"
DEFAULT_PREFERENCE = "-1"
SRC_URI = "http://ftp.funet.fi/pub/CPAN/src/perl-${PV}.tar.gz \
+ file://perl-5.8.8-gcc-4.2.patch;patch=1 \
file://Configure-multilib.patch;patch=1 \
file://perl-configpm-switch.patch;patch=1"