aboutsummaryrefslogtreecommitdiffstats
path: root/packages/perl
diff options
context:
space:
mode:
authorJamie Lenehan <lenehan@twibble.org>2007-04-05 06:52:55 +0000
committerJamie Lenehan <lenehan@twibble.org>2007-04-05 06:52:55 +0000
commit4ff751b50feb7397a9909f1a684008fa17423223 (patch)
tree9178ef258876aba1db1fe4e7ff38c8049bc3ad22 /packages/perl
parent38156d3b6c2372933ff6d290cba23eb6fc288000 (diff)
downloadopenembedded-4ff751b50feb7397a9909f1a684008fa17423223.tar.gz
perl 5.8.7: Simplify the addition of patches to support gcc for linking and
using PIC for compiling shared libraries.
Diffstat (limited to 'packages/perl')
-rw-r--r--packages/perl/perl_5.8.7.bb15
1 files changed, 7 insertions, 8 deletions
diff --git a/packages/perl/perl_5.8.7.bb b/packages/perl/perl_5.8.7.bb
index 69b5784f38..874c95a79c 100644
--- a/packages/perl/perl_5.8.7.bb
+++ b/packages/perl/perl_5.8.7.bb
@@ -16,14 +16,13 @@ SRC_URI += "file://config.sh-armeb-linux \
file://config.sh-sh3-linux \
file://config.sh-sh4-linux"
-# Patches for sh3/sh4, use gcc to link and override generaet.sh to
-# use PIC mode for compiling shared library objects.
-SRC_URI_append_sh4 += "file://override-generate-sh.patch;patch=1"
-SRC_URI_append_sh4 += "file://makefile-usegcc-to-link.patch;patch=1"
-SRC_URI_append_sh3 += "file://override-generate-sh.patch;patch=1"
-SRC_URI_append_sh3 += "file://makefile-usegcc-to-link.patch;patch=1"
-SRC_URI_append_powerpc += "file://override-generate-sh.patch;patch=1"
-SRC_URI_append_powerpc += "file://makefile-usegcc-to-link.patch;patch=1"
+# Use gcc to link and use PIC mode for compiling shared libs
+GCCLINK_SRC = "file://override-generate-sh.patch;patch=1 \
+ file://makefile-usegcc-to-link.patch;patch=1"
+
+SRC_URI_append_sh4 += " ${GCCLINK_SRC}"
+SRC_URI_append_sh3 += " ${GCCLINK_SRC}"
+SRC_URI_append_powerpc += " ${GCCLINK_SRC}"
PARALLEL_MAKE = ""