aboutsummaryrefslogtreecommitdiffstats
path: root/packages/perl
diff options
context:
space:
mode:
authorJamie Lenehan <lenehan@twibble.org>2007-05-06 23:52:01 +0000
committerJamie Lenehan <lenehan@twibble.org>2007-05-06 23:52:01 +0000
commit68333c4e017dc63020fd318d19069e1b66166273 (patch)
tree63e48898d716df497399cf04bf5de27dd828d650 /packages/perl
parent5b5b45a39e698b3c5e0f5647413a2cb051a991bc (diff)
downloadopenembedded-68333c4e017dc63020fd318d19069e1b66166273.tar.gz
perl-native 5.8.8: Fix for cross-compile badness in the perl build. The
perl-native configure script was added -I/usr/include/gdbm to the ccflags if you host had a /usr/include/gdbm/ndbm.h header, even though gdbm support is disabled. This patch stops the configure script adding that even if it finds the header there.
Diffstat (limited to 'packages/perl')
-rw-r--r--packages/perl/perl-5.8.8/native-no-gdbminc.patch18
-rw-r--r--packages/perl/perl-native_5.8.8.bb5
2 files changed, 21 insertions, 2 deletions
diff --git a/packages/perl/perl-5.8.8/native-no-gdbminc.patch b/packages/perl/perl-5.8.8/native-no-gdbminc.patch
new file mode 100644
index 0000000000..f00fa2cc17
--- /dev/null
+++ b/packages/perl/perl-5.8.8/native-no-gdbminc.patch
@@ -0,0 +1,18 @@
+If you have a /usr/include/gdbm/ndbm.h host on the header then the configure
+script adds -I/usr/include/gdbm to the ccflags even though gdbm support is
+disabled. Prevent perl from doing this so we don't get cross compile badness
+errors while building perl.
+
+--- perl-5.8.8/Configure 2007/05/06 23:42:18 1.1
++++ perl-5.8.8/Configure 2007/05/06 23:42:48
+@@ -20033,8 +20033,8 @@
+ # ndbm.h header in /usr/include/gdbm/ndbm.h.
+ if $test -f /usr/include/gdbm/ndbm.h; then
+ echo '<gdbm/ndbm.h> found.'
+- ccflags="$ccflags -I/usr/include/gdbm"
+- cppflags="$cppflags -I/usr/include/gdbm"
++# ccflags="$ccflags -I/usr/include/gdbm"
++# cppflags="$cppflags -I/usr/include/gdbm"
+ t_ndbm=$define
+ fi
+ ;;
diff --git a/packages/perl/perl-native_5.8.8.bb b/packages/perl/perl-native_5.8.8.bb
index d6a3dc619e..84311d3f59 100644
--- a/packages/perl/perl-native_5.8.8.bb
+++ b/packages/perl/perl-native_5.8.8.bb
@@ -3,7 +3,7 @@ HOMEPAGE = "http://www.perl.org/"
SECTION = "libs"
LICENSE = "Artistic|GPL"
DEPENDS = "virtual/db-native gdbm-native"
-PR = "r4"
+PR = "r6"
FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/perl-${PV}"
@@ -13,7 +13,8 @@ SRC_URI = "http://ftp.funet.fi/pub/CPAN/src/perl-${PV}.tar.gz \
file://perl-5.8.8-gcc-4.2.patch;patch=1 \
file://Configure-multilib.patch;patch=1 \
file://perl-configpm-switch.patch;patch=1 \
- file://native-nopacklist.patch;patch=1"
+ file://native-nopacklist.patch;patch=1 \
+ file://native-no-gdbminc.patch;patch=1"
S = "${WORKDIR}/perl-${PV}"