aboutsummaryrefslogtreecommitdiffstats
path: root/packages/perl
diff options
context:
space:
mode:
authorJamie Lenehan <lenehan@twibble.org>2007-07-06 03:08:35 +0000
committerJamie Lenehan <lenehan@twibble.org>2007-07-06 03:08:35 +0000
commit8809e54182b51dcc864765d075843150db5480c7 (patch)
tree308b89dec409db55510170f9821f2f6a6ca8f25c /packages/perl
parentcca64dcefa7950d7cb7844d2c0cdac3b828466a3 (diff)
downloadopenembedded-8809e54182b51dcc864765d075843150db5480c7.tar.gz
perl/perl-native 5.8.8: Fix up asm/page.h include issue. Perl was including
it in order to get the definition for getpagesize which has been definied in unistd.h, which it already includes, since glibc 2.1. Some versions of linux libc headers removed the asm/page.h resulting in failures here for some people. Closes #2546.
Diffstat (limited to 'packages/perl')
-rw-r--r--packages/perl/perl-5.8.8/asm-pageh-fix.patch19
-rw-r--r--packages/perl/perl-native_5.8.8.bb8
-rw-r--r--packages/perl/perl_5.8.8.bb5
3 files changed, 25 insertions, 7 deletions
diff --git a/packages/perl/perl-5.8.8/asm-pageh-fix.patch b/packages/perl/perl-5.8.8/asm-pageh-fix.patch
new file mode 100644
index 0000000000..41f3b1d23c
--- /dev/null
+++ b/packages/perl/perl-5.8.8/asm-pageh-fix.patch
@@ -0,0 +1,19 @@
+Perl inclues asm/page.h in order to get the definition for getpagesize which
+has been definied in unistd.h since glibc 2.1. Some recent version of linux
+libc headers removed the asm/page.h resulting in failures here for some
+people.
+
+Index: perl-5.8.8/ext/IPC/SysV/SysV.xs
+===================================================================
+--- perl-5.8.8.orig/ext/IPC/SysV/SysV.xs 2001-07-01 04:46:07.000000000 +1000
++++ perl-5.8.8/ext/IPC/SysV/SysV.xs 2007-07-06 11:40:21.000000000 +1000
+@@ -3,9 +3,6 @@
+ #include "XSUB.h"
+
+ #include <sys/types.h>
+-#ifdef __linux__
+-# include <asm/page.h>
+-#endif
+ #if defined(HAS_MSG) || defined(HAS_SEM) || defined(HAS_SHM)
+ #ifndef HAS_SEM
+ # include <sys/ipc.h>
diff --git a/packages/perl/perl-native_5.8.8.bb b/packages/perl/perl-native_5.8.8.bb
index 2955313a99..0e89f11050 100644
--- a/packages/perl/perl-native_5.8.8.bb
+++ b/packages/perl/perl-native_5.8.8.bb
@@ -3,7 +3,7 @@ HOMEPAGE = "http://www.perl.org/"
SECTION = "libs"
LICENSE = "Artistic|GPL"
DEPENDS = "virtual/db-native gdbm-native"
-PR = "r12"
+PR = "r13"
FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/perl-${PV}"
@@ -14,10 +14,8 @@ SRC_URI = "http://ftp.funet.fi/pub/CPAN/src/perl-${PV}.tar.gz \
file://native-nopacklist.patch;patch=1 \
file://native-no-gdbminc.patch;patch=1 \
file://native-perlinc.patch;patch=1 \
- file://makedepend-dash.patch;patch=1"
-
-# This sloppy patch breaks normal gcc
-# file://native-ssp.patch;patch=1
+ file://makedepend-dash.patch;patch=1 \
+ file://asm-pageh-fix.patch;patch=1"
S = "${WORKDIR}/perl-${PV}"
diff --git a/packages/perl/perl_5.8.8.bb b/packages/perl/perl_5.8.8.bb
index 42a9a5cc3a..9df89222b9 100644
--- a/packages/perl/perl_5.8.8.bb
+++ b/packages/perl/perl_5.8.8.bb
@@ -5,7 +5,7 @@ LICENSE = "Artistic|GPL"
PRIORITY = "optional"
# We need gnugrep (for -I)
DEPENDS = "virtual/db perl-native grep-native"
-PR = "r23"
+PR = "r24"
# Major part of version
PVM = "5.8"
@@ -13,7 +13,7 @@ PVM = "5.8"
SRC_URI = "ftp://ftp.funet.fi/pub/CPAN/src/perl-${PV}.tar.gz \
file://Makefile.patch;patch=1 \
file://Makefile.SH.patch;patch=1 \
- file://makedepend-dash.patch;patch=1 \
+ file://makedepend-dash.patch;patch=1 \
file://installperl.patch;patch=1 \
file://perl-dynloader.patch;patch=1 \
file://perl-moreconfig.patch;patch=1 \
@@ -28,6 +28,7 @@ SRC_URI = "ftp://ftp.funet.fi/pub/CPAN/src/perl-${PV}.tar.gz \
file://60_debian_libnet_config_path.patch;patch=1 \
file://62_debian_cpan_definstalldirs.patch;patch=1 \
file://64_debian_enc2xs_inc.patch;patch=1 \
+ file://asm-pageh-fix.patch;patch=1 \
file://config.sh \
file://config.sh-32 \
file://config.sh-32-le \