aboutsummaryrefslogtreecommitdiffstats
path: root/packages/perl
diff options
context:
space:
mode:
authorJamie Lenehan <lenehan@twibble.org>2007-05-01 16:21:30 +0000
committerJamie Lenehan <lenehan@twibble.org>2007-05-01 16:21:30 +0000
commit9c4f5f2745e24cf8e99e63e345ed8408f0a7c06b (patch)
tree477fcf2ea4adb56ffdb8678c9b6bc531b409d164 /packages/perl
parent8b31361c55e8905332b9d2691ad81c05f51e905a (diff)
downloadopenembedded-9c4f5f2745e24cf8e99e63e345ed8408f0a7c06b.tar.gz
perl 5.8.8: Fix to tell bitbake about the perl module packages. I'd left out
the PACKAGES_DYNAMIC declaration for the perl modules. This declaration appears to be global though - so if either of the older perl versions exist it actually works - bitbake picks up the definition from the older recipes even though it isn't building them. This shows up as "No providers of runtime build target <x>" errors where x is a perl module. Thanks to Koen for figuring this one out.
Diffstat (limited to 'packages/perl')
-rw-r--r--packages/perl/perl_5.8.8.bb4
1 files changed, 3 insertions, 1 deletions
diff --git a/packages/perl/perl_5.8.8.bb b/packages/perl/perl_5.8.8.bb
index 7f2416162d..1f7751851d 100644
--- a/packages/perl/perl_5.8.8.bb
+++ b/packages/perl/perl_5.8.8.bb
@@ -5,7 +5,7 @@ LICENSE = "Artistic|GPL"
PRIORITY = "optional"
# We need gnugrep (for -I)
DEPENDS = "virtual/db perl-native grep-native"
-PR = "r9"
+PR = "r10"
# Major part of version
PVM = "5.8"
@@ -185,6 +185,8 @@ python populate_packages_prepend () {
do_split_packages(d, datadir, '(.*)\.(pm|pl|e2x)', 'perl-module-%s', 'perl module %s', recursive=True, allow_dirs=False, match_path=True)
}
+PACKAGES_DYNAMIC = "perl-module-*"
+
require perl-rdepends_${PV}.inc
require perl-rprovides.inc