aboutsummaryrefslogtreecommitdiffstats
path: root/packages/perl
diff options
context:
space:
mode:
authorJamie Lenehan <lenehan@twibble.org>2007-06-07 05:17:14 +0000
committerJamie Lenehan <lenehan@twibble.org>2007-06-07 05:17:14 +0000
commita5f0bf16d2273f5541bfeb0ccabf4a564fe0602f (patch)
tree2ea6b85ff275e4e25a87a6c6004470899cf5f184 /packages/perl
parent78c7219f57fbcfdd631c486d59fa96e8de4e6cab (diff)
downloadopenembedded-a5f0bf16d2273f5541bfeb0ccabf4a564fe0602f.tar.gz
perl-native 5.8.8: Fix for building with SSP-modified host gcc's, as
requested in bug #1980. Closes #1980.
Diffstat (limited to 'packages/perl')
-rw-r--r--packages/perl/perl-5.8.8/native-ssp.patch14
-rw-r--r--packages/perl/perl-native_5.8.8.bb5
2 files changed, 17 insertions, 2 deletions
diff --git a/packages/perl/perl-5.8.8/native-ssp.patch b/packages/perl/perl-5.8.8/native-ssp.patch
new file mode 100644
index 0000000000..f815aad452
--- /dev/null
+++ b/packages/perl/perl-5.8.8/native-ssp.patch
@@ -0,0 +1,14 @@
+Fix for compiling with ssp enabled gcc:
+See http://bugs.openembedded.org/show_bug.cgi?id=1980
+
+diff -Naur perl-5.8.7.orig/cflags.SH perl-5.8.7/cflags.SH
+--- perl-5.8.7.orig/cflags.SH 2002-09-30 10:59:07.000000000 +0000
++++ perl-5.8.7/cflags.SH 2005-10-02 04:08:39.000000000 +0000
+@@ -165,6 +165,8 @@
+ esac
+
+ : Can we perhaps use $ansi2knr here
++ [[ $file == regcomp ]] && export ccflags="${ccflags} -fno-stack-protector"
++ [[ $file == regexec ]] && export ccflags="${ccflags} -fno-stack-protector"
+ echo "$cc -c -DPERL_CORE $ccflags $optimize $warn"
+ eval "$also "'"$cc -DPERL_CORE -c $ccflags $optimize $warn"'
diff --git a/packages/perl/perl-native_5.8.8.bb b/packages/perl/perl-native_5.8.8.bb
index d4896daa12..dd9a581614 100644
--- a/packages/perl/perl-native_5.8.8.bb
+++ b/packages/perl/perl-native_5.8.8.bb
@@ -3,7 +3,7 @@ HOMEPAGE = "http://www.perl.org/"
SECTION = "libs"
LICENSE = "Artistic|GPL"
DEPENDS = "virtual/db-native gdbm-native"
-PR = "r10"
+PR = "r11"
FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/perl-${PV}"
@@ -14,7 +14,8 @@ SRC_URI = "http://ftp.funet.fi/pub/CPAN/src/perl-${PV}.tar.gz \
file://native-nopacklist.patch;patch=1 \
file://native-no-gdbminc.patch;patch=1 \
file://native-perlinc.patch;patch=1 \
- file://native-makedepend-dash.patch;patch=1"
+ file://native-makedepend-dash.patch;patch=1 \
+ file://native-ssp.patch;patch=1"
S = "${WORKDIR}/perl-${PV}"