aboutsummaryrefslogtreecommitdiffstats
path: root/packages/perl
diff options
context:
space:
mode:
authorJamie Lenehan <lenehan@twibble.org>2007-07-06 04:29:44 +0000
committerJamie Lenehan <lenehan@twibble.org>2007-07-06 04:29:44 +0000
commitebcf2e8a705159f9ff8f6817b4dc3be978595316 (patch)
treed17b5ae85116b7be35b4b9ea6c45d0bb9da5de91 /packages/perl
parent8809e54182b51dcc864765d075843150db5480c7 (diff)
downloadopenembedded-ebcf2e8a705159f9ff8f6817b4dc3be978595316.tar.gz
perl 5.8.8: A few host paths were being included in the perl for the target.
Update the sed magic to catch the files that were being missed. Closes #2575.
Diffstat (limited to 'packages/perl')
-rw-r--r--packages/perl/perl_5.8.8.bb14
1 files changed, 12 insertions, 2 deletions
diff --git a/packages/perl/perl_5.8.8.bb b/packages/perl/perl_5.8.8.bb
index 9df89222b9..a3873d99fb 100644
--- a/packages/perl/perl_5.8.8.bb
+++ b/packages/perl/perl_5.8.8.bb
@@ -5,7 +5,7 @@ LICENSE = "Artistic|GPL"
PRIORITY = "optional"
# We need gnugrep (for -I)
DEPENDS = "virtual/db perl-native grep-native"
-PR = "r24"
+PR = "r25"
# Major part of version
PVM = "5.8"
@@ -122,8 +122,18 @@ do_install() {
sed -i -e "s,${D},,g" \
-e "s,-isystem${STAGING_INCDIR} ,,g" \
-e "s,${STAGING_LIBDIR},${libdir},g" \
+ -e "s,${STAGING_BINDIR},${bindir},g" \
-e "s,${STAGING_INCDIR},${includedir},g" \
- ${D}/${libdir}/perl/${PV}/Config_heavy.pl
+ -e "s,${CROSS_DIR}${base_bindir}/,,g" \
+ ${D}${bindir}/h2xs \
+ ${D}${bindir}/h2ph \
+ ${D}${datadir}/perl/${PV}/pod/*.pod \
+ ${D}${datadir}/perl/${PV}/cacheout.pl \
+ ${D}${datadir}/perl/${PV}/FileCache.pm \
+ ${D}${libdir}/perl/${PV}/Config.pm \
+ ${D}${libdir}/perl/${PV}/Config_heavy.pl \
+ ${D}${libdir}/perl/${PV}/CORE/perl.h \
+ ${D}${libdir}/perl/${PV}/CORE/pp.h
fi
}
do_stage() {