aboutsummaryrefslogtreecommitdiffstats
path: root/packages/perl
diff options
context:
space:
mode:
authorJamie Lenehan <lenehan@twibble.org>2007-05-30 00:01:50 +0000
committerJamie Lenehan <lenehan@twibble.org>2007-05-30 00:01:50 +0000
commitf03de6e7b9bf301212f7219d32d17b74ef0c9a5d (patch)
treea360f49c20b69c7c8de46ef1623db555a54f6987 /packages/perl
parent87fd6c090376dd2a5e54177eaa41bd931007e617 (diff)
downloadopenembedded-f03de6e7b9bf301212f7219d32d17b74ef0c9a5d.tar.gz
perl: Add some more modules which I've been using locally incase someone
else happens to want to use them.
Diffstat (limited to 'packages/perl')
-rw-r--r--packages/perl/libextutils-depends-perl-native_0.205.bb5
-rw-r--r--packages/perl/libextutils-depends-perl_0.205.bb10
-rw-r--r--packages/perl/libextutils-pkgconfig-perl-native_1.07.bb5
-rw-r--r--packages/perl/libextutils-pkgconfig-perl_1.07.bb10
-rw-r--r--packages/perl/libhtml-mason-perl_1.35.bb35
5 files changed, 65 insertions, 0 deletions
diff --git a/packages/perl/libextutils-depends-perl-native_0.205.bb b/packages/perl/libextutils-depends-perl-native_0.205.bb
new file mode 100644
index 0000000000..e0216cbfb5
--- /dev/null
+++ b/packages/perl/libextutils-depends-perl-native_0.205.bb
@@ -0,0 +1,5 @@
+SECTION = "libs"
+
+inherit native
+
+require libextutils-depends-perl_${PV}.bb
diff --git a/packages/perl/libextutils-depends-perl_0.205.bb b/packages/perl/libextutils-depends-perl_0.205.bb
new file mode 100644
index 0000000000..274550dbd3
--- /dev/null
+++ b/packages/perl/libextutils-depends-perl_0.205.bb
@@ -0,0 +1,10 @@
+DESCRIPTION = "ExtUtils::Depends - Easily build XS extensions that depend on XS extensions"
+SECTION = "libs"
+LICENSE = "Artistic|GPL"
+PR = "r2"
+
+SRC_URI = "http://search.cpan.org/CPAN/authors/id/R/RM/RMCFARLA/Gtk2-Perl/ExtUtils-Depends-${PV}.tar.gz"
+
+S = "${WORKDIR}/ExtUtils-Depends-${PV}"
+
+inherit cpan
diff --git a/packages/perl/libextutils-pkgconfig-perl-native_1.07.bb b/packages/perl/libextutils-pkgconfig-perl-native_1.07.bb
new file mode 100644
index 0000000000..b5cd092dbd
--- /dev/null
+++ b/packages/perl/libextutils-pkgconfig-perl-native_1.07.bb
@@ -0,0 +1,5 @@
+SECTION = "libs"
+
+inherit native
+
+require libextutils-pkgconfig-perl_${PV}.bb
diff --git a/packages/perl/libextutils-pkgconfig-perl_1.07.bb b/packages/perl/libextutils-pkgconfig-perl_1.07.bb
new file mode 100644
index 0000000000..e0b807f374
--- /dev/null
+++ b/packages/perl/libextutils-pkgconfig-perl_1.07.bb
@@ -0,0 +1,10 @@
+DESCRIPTION = "ExtUtils::PkgConfig - simplistic interface to pkg-config"
+SECTION = "libs"
+LICENSE = "Artistic|GPL"
+PR = "r3"
+
+SRC_URI = "http://search.cpan.org/CPAN/authors/id/R/RM/RMCFARLA/Gtk2-Perl/ExtUtils-PkgConfig-${PV}.tar.gz"
+
+S = "${WORKDIR}/ExtUtils-PkgConfig-${PV}"
+
+inherit cpan
diff --git a/packages/perl/libhtml-mason-perl_1.35.bb b/packages/perl/libhtml-mason-perl_1.35.bb
new file mode 100644
index 0000000000..7b6ede5d49
--- /dev/null
+++ b/packages/perl/libhtml-mason-perl_1.35.bb
@@ -0,0 +1,35 @@
+SECTION = "libs"
+LICENSE = "Artistic|GPL"
+DEPENDS = "libexception-class-perl-native libparams-validate-perl-native \
+ libcache-cache-perl-native libclass-container-perl-native"
+RDEPENDS_${PN} = "libexception-class-perl libparams-validate-perl \
+ libcache-cache-perl libclass-container-perl perl-module-strict \
+ perl-module-warnings perl-module-file-basename perl-module-file-path \
+ perl-module-file-spec perl-module-file-spec-unix perl-module-file-temp \
+ perl-module-carp-heavy perl-module-io-handle perl-module-io \
+ perl-module-exporter-heavy perl-module-cwd perl-module-scalar-util \
+ perl-module-list-util perl-module-bytes perl-module-file-glob \
+ perl-module-data-dumper"
+PR = "r0"
+
+SRC_URI = "http://search.cpan.org/CPAN/authors/id/D/DR/DROLSKY/HTML-Mason-${PV}.tar.gz"
+
+S = "${WORKDIR}/HTML-Mason-${PV}"
+
+inherit cpan_build
+
+do_install_append () {
+ # Fix up paths to the perl interpreter
+ for i in ${D}${bindir}/*.pl; do
+ sed -i -e "s#${STAGING_BINDIR}/perl#${bindir}/perl#g" $i
+ done
+
+ # Install the html documentation and example files
+ install -m 0755 -d ${D}${docdir}/${PN}/html \
+ ${D}${docdir}/${PN}/examples/samples \
+ ${D}${docdir}/${PN}/examples/eg
+ cp -pRP ${S}/htdocs ${D}${docdir}/${PN}/html
+ cp -pRP ${S}/eg ${D}${docdir}/${PN}/examples/eg
+ cp -pRP ${S}/samples ${D}${docdir}/${PN}/examples/samples
+}
+