aboutsummaryrefslogtreecommitdiffstats
path: root/packages/perl
diff options
context:
space:
mode:
authorJamie Lenehan <lenehan@twibble.org>2007-04-30 04:10:56 +0000
committerJamie Lenehan <lenehan@twibble.org>2007-04-30 04:10:56 +0000
commitffc51060357ce21e555d9ed50042ccfa04286528 (patch)
tree9128e0846ec8c6837f24581935fa692e7aecf57b /packages/perl
parente24dc2b20fb661b1d804d180b3d0901e1254e679 (diff)
downloadopenembedded-ffc51060357ce21e555d9ed50042ccfa04286528.tar.gz
libxml-parser-perl: Add a dependency on expat-native and pass in the
appropriate libarary and include directories for exapt to the makefile. NOTE: This still doesn't work since it tries to use the host headers when linking to perl. Fixing this properly will need "perl" to be installed in the staging area (currently we stage perl-native only).
Diffstat (limited to 'packages/perl')
-rw-r--r--packages/perl/libxml-parser-perl_2.34.bb5
1 files changed, 4 insertions, 1 deletions
diff --git a/packages/perl/libxml-parser-perl_2.34.bb b/packages/perl/libxml-parser-perl_2.34.bb
index f6cbb4efbe..67ee0bd8de 100644
--- a/packages/perl/libxml-parser-perl_2.34.bb
+++ b/packages/perl/libxml-parser-perl_2.34.bb
@@ -1,11 +1,14 @@
SECTION = "libs"
LICENSE = "Artistic"
-PR = "r3"
+DEPENDS += "expat-native"
+PR = "r4"
SRC_URI = "http://www.cpan.org/modules/by-module/XML/XML-Parser-${PV}.tar.gz"
S = "${WORKDIR}/XML-Parser-${PV}"
+EXTRA_CPANFLAGS = "EXPATLIBPATH=${STAGING_LIBDIR} EXPATINCPATH=${STAGING_INCDIR}"
+
inherit cpan
FILES_${PN} = "${PERLLIBDIRS}/auto/XML/Parser/Expat/* \