aboutsummaryrefslogtreecommitdiffstats
path: root/packages/portabase
diff options
context:
space:
mode:
authornslu2-linux.adm@bkbits.net <nslu2-linux.adm@bkbits.net>2004-12-31 22:27:41 +0000
committernslu2-linux.adm@bkbits.net <nslu2-linux.adm@bkbits.net>2004-12-31 22:27:41 +0000
commit9c9c7139952b06112d99b5b11bfa3d36435a6459 (patch)
treefd0778f2b3d3d14f05cd4ff4b4cb341573e92d82 /packages/portabase
parentf73398ac656a31e2bbd214a3b2c3dc92eddaaecf (diff)
downloadopenembedded-9c9c7139952b06112d99b5b11bfa3d36435a6459.tar.gz
Merge bk://oe-devel.bkbits.net/openembedded
into bkbits.net:/repos/n/nslu2-linux/openembedded 2004/12/31 14:27:40-08:00 (none)!ggilbert Merge bk://oe-devel@oe-devel.bkbits.net/openembedded into olddog.(none):/home/ggilbert/oe/openembedded 2004/12/31 14:27:30-08:00 (none)!ggilbert Add many licenses 2004/12/31 21:28:22+00:00 nexus.co.uk!pb fix typo introduced with recent LICENSE patches 2004/12/31 21:12:38+00:00 nexus.co.uk!pb gpe-soundbite is GPL 2004/12/31 21:11:57+00:00 nexus.co.uk!pb gpe-question is GPL 2004/12/31 21:11:12+00:00 nexus.co.uk!pb gpe-nmf is GPL 2004/12/31 21:10:28+00:00 nexus.co.uk!pb gpe-gallery is GPL 2004/12/31 21:09:42+00:00 nexus.co.uk!pb gpe-edit is GPL 2004/12/31 21:07:12+00:00 nexus.co.uk!pb gpe-ownerinfo is GPL 2004/12/31 21:03:44+00:00 nexus.co.uk!pb delete old gpe-bootsplash with no LICENSE 2004/12/31 21:02:29+00:00 nexus.co.uk!pb delete some old gpe-clock versions with no LICENSE 2004/12/31 21:00:16+00:00 nexus.co.uk!pb delete old hotplug-dbus versions with no LICENSE 2004/12/31 20:59:20+00:00 nexus.co.uk!pb Merge bk://oe-devel@oe-devel.bkbits.net/openembedded into stealth.nexus.co.uk:/home/pb/oe/oe 2004/12/31 13:35:00-08:00 (none)!ggilbert Merge bk://oe-devel@oe-devel.bkbits.net/openembedded into olddog.(none):/home/ggilbert/oe/openembedded 2004/12/31 13:34:19-08:00 (none)!ggilbert More licenses 2004/12/31 20:59:03+00:00 nexus.co.uk!pb add LICENSE for gpe-confd, and blow away some old versions BKrev: 41d5d25dQOnhk1FZOyFZXNL3fxoihA
Diffstat (limited to 'packages/portabase')
-rw-r--r--packages/portabase/metakit_2.4.9.3.bb65
1 files changed, 65 insertions, 0 deletions
diff --git a/packages/portabase/metakit_2.4.9.3.bb b/packages/portabase/metakit_2.4.9.3.bb
index e69de29bb2..b36fd2c176 100644
--- a/packages/portabase/metakit_2.4.9.3.bb
+++ b/packages/portabase/metakit_2.4.9.3.bb
@@ -0,0 +1,65 @@
+SECTION = "libs"
+DESCRIPTION = "Metakit is an efficient embedded database library with a small \
+footprint. It fills the gap between flat-file, relational, object-oriented, and \
+tree-structured databases, supporting relational joins, serialization, nested structures,\
+and instant schema evolution."
+LICENSE = "MetaKit"
+HOMEPAGE = "http://www.equi4.com/metakit.html"
+SRC_URI = "http://www.equi4.com/pub/mk/metakit-${PV}.tar.gz \
+ file://metakit-2.4.9.3.patch;patch=1"
+PR = "r1"
+
+do_configure_prepend() {
+
+ cp ${STAGING_DATADIR}/libtool/* ${S}/unix/scripts/
+
+}
+do_configure () {
+
+ cd builds
+ ../unix/configure \
+ --build=${BUILD_SYS} \
+ --host=${HOST_SYS} \
+ --target=${TARGET_SYS} \
+ --prefix=${prefix} \
+ --exec_prefix=${exec_prefix} \
+ --bindir=${bindir} \
+ --sbindir=${sbindir} \
+ --libexecdir=${libexecdir} \
+ --datadir=${datadir} \
+ --sysconfdir=${sysconfdir} \
+ --sharedstatedir=${sharedstatedir} \
+ --localstatedir=${localstatedir} \
+ --libdir=${libdir} \
+ --includedir=${includedir} \
+ --oldincludedir=${oldincludedir} \
+ --infodir=${infodir} \
+ --mandir=${mandir} \
+ ${EXTRA_OECONF} \
+ $@;
+
+}
+
+
+do_stage() {
+# oe_libinstall -a -C builds/.libs libmk4 ${STAGING_LIBDIR}
+ cp builds/.libs/libmk4.a ${STAGING_LIBDIR}
+ install -d ${STAGING_INCDIR}/
+ for X in mk4.h mk4.inl
+ do
+ install -m 0644 include/${X} ${STAGING_INCDIR}/${X}
+ done
+
+}
+
+
+
+do_compile () {
+ cd builds
+ oe_runmake
+}
+
+do_install() {
+
+ :
+}