aboutsummaryrefslogtreecommitdiffstats
path: root/packages/postfix
diff options
context:
space:
mode:
authorJohn Bowler <jbowler@nslu2-linux.org>2005-11-11 07:15:36 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-11-11 07:15:36 +0000
commit1c60e3ea33243897f1159d617a0bf0fb9e5916f3 (patch)
tree9c07ba79b1bd4132216ca513c55faf5df5a74c66 /packages/postfix
parent82111b6f46d1afcb5d480fceaabc6822403e1867 (diff)
downloadopenembedded-1c60e3ea33243897f1159d617a0bf0fb9e5916f3.tar.gz
db: fix db3/db4 confusion by causing all packages to use virtual/db in db-4.3 4.3.29
- The SleepyCat implementation of the Berkeley DB exists in OE in two different - versions, 3.2 and 4.3. These appear to now be compatible (i.e. with the correct - settings db-4.3 can do everything db-3.2 can do and all packages compile with it). - The previous scheme of allowing both to be built (which was highly error prone) - has been removed and all db users now reference virtual/db. - Affects: - bogofilter, cyrus-*, openldap, perl, postfix, rpm
Diffstat (limited to 'packages/postfix')
-rw-r--r--packages/postfix/postfix-native_2.0.20.bb2
-rw-r--r--packages/postfix/postfix_2.0.20.bb13
2 files changed, 11 insertions, 4 deletions
diff --git a/packages/postfix/postfix-native_2.0.20.bb b/packages/postfix/postfix-native_2.0.20.bb
index 99a1d9fbaf..bf00fd832d 100644
--- a/packages/postfix/postfix-native_2.0.20.bb
+++ b/packages/postfix/postfix-native_2.0.20.bb
@@ -2,7 +2,7 @@ SECTION = "console/network"
include postfix_${PV}.bb
inherit native
FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/postfix-${PV}"
-DEPENDS = "db3-native pcre-native"
+DEPENDS = "virtual/db-native pcre-native"
export DIRS = "src/util src/global src/postconf"
do_stage () {
diff --git a/packages/postfix/postfix_2.0.20.bb b/packages/postfix/postfix_2.0.20.bb
index a676c3f809..4a11a002e3 100644
--- a/packages/postfix/postfix_2.0.20.bb
+++ b/packages/postfix/postfix_2.0.20.bb
@@ -1,7 +1,7 @@
SECTION = "console/network"
-DEPENDS = "db3 pcre postfix-native"
+DEPENDS = "virtual/db pcre postfix-native"
LICENSE = "IPL"
-PR = "r7"
+PR = "r8"
SRC_URI = "ftp://ftp.porcupine.org/mirrors/postfix-release/official/postfix-${PV}.tar.gz \
file://${FILESDIR}/makedefs.patch;patch=1 \
@@ -18,7 +18,14 @@ inherit update-rc.d
INITSCRIPT_NAME = "postfix"
INITSCRIPT_PARAMS = "start 58 3 4 5 . stop 13 0 1 6 ."
-export SYSLIBS = "-lpcre -ldb -lnsl -lresolv ${LDFLAGS}"
+#FIXME: this is broken because the native build won't work on systems where
+# native bdb does not require libpthread. ARM doesn't require libpthread
+# because it uses an assembler mutex implementation.
+LIBBDB_EXTRA = "-lpthread"
+LIBBDB_EXTRA_arm = ""
+LIBBDB_EXTRA_armeb = ""
+
+export SYSLIBS = "-lpcre -ldb ${LIBBDB_EXTRA} -lnsl -lresolv ${LDFLAGS}"
export EXPORT = "AUXLIBS='-lpcre' CCARGS='-DHAS_PCRE ${CFLAGS}' OPT='' DEBUG='-g'"
export CC_append = " -DHAS_PCRE ${CFLAGS}"
export EXTRA_OEMAKE = "-e"