aboutsummaryrefslogtreecommitdiffstats
path: root/packages/postfix
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2005-06-30 08:19:37 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-06-30 08:19:37 +0000
commitc8e5702127e507e82e6f68a4b8c546803accea9d (patch)
tree00583491f40ecc640f2b28452af995e3a63a09d7 /packages/postfix
parent87ec8ca4d2e2eb4d1c1e1e1a6b46a395d56805b9 (diff)
downloadopenembedded-c8e5702127e507e82e6f68a4b8c546803accea9d.tar.gz
import clean BK tree at cset 1.3670
Diffstat (limited to 'packages/postfix')
-rw-r--r--packages/postfix/.mtn2git_empty0
-rw-r--r--packages/postfix/postfix-2.0.20/.mtn2git_empty0
-rw-r--r--packages/postfix/postfix-2.0.20/install.patch63
-rw-r--r--packages/postfix/postfix-2.0.20/makedefs.patch16
-rw-r--r--packages/postfix/postfix-native_2.0.20.bb10
-rw-r--r--packages/postfix/postfix_2.0.20.bb23
6 files changed, 112 insertions, 0 deletions
diff --git a/packages/postfix/.mtn2git_empty b/packages/postfix/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/postfix/.mtn2git_empty
diff --git a/packages/postfix/postfix-2.0.20/.mtn2git_empty b/packages/postfix/postfix-2.0.20/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/postfix/postfix-2.0.20/.mtn2git_empty
diff --git a/packages/postfix/postfix-2.0.20/install.patch b/packages/postfix/postfix-2.0.20/install.patch
index e69de29bb2..baffcce0e8 100644
--- a/packages/postfix/postfix-2.0.20/install.patch
+++ b/packages/postfix/postfix-2.0.20/install.patch
@@ -0,0 +1,63 @@
+
+#
+# Patch managed by http://www.holgerschurig.de/patcher.html
+#
+
+--- postfix-2.0.15/postfix-install~install.patch
++++ postfix-2.0.15/postfix-install
+@@ -187,8 +187,8 @@
+ exit 1
+ }
+
+-test -x bin/postconf || {
+- echo $0: Error: no bin/postconf file. Did you forget to run \"make\"? 1>&2
++test -x $POSTCONF || {
++ echo $0: Error: no $POSTCONF file. Did you forget to run \"make\"? 1>&2
+ exit 1
+ }
+
+@@ -336,7 +336,7 @@
+
+ : ${install_root=/}
+ : ${tempdir=`pwd`}
+-: ${config_directory=`bin/postconf -h -d config_directory`}
++: ${config_directory=`$POSTCONF -h -d config_directory`}
+
+ # Find out the location of installed configuration files.
+
+@@ -399,7 +399,7 @@
+ case "$junk" in
+ "") eval unset $name;;
+ esac
+- eval : \${$name=\`bin/postconf -c $CONFIG_DIRECTORY -h $name\`} ||
++ eval : \${$name=\`$POSTCONF -c $CONFIG_DIRECTORY -h $name\`} ||
+ exit 1
+ done
+ }
+@@ -414,7 +414,7 @@
+ case "$junk" in
+ "") eval unset $name;;
+ esac
+- eval : \${$name=\`bin/postconf -d -h $name\`} || exit 1
++ eval : \${$name=\`$POSTCONF -d -h $name\`} || exit 1
+ done
+
+ # Override settings manually.
+@@ -521,6 +521,8 @@
+ SAMPLE_DIRECTORY=$install_root$sample_directory
+ README_DIRECTORY=$install_root$readme_directory
+
++test "x$POSTCONF" != "x" || POSTCONF="bin/postconf"
++
+ # Avoid repeated tests for existence of these; default permissions suffice.
+
+ test -d $DAEMON_DIRECTORY || mkdir -p $DAEMON_DIRECTORY || exit 1
+@@ -639,7 +641,7 @@
+ # Postfix releases, and software should not suddenly be installed in
+ # the wrong place when Postfix is being upgraded.
+
+-bin/postconf -c $CONFIG_DIRECTORY -e \
++$POSTCONF -c $CONFIG_DIRECTORY -e \
+ "daemon_directory = $daemon_directory" \
+ "command_directory = $command_directory" \
+ "queue_directory = $queue_directory" \
diff --git a/packages/postfix/postfix-2.0.20/makedefs.patch b/packages/postfix/postfix-2.0.20/makedefs.patch
index e69de29bb2..433b171e5a 100644
--- a/packages/postfix/postfix-2.0.20/makedefs.patch
+++ b/packages/postfix/postfix-2.0.20/makedefs.patch
@@ -0,0 +1,16 @@
+
+#
+# Patch managed by http://www.mn-logistik.de/unsupported/pxa250/patcher
+#
+
+--- postfix-2.0.15/makedefs~makedefs
++++ postfix-2.0.15/makedefs
+@@ -189,7 +189,7 @@
+ echo "No <db.h> include file found." 1>&2
+ echo "Install the appropriate db*-devel package first." 1>&2
+ echo "See the RELEASE_NOTES file for more information." 1>&2
+- exit 1
++ #exit 1
+ fi
+ # GDBM locks the DBM .pag file after open. This breaks postmap.
+ # if [ -f /usr/include/gdbm-ndbm.h ]
diff --git a/packages/postfix/postfix-native_2.0.20.bb b/packages/postfix/postfix-native_2.0.20.bb
index e69de29bb2..99a1d9fbaf 100644
--- a/packages/postfix/postfix-native_2.0.20.bb
+++ b/packages/postfix/postfix-native_2.0.20.bb
@@ -0,0 +1,10 @@
+SECTION = "console/network"
+include postfix_${PV}.bb
+inherit native
+FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/postfix-${PV}"
+DEPENDS = "db3-native pcre-native"
+export DIRS = "src/util src/global src/postconf"
+
+do_stage () {
+ install -m 0755 src/postconf/postconf ${STAGING_BINDIR}/
+}
diff --git a/packages/postfix/postfix_2.0.20.bb b/packages/postfix/postfix_2.0.20.bb
index e69de29bb2..483e95f19c 100644
--- a/packages/postfix/postfix_2.0.20.bb
+++ b/packages/postfix/postfix_2.0.20.bb
@@ -0,0 +1,23 @@
+SECTION = "console/network"
+DEPENDS = "db3 pcre postfix-native"
+LICENSE = "IPL"
+SRC_URI = "ftp://ftp.porcupine.org/mirrors/postfix-release/official/postfix-${PV}.tar.gz \
+ file://${FILESDIR}/makedefs.patch;patch=1 \
+ file://${FILESDIR}/install.patch;patch=1"
+S = "${WORKDIR}/postfix-${PV}"
+
+export SYSLIBS = "-lpcre -ldb -lnsl -lresolv ${LDFLAGS}"
+export EXPORT = "AUXLIBS='-lpcre' CCARGS='-DHAS_PCRE ${CFLAGS}' OPT='' DEBUG='-g'"
+export CC_append = " -DHAS_PCRE ${CFLAGS}"
+export EXTRA_OEMAKE = "-e"
+export POSTCONF = "${STAGING_BINDIR}/postconf"
+
+do_compile () {
+ unset CFLAGS CPPFLAGS CXXFLAGS
+ oe_runmake makefiles
+ oe_runmake
+}
+
+do_install () {
+ sh ./postfix-install 'install_root=${D}' -non-interactive
+}