aboutsummaryrefslogtreecommitdiffstats
path: root/packages/postgresql
diff options
context:
space:
mode:
authorMichael Krelin <hacker@klever.net>2007-05-11 20:05:46 +0000
committerMichael Krelin <hacker@klever.net>2007-05-11 20:05:46 +0000
commite33d6e440b7fec9542b21a86fbcc514490a28391 (patch)
tree062ad5b609cd49b7e21e0aca1168fd0e8339d0ed /packages/postgresql
parent71a31178ffd49ffe09ff010385b69a017a3cce86 (diff)
downloadopenembedded-e33d6e440b7fec9542b21a86fbcc514490a28391.tar.gz
postgresql: added 8.2.4
Diffstat (limited to 'packages/postgresql')
-rw-r--r--packages/postgresql/files/.mtn2git_empty0
-rw-r--r--packages/postgresql/files/no-ecpg-test.patch12
-rw-r--r--packages/postgresql/postgresql_8.2.4.bb20
3 files changed, 32 insertions, 0 deletions
diff --git a/packages/postgresql/files/.mtn2git_empty b/packages/postgresql/files/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/postgresql/files/.mtn2git_empty
diff --git a/packages/postgresql/files/no-ecpg-test.patch b/packages/postgresql/files/no-ecpg-test.patch
new file mode 100644
index 0000000000..c0f28f4258
--- /dev/null
+++ b/packages/postgresql/files/no-ecpg-test.patch
@@ -0,0 +1,12 @@
+diff --git a/src/interfaces/ecpg/Makefile b/src/interfaces/ecpg/Makefile
+index dcd578f..1428423 100644
+--- a/src/interfaces/ecpg/Makefile
++++ b/src/interfaces/ecpg/Makefile
+@@ -8,7 +8,6 @@ all install installdirs uninstall dep depend distprep:
+ $(MAKE) -C ecpglib $@
+ $(MAKE) -C compatlib $@
+ $(MAKE) -C preproc $@
+- $(MAKE) -C test $@
+
+ clean distclean maintainer-clean:
+ -$(MAKE) -C include $@
diff --git a/packages/postgresql/postgresql_8.2.4.bb b/packages/postgresql/postgresql_8.2.4.bb
new file mode 100644
index 0000000000..3f65a4fd0d
--- /dev/null
+++ b/packages/postgresql/postgresql_8.2.4.bb
@@ -0,0 +1,20 @@
+DESCRIPTION = "PostgreSQL is a powerful, open source relational database system."
+HOMEPAGE = "http://www.postgresql.com"
+LICENSE = "BSD"
+DEPENDS = "zlib readline"
+
+#WARNING: this recipe assumes you have the timezone compiler present in /usr/sbin/zic
+
+SRC_URI = "ftp://ftp.us.postgresql.org/pub/mirrors/postgresql/source/v${PV}/${P}.tar.bz2 \
+ file://no-ecpg-test.patch;patch=1"
+
+
+inherit autotools pkgconfig
+
+FILES_${PN}-doc += "${prefix}/doc/"
+
+do_compile_append() {
+cp /usr/sbin/zic ${S}/src/timezone/
+}
+
+DEFAULT_PREFERENCE = "-1"