aboutsummaryrefslogtreecommitdiffstats
path: root/packages/povray
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2008-08-14 08:47:23 +0000
committerKoen Kooi <koen@openembedded.org>2008-08-14 08:47:23 +0000
commit3fb15bea58c24989ae479b9e0017367ec3f548f4 (patch)
tree92b28feea0eb5632884a7378328b24d3cafb9134 /packages/povray
parent72ec66764b262ee5276861436ee3ebc2b5ef268f (diff)
downloadopenembedded-3fb15bea58c24989ae479b9e0017367ec3f548f4.tar.gz
povray: update to 3.7.0 beta 25b
Diffstat (limited to 'packages/povray')
-rw-r--r--packages/povray/povray-3.6.1+3.7.0-beta25b/.mtn2git_empty0
-rw-r--r--packages/povray/povray-3.6.1+3.7.0-beta25b/configure-cross-hack.patch42
-rw-r--r--packages/povray/povray-3.6.1+3.7.0-beta25b/gcc43.diff70
-rw-r--r--packages/povray/povray_3.6.1+3.7.0-beta25b.bb42
4 files changed, 154 insertions, 0 deletions
diff --git a/packages/povray/povray-3.6.1+3.7.0-beta25b/.mtn2git_empty b/packages/povray/povray-3.6.1+3.7.0-beta25b/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/povray/povray-3.6.1+3.7.0-beta25b/.mtn2git_empty
diff --git a/packages/povray/povray-3.6.1+3.7.0-beta25b/configure-cross-hack.patch b/packages/povray/povray-3.6.1+3.7.0-beta25b/configure-cross-hack.patch
new file mode 100644
index 0000000000..e0803bafac
--- /dev/null
+++ b/packages/povray/povray-3.6.1+3.7.0-beta25b/configure-cross-hack.patch
@@ -0,0 +1,42 @@
+--- /tmp/configure.ac 2008-08-14 01:13:37.000000000 +0200
++++ povray-3.7.0.beta.25b/configure.ac 2008-08-14 01:17:56.253198000 +0200
+@@ -357,8 +357,6 @@
+ AC_MSG_RESULT([yes])
+ AX_CHECK_LIB([z], [$required_libz_version], [z], [zlibVersion], [zlib.h], [zlibVersion()], [$with_zlib])
+ if test x"$ax_check_lib" != x"ok"; then
+- AC_MSG_ERROR([cannot find a suitable ZLIB library])
+- else
+ pov_libz=ok
+ fi
+ fi
+@@ -373,8 +371,6 @@
+ AC_MSG_RESULT([yes])
+ AX_CHECK_LIB([png], [$required_libpng_version], [png12 png], [png_get_libpng_ver], [png.h], [png_get_libpng_ver(NULL)], [$with_libpng])
+ if test x"$ax_check_lib" != x"ok"; then
+- AC_MSG_ERROR([cannot find a suitable PNG library])
+- else
+ pov_libpng=ok
+ fi
+ fi
+@@ -390,11 +386,9 @@
+ AC_MSG_RESULT([yes])
+ AX_CHECK_LIBJPEG([$required_libjpeg_version], [$with_libjpeg])
+ if test x"$ax_check_libjpeg" != x"ok"; then
+- AC_MSG_ERROR([cannot find a suitable JPEG library])
+- else
+ # create jversion.h in builddir
+ test -d "./source" || mkdir ./source
+- echo "#define JVERSION \"${ax_check_libjpeg_version}\"" > ./source/jversion.h
++ echo "#define JVERSION \"62\"" > ./source/jversion.h
+ pov_libjpeg=ok
+ fi
+ fi
+@@ -409,8 +403,6 @@
+ AC_MSG_RESULT([yes])
+ AX_CHECK_LIBTIFF([$required_libtiff_version], [$with_libtiff])
+ if test x"$ax_check_libtiff" != x"ok"; then
+- AC_MSG_ERROR([cannot find a suitable TIFF library])
+- else
+ pov_libtiff=ok
+ fi
+ fi
diff --git a/packages/povray/povray-3.6.1+3.7.0-beta25b/gcc43.diff b/packages/povray/povray-3.6.1+3.7.0-beta25b/gcc43.diff
new file mode 100644
index 0000000000..696dfb471f
--- /dev/null
+++ b/packages/povray/povray-3.6.1+3.7.0-beta25b/gcc43.diff
@@ -0,0 +1,70 @@
+--- /tmp/processoptions.cpp 2008-08-14 01:47:37.000000000 +0200
++++ povray-3.7.0.beta.25b/source/base/processoptions.cpp 2008-08-14 01:48:23.853198000 +0200
+@@ -90,6 +90,7 @@
+ *
+ *********************************************************************************/
+
++#include <cstring>
+ #include <cstdarg>
+ #include <cctype>
+
+--- /tmp/fileinputoutput.cpp 2008-08-14 01:49:16.000000000 +0200
++++ povray-3.7.0.beta.25b/source/base/fileinputoutput.cpp 2008-08-14 01:49:33.043198000 +0200
+@@ -90,6 +90,7 @@
+ *
+ *********************************************************************************/
+
++#include <cstring>
+ #include <cstdlib>
+ #include <cstdarg>
+
+--- /tmp/textstreambuffer.cpp 2008-08-14 01:52:07.000000000 +0200
++++ povray-3.7.0.beta.25b/source/base/textstreambuffer.cpp 2008-08-14 01:52:21.693198000 +0200
+@@ -90,6 +90,7 @@
+ *
+ *********************************************************************************/
+
++#include <cstring>
+ #include <algorithm>
+
+ #include "configbase.h"
+--- /tmp/fileinputoutput.h 2008-08-14 01:53:49.000000000 +0200
++++ povray-3.7.0.beta.25b/source/base/fileinputoutput.h 2008-08-14 01:54:07.213198000 +0200
+@@ -96,6 +96,7 @@
+ #include "base/types.h"
+ #include "base/path.h"
+
++#include <cstring>
+ #include <string>
+
+ namespace pov_base
+--- /tmp/configbase.h 2008-08-14 01:57:58.000000000 +0200
++++ povray-3.7.0.beta.25b/source/base/configbase.h 2008-08-14 01:58:12.373198000 +0200
+@@ -95,6 +95,7 @@
+ #ifndef CONFIGBASE_H
+ #define CONFIGBASE_H
+
++#include <climits>
+ #include "syspovconfigbase.h"
+
+ #ifndef DBL
+--- /tmp/unixoptions.cpp 2008-08-14 02:02:52.000000000 +0200
++++ povray-3.7.0.beta.25b/vfe/unix/unixoptions.cpp 2008-08-14 10:22:09.073198000 +0200
+@@ -454,13 +454,16 @@
+ char *errormsg =
+ "Cannot determine the current working directory.\n"
+ "Check that the PWD environment variable does exist and is valid.\n";
++ int no_error_call = 1;
+ if(no_error_call)
+ {
+ fprintf(stderr, "%s: %s\n", PACKAGE, errormsg);
+ exit(EXIT_FAILURE);
+ }
++#ifdef USE_ERROR
+ else
+- Error("%s", errormsg);
++ std::Error("%s", errormsg);
++#endif
+ }
+ #endif
+
diff --git a/packages/povray/povray_3.6.1+3.7.0-beta25b.bb b/packages/povray/povray_3.6.1+3.7.0-beta25b.bb
new file mode 100644
index 0000000000..6c1cf5fa05
--- /dev/null
+++ b/packages/povray/povray_3.6.1+3.7.0-beta25b.bb
@@ -0,0 +1,42 @@
+DESCRIPTION = "The Persistence of Vision Raytracer is a high-quality, totally free tool for creating stunning three-dimensional graphics. "
+HOMEPAGE = "http://www.povray.org"
+SECTION = "console/graphics"
+#Make this a weak assigment to allow branding of the povray binary
+LICENSE = "povray"
+DEPENDS = "virtual/libx11 boost zlib jpeg libpng tiff"
+RDEPENDS = ""
+
+#We apply a patch that subverts the checks for jpeg, zlib, png and tiff because we know OE has the required versions, but it is still a hack.
+SRC_URI = "http://www.povray.org/redirect/www.povray.org/beta/source/povray-src-3.7.0.beta.25b.tar.bz2 \
+ file://configure-cross-hack.patch;patch=1 \
+ file://gcc43.diff;patch=1 \
+ "
+
+S = "${WORKDIR}/povray-3.7.0.beta.25b"
+
+inherit autotools pkgconfig
+
+#PARALLEL_MAKE = ""
+
+EXTRA_OECONF = " --with-boost-thread=boost_thread-mt \
+ COMPILED_BY=${MAINTAINER} "
+
+PACKAGES += "${PN}-scenes ${PN}-ini ${PN}-icons ${PN}-scripts ${PN}-includes"
+
+PACKAGE_ARCH_${PN}-doc = "all"
+
+PACKAGE_ARCH_${PN}-scenes = "all"
+FILES_${PN}-scenes = "${datadir}/povray-3.7/scenes"
+
+PACKAGE_ARCH_${PN}-ini = "all"
+FILES_${PN}-ini = "${datadir}/povray-3.7/ini"
+
+PACKAGE_ARCH_${PN}-icons = "all"
+FILES_${PN}-icons = "${datadir}/povray-3.7/icons"
+
+PACKAGE_ARCH_${PN}-scripts = "all"
+FILES_${PN}-scripts = "${datadir}/povray-3.7/scripts"
+
+PACKAGE_ARCH_${PN}-includes = "all"
+FILES_${PN}-includes = "${datadir}/povray-3.7/include"
+