aboutsummaryrefslogtreecommitdiffstats
path: root/packages/powermanga
diff options
context:
space:
mode:
authornslu2-linux.adm@bkbits.net <nslu2-linux.adm@bkbits.net>2005-02-23 12:47:30 +0000
committernslu2-linux.adm@bkbits.net <nslu2-linux.adm@bkbits.net>2005-02-23 12:47:30 +0000
commitdba2b89720b0318a28ebe7778294873b9353f71d (patch)
tree9925d056023ab3aae0687bb17ab5fb27e3eaf513 /packages/powermanga
parenteea951fc35679b928aedc6214274de67c031ce12 (diff)
downloadopenembedded-dba2b89720b0318a28ebe7778294873b9353f71d.tar.gz
Merge bk://oe-devel.bkbits.net/openembedded
into bkbits.net:/repos/n/nslu2-linux/openembedded 2005/02/23 12:40:33+01:00 uni-frankfurt.de!mickeyl Merge bk://oe-devel@oe-devel.bkbits.net/openembedded into gandalf.tm.informatik.uni-frankfurt.de:/local/pkg/oe/packages 2005/02/23 12:36:37+01:00 uni-frankfurt.de!mickeyl Merge bk://oe-devel@oe-devel.bkbits.net/openembedded into gandalf.tm.informatik.uni-frankfurt.de:/local/pkg/oe/packages 2005/02/23 11:34:13+01:00 mn-solutions.de!schurig Merge http://oe-devel@openembedded.bkbits.net/openembedded into mnz66.mn-solutions.de:/usr/src/oe/p 2005/02/23 11:33:31+01:00 mn-solutions.de!schurig fix installation stage 2005/02/23 09:27:44+00:00 (none)!xora New upstream version of kismet, fixes for compilation problems, and change of maintainer with Brunos permission 2005/02/23 01:11:25+01:00 uni-frankfurt.de!mickeyl add a sharprom-compatible distro configuration. relies on an external 2.95.3 toolchain (for now... until someone adds it to OE) and needs further work. It's a start for someone interested though. 2005/02/23 01:09:23+01:00 uni-frankfurt.de!mickeyl bump cvsdate on oz-3.5.3 2005/02/22 17:37:44-06:00 ti.com!kergoth Fix the quilt PATCHCMD to stop rampantly chmod'ing, which made the CVS directories not executable, thereby screwing up the ability to rm -rf tmp. Thanks to holger freyther for pointing it out. BKrev: 421c7b62hBWfitoVhb3IO3ZT5nS71A
Diffstat (limited to 'packages/powermanga')
-rw-r--r--packages/powermanga/powermanga_0.79.bb38
1 files changed, 38 insertions, 0 deletions
diff --git a/packages/powermanga/powermanga_0.79.bb b/packages/powermanga/powermanga_0.79.bb
index e69de29bb2..36ebdddc2b 100644
--- a/packages/powermanga/powermanga_0.79.bb
+++ b/packages/powermanga/powermanga_0.79.bb
@@ -0,0 +1,38 @@
+DESCRIPTION = "Powermanga is an arcade 2D shoot-em-up game with 41 levels and more than 200 sprites."
+SECTION = "opie/games"
+PRIORITY = "optional"
+MAINTAINER = "Chris Lord <cwiiis@handhelds.org>"
+LICENSE = "GPL"
+DEPENDS = "libsdl-qpe libsdl-mixer"
+PR = "r1"
+
+SRC_URI = "http://linux.tlk.fr/games/Powermanga/download/powermanga-0.79.tgz \
+ file://linuxroutines.cpp \
+ file://pda-tweaks.patch;patch=1 \
+ file://powermanga.pro \
+ file://powermanga.png \
+ file://powermanga.desktop"
+
+S = ${WORKDIR}/${PN}-${PV}/
+
+inherit palmtop
+
+do_configure_prepend() {
+ mv ${WORKDIR}/linuxroutines.cpp ${S}/src/
+ mv ${WORKDIR}/powermanga.pro ${S}/
+ rm -f `find ${S}/ -name Makefile\*`
+ rm -f `find ${S}/ -name config\*`
+}
+
+do_install() {
+ install -d ${D}${palmtopdir}/bin \
+ ${D}${palmtopdir}/pics \
+ ${D}${palmtopdir}/apps/Games \
+ ${D}${palmtopdir}/share/games/powermanga/graphics \
+ ${D}${palmtopdir}/share/games/powermanga/sounds
+ install -m 0755 ${S}/src/powermanga ${D}${palmtopdir}/bin/powermanga
+ install -m 0644 ${WORKDIR}/powermanga.png ${D}${palmtopdir}/pics/powermanga.png
+ install -m 0644 ${WORKDIR}/powermanga.desktop ${D}${palmtopdir}/apps/Games/powermanga.desktop
+ install -m 0644 ${S}/graphics/* ${D}${palmtopdir}/share/games/powermanga/graphics/
+ install -m 0644 ${S}/sounds/* ${D}${palmtopdir}/share/games/powermanga/sounds/
+}