aboutsummaryrefslogtreecommitdiffstats
path: root/packages/powertop
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2007-05-13 12:29:15 +0000
committerKoen Kooi <koen@openembedded.org>2007-05-13 12:29:15 +0000
commit54f41deb80df2bb03543e93e85ee1e3ca8cc7e4e (patch)
tree8681fff9f7ac3733608d02d7543bb33cf206c070 /packages/powertop
parent057e3c4c22dfa2e2da87de5e4d8c4b924be55c5a (diff)
downloadopenembedded-54f41deb80df2bb03543e93e85ee1e3ca8cc7e4e.tar.gz
powertop: add 1.0
Power usage is a hot topic for computer users everywhere. For some, it's a matter of how long a laptop lasts without being plugged in. For others, it's controlling the temperature of hundreds of systems within a datacenter. For all of us, it's about keeping the electricity bill under control and being kind to the environment. Getting your computer to use the least amount of power can be problematic. This site provides information on reducing power usage, tips, and tricks for Intel-based computers running Linux*. As a first step, Intel is releasing PowerTOP, a tool that helps you find what software is using the most power. By fixing (or closing) these applications or processes, you can immediately see the power savings in the tool. You'll also see the estimated time left for battery power if you are running a laptop.
Diffstat (limited to 'packages/powertop')
-rw-r--r--packages/powertop/.mtn2git_empty0
-rw-r--r--packages/powertop/powertop_1.0.bb17
2 files changed, 17 insertions, 0 deletions
diff --git a/packages/powertop/.mtn2git_empty b/packages/powertop/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/powertop/.mtn2git_empty
diff --git a/packages/powertop/powertop_1.0.bb b/packages/powertop/powertop_1.0.bb
new file mode 100644
index 0000000000..a06397bfc4
--- /dev/null
+++ b/packages/powertop/powertop_1.0.bb
@@ -0,0 +1,17 @@
+DESCRIPTION = "PowerTOP, a tool that helps you find what software is using the most power."
+LICENSE = "GPLv2"
+
+SRC_URI = "http://www.linuxpowertop.org/download/powertop-${PV}.tar.gz"
+
+S = "${WORKDIR}/${PN}"
+
+
+do_compile() {
+ ${CC} -Wall -W -O1 -g powertop.c config.c -o powertop
+}
+
+do_install() {
+ install -d ${D}${bindir}
+ install -m 755 powertop ${D}${bindir}
+}
+