aboutsummaryrefslogtreecommitdiffstats
path: root/packages/ppp
diff options
context:
space:
mode:
authornslu2-linux.adm@bkbits.net <nslu2-linux.adm@bkbits.net>2004-12-28 22:18:35 +0000
committernslu2-linux.adm@bkbits.net <nslu2-linux.adm@bkbits.net>2004-12-28 22:18:35 +0000
commit6e5c4d23f5cb1ba9ed28894ca4d6a634e225314a (patch)
tree50ffceaa04f5b0fb0feea19a80d28fd3f5c359fc /packages/ppp
parentf91749f66496a291e4f6f610d58ec0ed90e2adf5 (diff)
downloadopenembedded-6e5c4d23f5cb1ba9ed28894ca4d6a634e225314a.tar.gz
Merge bk://oe-devel.bkbits.net/openembedded
into bkbits.net:/repos/n/nslu2-linux/openembedded 2004/12/28 16:38:28-05:00 handhelds.org!kergoth Merge oe-devel@oe-devel.bkbits.net:openembedded into handhelds.org:/home/kergoth/code/openembedded 2004/12/28 16:18:33-06:00 ti.com!kergoth Change CCLD to be identical to CC for the moment, so libtool's lack of CCLD awareness doesn't break things. 2004/12/28 22:09:49+01:00 dyndns.org!reenoo Merge oe-devel@oe-devel.bkbits.net:openembedded into sugarcube.dyndns.org:/home2/oe/bakery/openembedded 2004/12/28 22:09:29+01:00 dyndns.org!reenoo ppp(-dialin): fix ppp-dialin (and other uses of pppd) by making pppd suid root. 2004/12/28 21:59:53+01:00 uni-frankfurt.de!mickeyl Merge bk://oe-devel@oe-devel.bkbits.net/openembedded into r2d2.tm.informatik.uni-frankfurt.de:/local/pkg/oe/packages 2004/12/28 21:59:44+01:00 uni-frankfurt.de!mickeyl fix zbedic to 20041227 and add a qtopia17.patch BKrev: 41d1dbbb__VEbpAroY8Qu9r_OOB55g
Diffstat (limited to 'packages/ppp')
-rw-r--r--packages/ppp/ppp_2.4.1.bb40
1 files changed, 40 insertions, 0 deletions
diff --git a/packages/ppp/ppp_2.4.1.bb b/packages/ppp/ppp_2.4.1.bb
index e69de29bb2..7f4e58e107 100644
--- a/packages/ppp/ppp_2.4.1.bb
+++ b/packages/ppp/ppp_2.4.1.bb
@@ -0,0 +1,40 @@
+SECTION = "console/network"
+DESCRIPTION = "Point-to-Point Protocol (PPP) daemon"
+HOMEPAGE = "http://samba.org/ppp/"
+LICENSE = "BSD GPLv2"
+PR = "r4"
+
+SRC_URI = "ftp://ftp.samba.org/pub/ppp/ppp-2.4.1.tar.gz \
+ file://pppd.patch;patch=1 \
+ file://man.patch;patch=1 \
+ file://pon \
+ file://poff \
+ file://init \
+ file://ip-up \
+ file://ip-down"
+
+inherit autotools libtool
+
+EXTRA_OEMAKE = "STRIPPROG=${STRIP}"
+EXTRA_OECONF = --disable-strip
+
+do_install_append () {
+ install -d ${D}${bindir}/ ${D}${sysconfdir}/init.d
+ install -m 0755 ${WORKDIR}/pon ${D}${bindir}/pon
+ install -m 0755 ${WORKDIR}/poff ${D}${bindir}/poff
+ install -m 0755 ${WORKDIR}/init ${D}${sysconfdir}/init.d/ppp
+ install -m 0755 ${WORKDIR}/ip-up ${D}${sysconfdir}/ppp/
+ install -m 0755 ${WORKDIR}/ip-down ${D}${sysconfdir}/ppp/
+ install -d ${D}${sysconfdir}/ppp/ip-up.d/
+ install -d ${D}${sysconfdir}/ppp/ip-down.d/
+}
+
+CONFFILES_${PN}_nylon = "${sysconfdir}/ppp/pap-secrets ${sysconfdir}/ppp/chap-secrets"
+
+pkg_postinst() {
+if test "x$D" != "x"; then
+ exit 1
+else
+ chmod u+s /usr/sbin/pppd
+fi
+}