aboutsummaryrefslogtreecommitdiffstats
path: root/packages/prismstumbler
diff options
context:
space:
mode:
authorFlorian Boor <florian.boor@kernelconcepts.de>2007-03-31 23:12:47 +0000
committerFlorian Boor <florian.boor@kernelconcepts.de>2007-03-31 23:12:47 +0000
commitbe56d1922f1877037f1376870074360d8b5ea3d6 (patch)
treeb1c013466a55b5d347c3319e37fd3b7d09f86e7c /packages/prismstumbler
parent55ca5fa3f37ec2fd4c39a6eb8b51618896e45b8e (diff)
downloadopenembedded-be56d1922f1877037f1376870074360d8b5ea3d6.tar.gz
prismstumbler: add 0.7.4pre1
Diffstat (limited to 'packages/prismstumbler')
-rw-r--r--packages/prismstumbler/prismstumbler_0.7.4pre1.bb38
1 files changed, 38 insertions, 0 deletions
diff --git a/packages/prismstumbler/prismstumbler_0.7.4pre1.bb b/packages/prismstumbler/prismstumbler_0.7.4pre1.bb
new file mode 100644
index 0000000000..1cff5d90c6
--- /dev/null
+++ b/packages/prismstumbler/prismstumbler_0.7.4pre1.bb
@@ -0,0 +1,38 @@
+SECTION = "x11/network"
+PR = "r0"
+
+PACKAGES = "prismstumbler prismstumbler-frontend prismstumbler-doc"
+DESCRIPTION = "Prismstumbler wireless LAN scanner"
+DESCRIPTION_prismstumbler-frontend = "Prismstumbler wireless LAN scanner GTK frontend"
+LICENSE = "GPL"
+DEPENDS = "libpcap gtk+ wireless-tools sqlite zlib dbus-glib gpsd"
+RDEPENDS = "wireless-tools"
+RRECOMMENDS = "gpsd"
+
+SRC_URI = "http://projects.linuxtogo.org/frs/download.php/14/${PN}-${PV}.tar.gz"
+
+inherit autotools pkgconfig
+
+EXTRA_OECONF = "--x-includes=${STAGING_INCDIR}/X11 \
+ --x-libraries=${STAGING_LIBDIR} \
+ --with-libgps=${STAGING_DIR}/${HOST_SYS} \
+ --with-libpcap=${STAGING_DIR}/${HOST_SYS} \
+ --with-sqlite-includes=${STAGING_INCDIR} \
+ --with-sqlite-libs=${STAGING_LIBDIR} \
+ --without-athena --enable-dbus"
+
+CFLAGS =+ "-I${S}/include"
+LDFLAGS += "-lz"
+
+FILES_${PN} = "${bindir}/prismstumbler"
+
+FILES_prismstumbler-frontend = "${bindir}/psfront ${bindir}/pst \
+ ${datadir}/applications \
+ ${datadir}/pixmaps ${docdir}/prismstumbler/help.txt \
+ ${sysconfdir}"
+RDEPENDS_prismstumbler-frontend = "${PN}"
+
+
+do_install_append() {
+ chmod a+s ${D}${bindir}/prismstumbler
+}