aboutsummaryrefslogtreecommitdiffstats
path: root/packages/procps/procps-3.2.5
diff options
context:
space:
mode:
authorOyvind Repvik <nail@nslu2-linux.org>2005-08-03 02:59:03 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-08-03 02:59:03 +0000
commit013f194702c58b4c43cec0e41e4ea1712f2b3e06 (patch)
treec5e816e32567e550d735e8b4aed2f36c6fb9a799 /packages/procps/procps-3.2.5
parent9b171e726a64521ff495883ff96b76bbf49031af (diff)
downloadopenembedded-013f194702c58b4c43cec0e41e4ea1712f2b3e06.tar.gz
Fix lib64 issue (SlugBug #219)
Diffstat (limited to 'packages/procps/procps-3.2.5')
-rw-r--r--packages/procps/procps-3.2.5/install.patch52
1 files changed, 27 insertions, 25 deletions
diff --git a/packages/procps/procps-3.2.5/install.patch b/packages/procps/procps-3.2.5/install.patch
index a05eec4ab6..9f1ef6915d 100644
--- a/packages/procps/procps-3.2.5/install.patch
+++ b/packages/procps/procps-3.2.5/install.patch
@@ -1,25 +1,27 @@
-*** procps-3.2.5/Makefile.orig Sun Jul 24 03:29:32 2005
---- procps-3.2.5/Makefile Sun Jul 24 03:30:14 2005
-***************
-*** 211,220 ****
- ###### install
-
- $(BINFILES) : all
-! $(install) --mode a=rx $(notdir $@) $@
-
- $(MANFILES) : all
-! $(install) --mode a=r $(notdir $@) $@
-
- install: $(filter-out $(SKIP) $(addprefix $(DESTDIR),$(SKIP)),$(INSTALL))
- cd $(usr/bin) && $(ln_f) skill snice
---- 211,220 ----
- ###### install
-
- $(BINFILES) : all
-! $(install) -m 555 $(notdir $@) $@
-
- $(MANFILES) : all
-! $(install) -m 444 $(notdir $@) $@
-
- install: $(filter-out $(SKIP) $(addprefix $(DESTDIR),$(SKIP)),$(INSTALL))
- cd $(usr/bin) && $(ln_f) skill snice
+--- procps-3.2.5.virgin/Makefile 2005-01-26 05:55:26.000000000 +0100
++++ procps-3.2.5/Makefile 2005-08-03 04:55:26.346984488 +0200
+@@ -30,7 +30,10 @@
+ install := install -D --owner 0 --group 0
+
+ # Lame x86-64 /lib64 and /usr/lib64 abomination:
+-lib64 := lib$(shell [ -d /lib64 ] && echo 64)
++# lib64 := lib$(shell [ -d /lib64 ] && echo 64)
++
++# Equally lame hack to work around makefile lameness when the host arch is 64bit, but the target is not.
++lib64 := lib
+
+ usr/bin := $(DESTDIR)/usr/bin/
+ bin := $(DESTDIR)/bin/
+@@ -211,10 +214,10 @@
+ ###### install
+
+ $(BINFILES) : all
+- $(install) --mode a=rx $(notdir $@) $@
++ $(install) -m 555 $(notdir $@) $@
+
+ $(MANFILES) : all
+- $(install) --mode a=r $(notdir $@) $@
++ $(install) -m 444 $(notdir $@) $@
+
+ install: $(filter-out $(SKIP) $(addprefix $(DESTDIR),$(SKIP)),$(INSTALL))
+ cd $(usr/bin) && $(ln_f) skill snice