aboutsummaryrefslogtreecommitdiffstats
path: root/packages/psplash
diff options
context:
space:
mode:
authorPaul Sokolovsky <pmiscml@gmail.com>2007-12-26 01:26:04 +0000
committerPaul Sokolovsky <pmiscml@gmail.com>2007-12-26 01:26:04 +0000
commit272c406884fa6619b3c8f3d78d51fb259dafa3be (patch)
tree90fee004f964f0c6c2ca0013de644affdd7062cf /packages/psplash
parentd717570ad180da61707b73127a76ac724b791483 (diff)
downloadopenembedded-272c406884fa6619b3c8f3d78d51fb259dafa3be.tar.gz
psplash svn: Use standard OE init.d library for machine detection.
* Fixes #3471.
Diffstat (limited to 'packages/psplash')
-rw-r--r--packages/psplash/files/psplash-init11
-rw-r--r--packages/psplash/psplash_svn.bb3
2 files changed, 10 insertions, 4 deletions
diff --git a/packages/psplash/files/psplash-init b/packages/psplash/files/psplash-init
index 5587346cb1..7f7eb36fbe 100644
--- a/packages/psplash/files/psplash-init
+++ b/packages/psplash/files/psplash-init
@@ -9,10 +9,14 @@ for x in $(cat /proc/cmdline); do
esac
done
+. /etc/init.d/functions
+
psplash_args=''
-case "`grep ^Hardware /proc/cpuinfo|cut -d: -f2 |tr A-Z a-z`" in
- "hp ipaq h3100"|"hp ipaq h3800") pspash_args='-a 90' ;;
- "hp ipaq 3600"|"hp ipaq 3700"|"hp ipaq h3900"|"htc universal"|*collie|*poodle|*akita|*spitz|*borzoi) psplash_args='-a 270' ;;
+case `machine_id` in
+ "hp_ipaq_h3100"|"hp_ipaq_h3800")
+ pspash_args='-a 90' ;;
+ "hp_ipaq_3600"|"hp_ipaq_3700"|"hp_ipaq_h3900"|"htc_universal"|*collie|*poodle|*akita|*spitz|*borzoi)
+ psplash_args='-a 270' ;;
esac
export TMPDIR=/mnt/.psplash
@@ -20,4 +24,5 @@ mount tmpfs -t tmpfs $TMPDIR -o,size=40k
/usr/bin/psplash $psplash_args &
+# Timetrap against hanging with splash hiding console messages.
(sleep 120; psplash-write "QUIT") &
diff --git a/packages/psplash/psplash_svn.bb b/packages/psplash/psplash_svn.bb
index cf6e228d92..17b459a15f 100644
--- a/packages/psplash/psplash_svn.bb
+++ b/packages/psplash/psplash_svn.bb
@@ -3,7 +3,8 @@ HOMEPAGE = "http://projects.o-hand.com/psplash"
SECTION = "base"
LICENSE = "GPL"
PV = "0.0+svnr${SRCREV}"
-PR = "r11"
+PR = "r12"
+RDEPENDS = "initscripts"
# You can create your own pslash-hand-img.h by doing
# ./make-image-header.sh <file>.png HAND