aboutsummaryrefslogtreecommitdiffstats
path: root/packages/psplash
diff options
context:
space:
mode:
authorMichael Krelin <hacker@klever.net>2007-05-07 21:58:16 +0000
committerMichael Krelin <hacker@klever.net>2007-05-07 21:58:16 +0000
commit518527b6271e8f0adf22ba8a69984047ed238228 (patch)
tree67254ea3e926a4ff35316a7cb0a06d38a9f6222c /packages/psplash
parent1c484102d87944ebda3f30bcffce3e788cfe0cf3 (diff)
downloadopenembedded-518527b6271e8f0adf22ba8a69984047ed238228.tar.gz
packages/psplash: added psplash-zap package with initscript to quit psplash before going for login prompt on console image.
Diffstat (limited to 'packages/psplash')
-rw-r--r--packages/psplash/files/zzapsplash-init4
-rw-r--r--packages/psplash/psplash-zap_1.0.bb13
2 files changed, 17 insertions, 0 deletions
diff --git a/packages/psplash/files/zzapsplash-init b/packages/psplash/files/zzapsplash-init
new file mode 100644
index 0000000000..5a713e5701
--- /dev/null
+++ b/packages/psplash/files/zzapsplash-init
@@ -0,0 +1,4 @@
+#!/bin/sh
+TMPDIR=/mnt/.psplash psplash-write "QUIT" || true
+sleep 1
+umount /mnt/.psplash >/dev/null 2>/dev/null
diff --git a/packages/psplash/psplash-zap_1.0.bb b/packages/psplash/psplash-zap_1.0.bb
new file mode 100644
index 0000000000..58fa3ed52b
--- /dev/null
+++ b/packages/psplash/psplash-zap_1.0.bb
@@ -0,0 +1,13 @@
+
+SRC_URI = "file://zzapsplash-init"
+
+do_install_prepend() {
+ install -d "${D}${sysconfdir}/init.d/"
+ install -m 0755 "${WORKDIR}/zzapsplash-init" "${D}${sysconfdir}/init.d/zzapsplash"
+}
+
+inherit update-rc.d
+
+INITSCRIPT_NAME = "zzapsplash"
+INITSCRIPT_PARAMS = "start 99 5 S ."
+