aboutsummaryrefslogtreecommitdiffstats
path: root/packages/psplash
diff options
context:
space:
mode:
authorMichael Krelin <hacker@klever.net>2007-05-07 00:15:58 +0000
committerMichael Krelin <hacker@klever.net>2007-05-07 00:15:58 +0000
commit5a9f53c93da41fe05be3cd1ec53df79c77add595 (patch)
tree4e8efda2bd7663323c5cc0cdfcb68ee95bff74c4 /packages/psplash
parentb80b73d95c8885788b3e7edd3d75d09f47830c63 (diff)
downloadopenembedded-5a9f53c93da41fe05be3cd1ec53df79c77add595.tar.gz
psplash: adjust the rotation angle in the initscript according to the machine being used. Should fix #2149
Diffstat (limited to 'packages/psplash')
-rw-r--r--packages/psplash/files/psplash-init9
-rw-r--r--packages/psplash/psplash_svn.bb2
2 files changed, 8 insertions, 3 deletions
diff --git a/packages/psplash/files/psplash-init b/packages/psplash/files/psplash-init
index a966638074..2bd83cfb07 100644
--- a/packages/psplash/files/psplash-init
+++ b/packages/psplash/files/psplash-init
@@ -9,8 +9,13 @@ for x in $(cat /proc/cmdline); do
esac
done
+psplash_args=''
+case "`grep ^Hardware /proc/cpuinfo|cut -d: -f2 |tr A-Z a-z`" in
+ "hp ipaq h3100"|"hp ipaq h3800") pspash_args='-a 90' ;;
+ "hp ipaq 3600"|"hp ipaq 3700"|"hp ipaq h3900"|"htc universal"|*collie|*poodle|*akita|*spitz|*borzoi) psplash_args='-a 270' ;;
+esac
+
export TMPDIR=/mnt/.psplash
mount tmpfs -t tmpfs $TMPDIR -o,size=40k
-/usr/bin/psplash &
-
+/usr/bin/psplash $psplash_args &
diff --git a/packages/psplash/psplash_svn.bb b/packages/psplash/psplash_svn.bb
index eebe2179da..6b51d33597 100644
--- a/packages/psplash/psplash_svn.bb
+++ b/packages/psplash/psplash_svn.bb
@@ -3,7 +3,7 @@ SECTION = "base"
LICENSE = "GPL"
PV = "0.0+svn${SRCDATE}"
-PR = "r2"
+PR = "r3"
# You can create your own pslash-hand-img.h by doing
# ./make-image-header.sh <file>.png HAND