aboutsummaryrefslogtreecommitdiffstats
path: root/packages/psplash
diff options
context:
space:
mode:
authorGraeme Gregory <dp@xora.org.uk>2007-12-06 11:59:27 +0000
committerGraeme Gregory <dp@xora.org.uk>2007-12-06 11:59:27 +0000
commit69af5c3889e0ebe7ee5c4921cab5cf8c4e3a09dd (patch)
treeb6d314fccd79daa8379a00666810497d595fd139 /packages/psplash
parentee1b83d05c96199a45b53840e96eafc6dec33d6e (diff)
downloadopenembedded-69af5c3889e0ebe7ee5c4921cab5cf8c4e3a09dd.tar.gz
psplash_svn.bb : rediff openmoko patch
Diffstat (limited to 'packages/psplash')
-rw-r--r--packages/psplash/files/configurability.patch46
-rw-r--r--packages/psplash/psplash_svn.bb2
2 files changed, 23 insertions, 25 deletions
diff --git a/packages/psplash/files/configurability.patch b/packages/psplash/files/configurability.patch
index b923cb24f1..c9688655c9 100644
--- a/packages/psplash/files/configurability.patch
+++ b/packages/psplash/files/configurability.patch
@@ -1,8 +1,8 @@
Index: psplash/psplash.c
===================================================================
---- psplash.orig/psplash.c
-+++ psplash/psplash.c
-@@ -44,17 +44,17 @@ psplash_draw_msg (PSplashFB *fb, const c
+--- psplash.orig/psplash.c 2007-12-06 11:14:23.000000000 +0000
++++ psplash/psplash.c 2007-12-06 11:19:12.000000000 +0000
+@@ -44,17 +44,17 @@
/* Clear */
@@ -27,7 +27,7 @@ Index: psplash/psplash.c
&radeon_font,
msg);
}
-@@ -66,36 +66,36 @@ psplash_draw_progress (PSplashFB *fb, in
+@@ -66,36 +66,36 @@
/* 4 pix border */
x = ((fb->width - BAR_IMG_WIDTH)/2) + 4 ;
@@ -75,7 +75,7 @@ Index: psplash/psplash.c
{
char *command;
int parsed=0;
-@@ -103,21 +103,21 @@ parse_command (PSplashFB *fb, char *stri
+@@ -103,21 +103,21 @@
parsed = strlen(string)+1;
DBG("got cmd %s", string);
@@ -103,7 +103,7 @@ Index: psplash/psplash.c
{
return 1;
}
-@@ -125,8 +125,8 @@ parse_command (PSplashFB *fb, char *stri
+@@ -125,8 +125,8 @@
return 0;
}
@@ -114,7 +114,7 @@ Index: psplash/psplash.c
{
int err;
ssize_t length = 0;
-@@ -143,14 +143,14 @@ psplash_main (PSplashFB *fb, int pipe_fd
+@@ -143,14 +143,14 @@
end = command;
@@ -133,7 +133,7 @@ Index: psplash/psplash.c
{
/*
if (errno == EINTR)
-@@ -158,29 +158,29 @@ psplash_main (PSplashFB *fb, int pipe_fd
+@@ -158,29 +158,29 @@
*/
return;
}
@@ -171,7 +171,7 @@ Index: psplash/psplash.c
FD_ZERO(&descriptors);
FD_SET(pipe_fd,&descriptors);
}
-@@ -188,14 +188,14 @@ psplash_main (PSplashFB *fb, int pipe_fd
+@@ -188,14 +188,14 @@
return;
}
@@ -189,7 +189,7 @@ Index: psplash/psplash.c
signal(SIGHUP, psplash_exit);
signal(SIGINT, psplash_exit);
signal(SIGQUIT, psplash_exit);
-@@ -214,10 +214,10 @@ main (int argc, char** argv)
+@@ -214,10 +214,10 @@
angle = atoi(argv[i]);
continue;
}
@@ -203,7 +203,7 @@ Index: psplash/psplash.c
argv[0]);
exit(-1);
}
-@@ -231,7 +231,7 @@ main (int argc, char** argv)
+@@ -231,7 +231,7 @@
if (mkfifo(PSPLASH_FIFO, S_IRUSR | S_IWUSR | S_IRGRP | S_IWGRP))
{
@@ -212,7 +212,7 @@ Index: psplash/psplash.c
{
perror("mkfifo");
exit(-1);
-@@ -239,8 +239,8 @@ main (int argc, char** argv)
+@@ -239,8 +239,8 @@
}
pipe_fd = open (PSPLASH_FIFO,O_RDONLY|O_NONBLOCK);
@@ -223,22 +223,20 @@ Index: psplash/psplash.c
{
perror("pipe open");
exit(-2);
-@@ -252,30 +252,30 @@ main (int argc, char** argv)
- if ((fb = psplash_fb_new(angle)) == NULL)
+@@ -253,29 +253,29 @@
exit(-1);
-- /* Clear the background with #ecece1 */
+ /* Clear the background with #ecece1 */
- psplash_fb_draw_rect (fb, 0, 0, fb->width, fb->height, 0xec, 0xec, 0xe1);
-+ /* Clear the background */
+ psplash_fb_draw_rect (fb, 0, 0, fb->width, fb->height, PSPLASH_BACKGROUND_COLOR_R, PSPLASH_BACKGROUND_COLOR_G, PSPLASH_BACKGROUND_COLOR_B);
/* Draw the OH logo */
- psplash_fb_draw_image (fb,
- (fb->width - HAND_IMG_WIDTH)/2,
-- (fb->height - HAND_IMG_HEIGHT)/2,
+- ((fb->height * 5) / 6 - HAND_IMG_HEIGHT)/2,
+ psplash_fb_draw_image (fb,
-+ (fb->width - HAND_IMG_WIDTH)/2,
-+ (fb->height - HAND_IMG_HEIGHT)/2,
++ (fb->width - HAND_IMG_WIDTH)/2,
++ (fb->height - HAND_IMG_HEIGHT)/2,
HAND_IMG_WIDTH,
HAND_IMG_HEIGHT,
HAND_IMG_BYTES_PER_PIXEL,
@@ -249,8 +247,8 @@ Index: psplash/psplash.c
- (fb->width - BAR_IMG_WIDTH)/2,
- fb->height - (fb->height/6),
+ psplash_fb_draw_image (fb,
-+ (fb->width - BAR_IMG_WIDTH)/2,
-+ fb->height - (fb->height/PSPLASH_PROGRESS_DIVIDER),
++ (fb->width - BAR_IMG_WIDTH)/2,
++ fb->height - (fb->height/PSPLASH_PROGRESS_DIVIDER),
BAR_IMG_WIDTH,
BAR_IMG_HEIGHT,
BAR_IMG_BYTES_PER_PIXEL,
@@ -266,9 +264,9 @@ Index: psplash/psplash.c
Index: psplash/psplash.h
===================================================================
---- psplash.orig/psplash.h
-+++ psplash/psplash.h
-@@ -54,6 +54,21 @@ typedef int bool;
+--- psplash.orig/psplash.h 2007-12-06 11:15:35.000000000 +0000
++++ psplash/psplash.h 2007-12-06 11:15:45.000000000 +0000
+@@ -54,6 +54,21 @@
#define TRUE 1
#endif
diff --git a/packages/psplash/psplash_svn.bb b/packages/psplash/psplash_svn.bb
index 398141de69..cf6e228d92 100644
--- a/packages/psplash/psplash_svn.bb
+++ b/packages/psplash/psplash_svn.bb
@@ -3,7 +3,7 @@ HOMEPAGE = "http://projects.o-hand.com/psplash"
SECTION = "base"
LICENSE = "GPL"
PV = "0.0+svnr${SRCREV}"
-PR = "r10"
+PR = "r11"
# You can create your own pslash-hand-img.h by doing
# ./make-image-header.sh <file>.png HAND