aboutsummaryrefslogtreecommitdiffstats
path: root/packages/psplash
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2006-10-10 22:44:27 +0000
committerKoen Kooi <koen@openembedded.org>2006-10-10 22:44:27 +0000
commit7624978966ae9b70ef1138c0f4729692c4cf4345 (patch)
tree41127804d85666c921de7d28855f3fa44c39f293 /packages/psplash
parentcf799ae1fa268a365d5030d02a8a36f2e52788c4 (diff)
downloadopenembedded-7624978966ae9b70ef1138c0f4729692c4cf4345.tar.gz
psplash: add psplash from poky
sane-srcdates: lock down psplash to today
Diffstat (limited to 'packages/psplash')
-rw-r--r--packages/psplash/.mtn2git_empty0
-rw-r--r--packages/psplash/files/.mtn2git_empty0
-rw-r--r--packages/psplash/files/psplash-init6
-rw-r--r--packages/psplash/psplash_svn.bb23
4 files changed, 29 insertions, 0 deletions
diff --git a/packages/psplash/.mtn2git_empty b/packages/psplash/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/psplash/.mtn2git_empty
diff --git a/packages/psplash/files/.mtn2git_empty b/packages/psplash/files/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/psplash/files/.mtn2git_empty
diff --git a/packages/psplash/files/psplash-init b/packages/psplash/files/psplash-init
new file mode 100644
index 0000000000..3a5cb653aa
--- /dev/null
+++ b/packages/psplash/files/psplash-init
@@ -0,0 +1,6 @@
+#!/bin/sh
+
+export TMPDIR=/mnt/.psplash
+mount tmpfs -t tmpfs $TMPDIR -o,size=40k
+
+/usr/bin/psplash &
diff --git a/packages/psplash/psplash_svn.bb b/packages/psplash/psplash_svn.bb
new file mode 100644
index 0000000000..f5e2195e82
--- /dev/null
+++ b/packages/psplash/psplash_svn.bb
@@ -0,0 +1,23 @@
+DESCRIPTION = "Userspace framebuffer boot logo based on usplash."
+SECTION = "base"
+LICENSE = "GPL"
+
+PV = "0.0+svn${SRCDATE}"
+
+SRC_URI = "svn://svn.o-hand.com/repos/misc/trunk;module=psplash;proto=http \
+ file://psplash-init"
+
+S = "${WORKDIR}/psplash"
+
+inherit autotools pkgconfig update-rc.d
+
+FILES_${PN} += "/mnt/.psplash"
+
+do_install_prepend() {
+ install -d ${D}/mnt/.psplash/
+ install -d ${D}${sysconfdir}/init.d/
+ install -m 0755 ${WORKDIR}/psplash-init ${D}${sysconfdir}/init.d/psplash
+}
+
+INITSCRIPT_NAME = "psplash"
+INITSCRIPT_PARAMS = "start 0 S . stop 20 0 1 6 ."